+ Responder ao Tópico



  1. #1
    max_mori
    Visitante

    Padrão iptables -t nat -A PREROUTING estao corretas

    $iptables -t nat -A PREROUTING -i eth1 -p tcp -m multiport --dport 21,22,25,53,80,110 -j REDIRECT -i eth0 --to-port 3128 #eth0 local
    $iptables -t nat -A PREROUTING -i eth1 -p tcp -m multiport --dport 21,22,25,53,80,110,6588 -j DNAT --to 192.168.0.2:3128

  2. #2

    Padrão iptables -t nat -A PREROUTING estao corretas

    oq vc ta querendo fazer... redirecionar tudo para o squid....???



  3. #3

    Padrão iptables -t nat -A PREROUTING estao corretas

    sintaticamente correto, logicamente incorreto, se é que voce me entende.

    afinal, o que voce quer fazer? voce esta dando a solucao e nao o problema, fica dificil avaliar.

  4. #4
    gmlinux
    Visitante

    Padrão iptables -t nat -A PREROUTING estao corretas

    Squid NÃO é proxy de ftp-control (21), ssh (22), smtp (25), DNS(53) e pop (110), se é que você redirecionou para esta porta por existir um squid lá....



  5. #5
    max_mori
    Visitante

    Padrão iptables -t nat -A PREROUTING estao corretas

    é que não estou conseguindo fazer com que o proxy funcione pensei que era um problema do iptables.

    mas quanto ao script abaixo do squid
    ok??



    visible_hostname athlon2000
    http_port 3128
    httpd_accel_port 3128
    cache_mem 5 MB
    maximum_object_size 4096 KB
    httpd_accel_host virtual
    httpd_accel_with_proxy on
    httpd_accel_uses_host_header on

    acl all src 192.168.0.2
    http_access allow all

    acl maquina1 src 192.168.0.1
    http_access allow maquina1

    acl SSL_port port 443 563 # https, news
    acl Safe_port port 80 # http
    acl Safe_port port 21 # ftp
    acl Safe_port port 443 563 # https, news

  6. #6
    max_mori
    Visitante

    Padrão iptables -t nat -A PREROUTING estao corretas

    2005/03/12 15:56:22| With 1024 file descriptors available
    2005/03/12 15:56:22| DNS Socket created at 0.0.0.0, port 32779, FD 4
    FATAL: Could not find any nameservers.
    Please check your /etc/resolv.conf file
    or use the 'dns_nameservers' option in squid.conf.
    Squid Cache (Version 2.5.STABLE3): Terminated abnormally.
    CPU Usage: 0.000 seconds = 0.000 user + 0.000 sys
    Maximum Resident Size: 0 KB
    Page faults with physical i/o: 359



  7. #7
    gmlinux
    Visitante

    Padrão iptables -t nat -A PREROUTING estao corretas

    o que tem no seu /etc/resolv.conf?

  8. #8
    max_mori
    Visitante

    Padrão iptables -t nat -A PREROUTING estao corretas

    não tem nada no arquivo.

    O que deveria ter??



  9. #9
    gmlinux
    Visitante

    Padrão iptables -t nat -A PREROUTING estao corretas

    Este arquivo lista os servidores usados para resolução de nomes (DNS servers), ou pelo menos deveria

  10. #10
    max_mori
    Visitante

    Padrão iptables -t nat -A PREROUTING estao corretas

    os DNS vedem ser o do provedor de internet (speedy)
    ou DNS interno


    se for o interno como???



  11. #11
    max_mori
    Visitante

    Padrão iptables -t nat -A PREROUTING estao corretas

    Arquivos /etc/HOSTNAME e /etc/resolv.conf


    O arquivo /etc/HOSTNAME contém o nome (hostname) de seu micro. O arquivo /etc/resolv.conf conterá informação sobre o Servidor de Nomes (DNS) do seu provedor de acesso.


    1. Arquivo /etc/HOSTNAME


    Você pode escolher o nome e o domínio de seu micro. A título de exemplo, vou escolher bh como nome e minas.br como domínio; assim, o arquivo /etc/HOSTNAME conterá apenas a seguinte linha:


    bh.minas.br


    2. Arquivo /etc/resolv.conf


    Você precisa obter de seu provedor de acesso o número IP do servidor DNS. A linha domain abaixo especifica o domínio que você escolheu para o seu micro. As linhas search especificam em qual (ou quais) domínio(s) procurar um host caso não se especifique o correspondente domínio do mesmo. A linha mais importante, para o nosso caso, é a última (nameserver): você deve substituir o número IP 200.238.239.3 pelo número IP do servidor DNS de seu provedor de acesso.


    Assim, o arquivo /etc/resolv.conf de nosso exemplo ficará:


    domain minas.br
    search speedmax.com.br meudominio.com.br
    nameserver 200.211.222.130

  12. #12

    Padrão iptables -t nat -A PREROUTING estao corretas

    Citação Postado originalmente por max_mori
    FATAL: Could not find any nameservers.
    Please check your /etc/resolv.conf file
    or use the 'dns_nameservers' option in squid.conf.
    02 opcoes:
    [a] ter DNS no resolv.conf
    [b] definir DNS na linha
    dns_nameservers 200.204.0.10 200.204.0.138 (exemplo)



  13. #13
    max_mori
    Visitante

    Padrão iptables -t nat -A PREROUTING estao corretas

    :cry:


    Ainda nao tive sucesso com o squid


    algum tipo de regra poderia impedir o squid de funcionar??


    alguma configuracao especifica no win98 para acessar a internet via squid??

  14. #14

    Padrão iptables -t nat -A PREROUTING estao corretas

    Pessoal escrevi está conf com a finalidade de fazer um proxy transparente, bem enxuto, que não barra-se nada , não tivesse nenhuma neura com o Skype, hotmail, msn e controla-se o tamanho do cache no hd para não estourar o espaço limite. Depois de vários testes feito por mim e por amigos em várias Distros diferentes resolvi coloca-lo aqui no site para poder ajudar a todos que me ajudaram a escreve-lo tão pequeno e tão funcional. Abraço em Geral

    #Squid.conf - 01/01/2005
    #Lacier Dias
    #msn: [email protected]

    http_port 192.168.0.1:3128

    hierarchy_stoplist cgi-bin ?
    acl QUERY urlpath_regex cgi-bin \?
    no_cache deny QUERY

    # memoria usada:
    cache_mem 32 MB

    #esvazia o cache:
    cache_swap_low 90
    cache_swap_high 93

    maximum_object_size 6144 KB
    minimum_object_size 0 KB

    maximum_object_size_in_memory 100 KB

    ipcache_size 1024
    ipcache_low 90
    ipcache_high 93

    cache_replacement_policy lru
    memory_replacement_policy lru

    # disco usado:
    cache_dir ufs /var/spool/squid/cache 5000 16 256

    cache_access_log /var/log/squid/access.log
    cache_log /var/log/squid/cache.log
    cache_store_log /var/log/squid/store.log

    auth_param basic children 5
    auth_param basic realm Squid proxy-caching web server
    auth_param basic credentialsttl 2 hours

    refresh_pattern ^ftp: 1440 20% 10080
    refresh_pattern ^gopher: 1440 0% 1440
    refresh_pattern . 0 20% 4320

    acl all src 0.0.0.0/0.0.0.0
    acl manager proto cache_object
    acl localhost src 127.0.0.1/255.255.255.255
    acl rede src 192.168.0.0/255.255.255.0

    acl to_localhost dst 127.0.0.0/8
    acl SSL_ports port 443 563
    acl Safe_ports port 80 # http
    acl Safe_ports port 21 # ftp
    acl Safe_ports port 443 563 # https, snews
    acl Safe_ports port 70 # gopher
    acl Safe_ports port 210 # wais
    acl Safe_ports port 1025-65535 # unregistered ports
    acl Safe_ports port 280 # http-mgmt
    acl Safe_ports port 488 # gss-http
    acl Safe_ports port 591 # filemaker
    acl Safe_ports port 777 # multiling http
    acl CONNECT method CONNECT

    http_access allow localhost
    http_access allow rede

    http_access allow manager localhost
    http_access deny manager
    http_access deny !Safe_ports
    http_access deny CONNECT !SSL_ports
    http_access deny all

    http_reply_access allow all

    icp_access allow all

    cache_effective_user squid
    cache_effective_group squid

    httpd_accel_port 80
    httpd_accel_host virtual
    httpd_accel_with_proxy on
    httpd_accel_uses_host_header on



  15. #15
    max_mori
    Visitante

    Padrão iptables -t nat -A PREROUTING estao corretas

    nas outras maquinas coloquei

    o ip do meu servidor mais o 3128

    conforme o http_port do squid




    estah certo??