+ Responder ao Tópico



  1. #1

    Padrão Não consigo usar o alsamixer.

    Atualizei o kernel para o 2.6.11.2 ontem .. depois de mto esforço e com a ajuda do ic3 eu consegui compilar ele certin.
    Só que agora eu tô com problema no som.

    Eu dou um:

    # alsaconf

    Aí ele vai e detecta a placa na boa.. instala e talz.

    Aí qdo eu dou o :

    # alsamixer

    Eu tenho esse erro:

    alsamixer: function snd_ctl_open failed for default: No such file or directory

    Sugestões?

  2. #2

    Padrão Não consigo usar o alsamixer.

    tentei por a placa de som como built-in no kernel ... mas ainda tô com o mesmo problema.

    sempre que dou alsamixer apareçe o erro:


    alsamixer: function snd_ctl_open failed for default: No such file or directory

    e os modulos da placa tao levantados:

    0$ lsmod
    Module Size Used by
    ppp_synctty 8352 -
    ppp_async 9376 -
    crc_ccitt 1568 -
    ppp_generic 25236 -
    slhc 6560 -
    snd_pcm_oss 47808 -
    snd_pcm 82212 -
    snd_timer 20740 -
    snd_page_alloc 7364 -
    snd_mixer_oss 17120 -
    via_rhine 20228 -


    E agora? Só falta o som pro kernel ficar redondo.



  3. #3

    Padrão Não consigo usar o alsamixer.

    não sei pq no slack só funciona como root

    pode usar o sudo, também:

    sudo alsamixer

    se não for como root ou sudo isso simplesmente não funciona, fica dizendo que falta biblioteca.

  4. #4

    Padrão Não consigo usar o alsamixer.

    o erro não é com as permissões, e sim algo com o mixer.



  5. #5
    bruosps
    Visitante

    Padrão Não consigo usar o alsamixer.

    ql eh a distro ?? se for slack ... tenta "desligar" o hotplug ....
    naum dexa o hotplug inicia ... e digita o alsamixer ...

    posta ai qualquer coisa ... vlw

  6. #6

    Padrão Não consigo usar o alsamixer.

    nem uso hotplug ....
    isso foi depois da recompilação do kernel ... então não tem a ver com essas coisas... e sim com o kernel, ou algo do proprio alsa.

    Outra sugestão?



  7. #7
    helkmut
    Visitante

    Padrão Não entendo muito mas...

    Olha, quando eu recompilei o Kernel tive de recompilar o alsa no Slackware também, somente o alsa-driver-.... pelo menos eu sempre recompilei e obtive sucesso modulando o som no Kernel e após o primeiro boot recompilando o alsa e após isto deixava o próprio script do Slackware iniciar ele sem problemas.