Página 2 de 2 PrimeiroPrimeiro 12
+ Responder ao Tópico



  1. Citação Postado originalmente por DropALL
    Vai no "supositorio" da RedHat e procura por updates de pacotes do RH9, ai tu baixa o glibc e roda um rpm -Uvh :P
    hauhauhaua

    busca no rpm.pbone.net e no rpmfind hehhee

    []'s

  2. ok..vou fazer os testes e depois posto as novis aqui.

    Abraços.



  3. Pessoal!

    Ao invés de eu atualizar o meu php e também o mysql, resolvi instalar o FC4, pois está tudo bem atualizado (tanto o php como o mysql tb).
    Verifiquei através de umas leituras que o módulo gd já vem imbutido juntamente com o php apartir da versão 4.3 (a versão do FC4 é a 5.0.3), porém por padrão ele vem compilado com o parâmetro '--without-gd' , e desta forma o gd ainda não está habilitado para funcionar juntamente com o php.
    Como eu faço para compilar o meu php com a opção "--with-gd[=DIR]" ??
    Não sei por onde começar...Help-me.

    Agradeço todas as dicas.
    Abraços.

  4. Pessoal!

    Como muitos costumam fazer (resolver o problema e não postar a solução), e tenho certeza que jamais vou fazer isto, então vamos lá.

    Depois de algumas leituras sobre gd, php4 e apache resolvi o problema da seguinte maneira:
    1) Instalei o FC3, somente com os serviços de server Web;
    2) Subi os serviços de Apache (httpd), Mysql (mysqld);
    3) Instalei o módulo php-gd (peguei este rpm no site www.rpmfind.net);

    Pronto!
    O módulo que instalei faz o php4.3 conversar diretinho com o gd-2.0.

    Bom é isto aí, mais um resolvido.
    Agradeço todas as dicas!
    E agora vou estudar um pouquinho sobre como compilar as coisinhas no linux (FC e Debian) diretamente com o arquivo binário.

    Abraços.



  5. #10
    Citação Postado originalmente por Wal
    Pessoal!

    Estou encontrando o seguinte problema, atualmente estou trabalhando com a distro RH9 e preciso fazer rolar o módulo GD para trabalhar juntamente com o PHP.
    Baixei o GD 1.6.2.rpm, instalei mas estou precisando da versão acima de 2.0; baixei o versão 2.0 e quando vou instalar dá o erro abaixo (falha de dependências):
    error: Failed dependencies:
    libc.so.6 (GLIBC_2.3.4) is need by gd-2.0.33-1
    liggd.so.1.8 is needed by (installed) php-4.2.2-17
    libgd.so.1.8 is needed by (installed) webalizer-2.01_10-11

    Como eu faço para resolver o problema acima?
    Como eu faço para colocar a libc.so.1.8 no server para parar a dependência.

    Para eu atualiza a versão do meu php p/ 4.3 é somente eu baixar o rpm e dar um #rpm -Uvh <pacote> ??

    Agradeço todas as dicas.
    Abraços.






Tópicos Similares

  1. Air Grid M5-HP trabalhando junto com tecnologia AC
    Por Guilhermealonso1 no fórum Redes
    Respostas: 6
    Último Post: 29-12-2014, 12:20
  2. Respostas: 4
    Último Post: 29-10-2014, 15:36
  3. Problema com a biblioteca GD
    Por marcio_nkg no fórum Servidores de Rede
    Respostas: 3
    Último Post: 24-08-2006, 12:50
  4. Configurar php com suporte GD library
    Por rodrigohewitt no fórum Linguagens de Programação
    Respostas: 5
    Último Post: 06-05-2005, 12:35
  5. Imagens com GD
    Por jamba no fórum Linguagens de Programação
    Respostas: 5
    Último Post: 07-04-2005, 16:11

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L