+ Responder ao Tópico



  1. #1

    Padrão LTSP não esta carregando modo gráfico, só o shell

    Salve amigos, configurei um servidor LTSP (Linux Terminal Service Project, servidor de boot remoto), e estava tudo funcionando normalmente, acontece que quando eu logo em modo texto (shell), a estação burra loga normalmente, mas quando eu mudo para o modo gráfico (startx), a interface abre, aparece o ponteiro do mouse, mas fica ai mesmo, não retorna nenhum erro e nem acontece nada.
    O mais estranho é que o servidor funcionou normalmente por 3 dias e hoje aconteceu isso, eu não sei se tem haver, mas o ambiente gráfico do servidor também travou, bom, não sei o que fazer, se alguém que meche com LTSP poder dar um dica. Desde já agradeço. Thanx
    [ ]'s

  2. #2

    Padrão LTSP não esta carregando modo gráfico, só o shell

    Voce colocou algum firewall na rede?

    Se colocou trate de desabilitar e veja o que acontece... posta o resultado.



  3. #3

    Padrão LTSP não esta carregando modo gráfico, só o shell

    Aew,

    Bom se travou tambem no servidor, tu poderia partir deste principio, nao acha???? primeiro resolva no server...


    flws,

  4. #4

    Padrão LTSP não esta carregando modo gráfico, só o shell

    desculpa eu não ter dito antes, mas no server foi soh um ctrl+alt+backspace e ja resolveu, o gozado eh que depois disso, eu reiniciei o servidor, chequei todas as configurações e nas estações burras, a rede acha o dhcp, acha o arquivo q inicia o linux e a tela vai entrar no modo gráfico, o ponteiro do mouse aparece e fica por ai, não faz mais nda.



  5. #5

    Padrão LTSP não esta carregando modo gráfico, só o shell

    Você ainda não me respondeu...

  6. #6

    Padrão Olha o status do iptables

    Amigo, não mudei nada no firewall, apenas coloquei o proxy squid rodar, mas msm assim não alterei nada, pois o serviço apenas estava parado, bom, eu não sei se ajuda, mas com o comando ltspcfg, eu vejo que a parte de XDMCP esta funcinando (enabled), e que tem tanto o GDM, o KDM e XDM, só que esta como none, não esta usando nenhum, segundo o status, acontece que quando coloquei pra funcionar, msm como none, a estação remota ja entrava direto no gdm, que é o gerenciador de login gráfico padrão do meu servidor, que é um fedora 3.
    Abaixo segue o status do iptables:
    Código :
    [[email protected] ~]# service iptables status
    Tabela: nat
    Chain PREROUTING (policy ACCEPT)
    target     prot opt source               destination
    REDIRECT   tcp  --  0.0.0.0/0            0.0.0.0/0           tcp dpt:80 redir ports 3128
    REDIRECT   tcp  --  0.0.0.0/0            0.0.0.0/0           tcp dpt:8080 redir ports 3128
     
    Chain POSTROUTING (policy ACCEPT)
    target     prot opt source               destination
     
    Chain OUTPUT (policy ACCEPT)
    target     prot opt source               destination
     
    Tabela: filter
    Chain INPUT (policy ACCEPT)
    target     prot opt source               destination
    RH-Firewall-1-INPUT  all  --  0.0.0.0/0            0.0.0.0/0
    ACCEPT     tcp  --  0.0.0.0/0            0.0.0.0/0           tcp dpt:80
    ACCEPT     tcp  --  0.0.0.0/0            0.0.0.0/0           tcp dpt:8080
    ACCEPT     tcp  --  0.0.0.0/0            0.0.0.0/0           tcp dpt:3128
    ACCEPT     tcp  --  0.0.0.0/0            0.0.0.0/0           tcp dpt:22
    ACCEPT     tcp  --  0.0.0.0/0            0.0.0.0/0           tcp dpt:631
     
    Chain FORWARD (policy ACCEPT)
    target     prot opt source               destination
    RH-Firewall-1-INPUT  all  --  0.0.0.0/0            0.0.0.0/0
    ACCEPT     all  --  0.0.0.0/0            0.0.0.0/0
     
    Chain OUTPUT (policy ACCEPT)
    target     prot opt source               destination
     
    Chain RH-Firewall-1-INPUT (2 references)
    target     prot opt source               destination
    ACCEPT     all  --  0.0.0.0/0            0.0.0.0/0
    ACCEPT     all  --  0.0.0.0/0            0.0.0.0/0
    ACCEPT     icmp --  0.0.0.0/0            0.0.0.0/0           icmp type 255
    ACCEPT     esp  --  0.0.0.0/0            0.0.0.0/0
    ACCEPT     ah   --  0.0.0.0/0            0.0.0.0/0
    ACCEPT     udp  --  0.0.0.0/0            224.0.0.251         udp dpt:5353
    ACCEPT     udp  --  0.0.0.0/0            0.0.0.0/0           udp dpt:631
    ACCEPT     all  --  0.0.0.0/0            0.0.0.0/0           state RELATED,ESTABLISHED
    ACCEPT     tcp  --  0.0.0.0/0            0.0.0.0/0           state NEW tcp dpt:80
    ACCEPT     tcp  --  0.0.0.0/0            0.0.0.0/0           state NEW tcp dpt:443
    ACCEPT     tcp  --  0.0.0.0/0            0.0.0.0/0           state NEW tcp dpt:21
    ACCEPT     tcp  --  0.0.0.0/0            0.0.0.0/0           state NEW tcp dpt:22
    ACCEPT     tcp  --  0.0.0.0/0            0.0.0.0/0           state NEW tcp dpt:631
    REJECT     all  --  0.0.0.0/0            0.0.0.0/0           reject-with icmp-host-prohibited

    Tela de status do LTSP (com,ando ltspcfg):
    Código :
    ltspcfg v0.11                                                        The Linux Terminal Server Project (http://www.LTSP.org)
     
    Interface IP Address      Netmask         Network         Broadcast        Used
    eth0      198.164.1.100   255.255.255.0   198.164.1.0     198.164.1.255   <-----
     
    Service    Installed   Enabled   Running   Notes
    dhcpd         Yes         Yes       Yes       Version 3
    tftpd           Yes         Yes       Yes       No '-s' flag
    portmapper Yes         Yes       Yes
    nfs              Yes         Yes       Yes
    xdmcp         Yes          no        Yes       xdm, gdm, kdm    Using: none!
     
    File                                  Configured  Notes
    /etc/hosts                               Yes
    /etc/hosts.allow                       Yes
    /etc/exports                            Yes
    /opt/ltsp/i386/etc/lts.conf         Yes
     
    Configured runlevel: 5         (value of initdefault in /etc/inittab)
         Current runlevel: 3         (output of the 'runlevel' command)
     
    Installation dir...: /opt/ltsp
     
    Press <enter> to return to the main menu...

    Bom, tá ai, se alguém tiver alguma dica e puder ajudar, fico grato.
    Abraços cordiais,
    Eduardo Henrique (dupotter)



  7. #7

    Padrão LTSP não esta carregando modo gráfico, só o shell

    Cara... Desative o firewall...

    Desative e tente carregar o LTSP com ele desativado.

  8. #8
    Super_Diaulas
    Visitante

    Padrão LTSP não esta carregando modo gráfico, só o shell

    cara não acredito que seja firewall,
    veja o q está aparecendo nos logs dentro do servidor.
    Funcionou por 3 dias, mas inseriu algum micro novo?


    veja os logs, de repente está a solução