+ Responder ao Tópico



  1. #1
    UnST4Bl3
    Visitante

    Padrão Debian - Problem Modo Grafico!

    Pessoal, não estou conseguindo usar o modo grafrico no meu Debian... instalei tudo direito, drive vesa, monitor 17 e etc... na hora de iniciar o Modo grafico, ele fica numa tela cinza com o cursor em cruz.... consegui até mudar a resolução da tela ajustando conforme tinha um post aqui... mas não consigo instalar de forma alguma o Drive da NVIDIA para 6600GT no meu AMD64... da erro na hora de descompactar o drive 7174 e tb da erro na hora de descompactar o nvidia-installer...
    No Readme:

    sh NVIDIA-Linux-x86-1.0-XXXX.run --extract-only
    cd NVIDIA-Linux-x86-1.0-XXXX/usr/src/nv/
    make nv-linux.o
    mkprecompiled --interface=nv-linux.o --output=nv-linux.o-mykernel \
    --description="This is not an interesting description" \
    --proc-version="`cat /proc/version`" \
    --major=1 --minor=0 --patch=XXXX
    mv nv-linux.o-mykernel precompiled

    Porém o arquivo nv-linux.o não existe... tem um nv-kernel.o apenas... talvez seja pq da msg de erro na hora de descompactar.

    Alguem consegue me ajudar? please!

    Kernel 2.6.8-10-amd64-k8
    nvidia-installer-1.0.7.tar
    drive: NVIDIA-Linux-x86_64-1.0-7174-pkg2.run

    Bom, o kernel acho q é esse mesmo q ta rodando... pois na hora de iniciar no grub eh ele q eu escolho...

    se alguém souber me ajudar eu agradeço.

    Vlw.

  2. #2

    Padrão Debian - Problem Modo Grafico!

    apesar de num ser pra amd64 acho q isso pode ajudar:
    https://under-linux.org/modules.php?...wtopic&t=27459



  3. #3
    UnST4Bl3
    Visitante

    Padrão Debian - Problem Modo Grafico!

    Citação Postado originalmente por 1c3_m4n
    apesar de num ser pra amd64 acho q isso pode ajudar:
    https://under-linux.org/modules.php?...wtopic&t=27459
    Então, eu tinha lido esse topico, e foi justamente dai que peguei a config da resolução q vc postou:
    Citação Postado originalmente por 1c3_m4n
    Código :
    Section "Screen"
            Identifier "Screen0"
            Device     "nvidia"
            Monitor    "Monitor0"
            DefaultDepth 24
            SubSection "Display"
                    Viewport   0 0
                    Depth     4
                    Modes       "1280x1024" "1024x768" "800x600" "640x480"
            EndSubSection
            SubSection "Display"
                    Viewport   0 0
                    Depth     8
                    Modes       "1280x1024" "1024x768" "800x600" "640x480"
            EndSubSection
            SubSection "Display"
                    Viewport   0 0
                    Depth     16
                    Modes       "1400x1050" "1280x1024" "1024x768" "800x600" "640x480"
            EndSubSection
            SubSection "Display"
                    Viewport   0 0
                    Depth     24
                    Modes      "1400x1050" "1280x1024" "1024x768" "800x600" "640x480"
            EndSubSection
    EndSection
    dai minha resolução de video ficou legal, pois antes ficava a tela cinza com o mouse em cruz Gigante, agora fica a mesma coisa, só q pequeno. 1.024x768 hehe... mas de qq forma não consegui instalar o drive da nvidia. :/


    Onde fica o xorg.conf pra eu dar uma olhada nele?

    vlw.

    Ah, e no meu não rolou esta setagem:
    Identifier "Screen0"
    Device "nvidia"
    Monitor "Monitor0"

    tive que deixar como tava:
    Identifier "Screen Default"
    Device "vesa"
    Monitor "Monitor Genérico"

    algo assim....

  4. #4

    Padrão Debian - Problem Modo Grafico!

    fica em /etc/X11/xorg,conf

    essas coisas q vc teve q mudar eh normal
    isso muda de maquna em maquina...

    pq vc num rodou soh sh driver.run ? ao inves de passar akele comando pra soh descompactar e instalar manualmente;?



  5. #5
    UnST4Bl3
    Visitante

    Padrão Debian - Problem Modo Grafico!

    Citação Postado originalmente por 1c3_m4n
    fica em /etc/X11/xorg,conf

    essas coisas q vc teve q mudar eh normal
    isso muda de maquna em maquina...

    pq vc num rodou soh sh driver.run ? ao inves de passar akele comando pra soh descompactar e instalar manualmente;?
    Eu rodei... soh que da um erro, fala q eu não tenho um kernel precompilado... sei lah o q isso quer dizer... dai ele pergunta se eu quero procurar no ftp da nvidia e eu deixo procurar, dai da este erro:

    No matching precompiled kernell interface was found on the NVIDIA ftp site. this means that the installer will need to compile a kernel interface for your kernel.

    Acho q esse erro se refere ao nvidia-installer-1.0.7, por isso peguei ele e tentei instala-lo... mas tb não consegui.

    O q pode ser????

  6. #6

    Padrão Debian - Problem Modo Grafico!

    nao cara, aki tb deu essa msg, mas aki como eu tenho o fonte do kernel, ele compilou o driver sozinho,

    dps q ele detecta q num tem nenhum driver pre-compilado ele compila de acordo com o kernel q tem na sua maquina

    jah q vc ta usando debia roda ae

    apt-get update
    apt-get install kernel-source



  7. #7
    UnST4Bl3
    Visitante

    Padrão Debian - Problem Modo Grafico!

    Citação Postado originalmente por 1c3_m4n
    nao cara, aki tb deu essa msg, mas aki como eu tenho o fonte do kernel, ele compilou o driver sozinho,

    dps q ele detecta q num tem nenhum driver pre-compilado ele compila de acordo com o kernel q tem na sua maquina

    jah q vc ta usando debia roda ae

    apt-get update
    apt-get install kernel-source
    Ok, vou tentar...
    vou bootar novamente no linux.

  8. #8
    UnST4Bl3
    Visitante

    Padrão Debian - Problem Modo Grafico!

    bom, meu kernel-source jah estava instalado, era o kernel-source-2.6.8,
    o erro que dava, após aquele q já cieti aqui, é este:
    Unable to find the kernel source tree for the currently running kernel. Please make sure you have installed the kernel source files for your kernel. On the Red Hat linux systens, for example, be sure you have the "kernel-source" rpm installed.
    --kernel-source-path.....



  9. #9
    UnST4Bl3
    Visitante

    Padrão Debian - Problem Modo Grafico!

    ah! e dentro do meu /etc/X11/ não tinha o arquivo xorg.conf ... pq?

  10. #10

    Padrão Debian - Problem Modo Grafico!

    bom o xorg nao ta no /etc/X11/ ainda eh normal, tem varios lugares q podem estar....
    procura com find / -name xorg.conf

    agora da compilacao:
    ele procura o kernel source em /usr/src/linux
    se vc tiver o source em outro dir eh soh criar o link

    ln -sf /usr/src/linux-xxxxxxxxxxxxx /usr/src/linux



  11. #11
    UnST4Bl3
    Visitante

    Padrão Debian - Problem Modo Grafico!

    não rolou.
    Não tem pasta linux dentro de /usr/src/
    não achou nenhum xorg.conf pelo find
    o kernel-source tava dentro duma pasta /usr/share/doc
    tinha o kernel-source dentro de /usr/src mas estava como arquivo compactado .tar... descompactei lah, não adiantou nada... não achou nenhum source na hora q tentei instalar o drive da nvidia. :/

  12. #12

    Padrão Debian - Problem Modo Grafico!

    entaum o debian ta usando o xfree e nao xorg, bom mas conf eha mesma
    ve se tem /etc/X11/XF86Config

    e nao adianta ter qq kernel descompactado no /usr/src, tem q ser exatamente a versao do kernel que vc ta usando, caso contrario nao vai ser compilado



  13. #13
    UnST4Bl3
    Visitante

    Padrão Debian - Problem Modo Grafico!

    meu kernel eh o 2.6.8-10-amd64-k8
    e o kernel source eh o 2.6.8
    teria que ter o kernel source 2.6.8-10-amd64-k8????

    acho q eh o XFree então... no top ele aparece como xdm

  14. #14
    D4rk_Sl4ck
    Visitante

    Padrão Debian - Problem Modo Grafico!

    no debian Sarge é /etc/X11/XF86Config-4 .. preste atenção na hora d usar o xf86config .. como ele aina tem resquícios do antigo xf86config ele tenta salvar em /etc/X11 o arquivo XF86Config e não o XF86Config-4 .. entendeu??? outra coisa .. instala os kernel-headers e qualquer outra coisa qu for referente ao Kernel .. apesar de nào ser obrigatório vc pode também instalar os pacotes referentes à Nvidia .. assim, foi desse jeito que fiz e deu certo para a mesma placa de rede .. soh num era a mesma arquitetura de processador .. era um AXP 2600+ ...



  15. #15
    UnST4Bl3
    Visitante

    Padrão Debian - Problem Modo Grafico!

    Consegui resolver aqui... o problema era mais simples, porém ridiculo q ele exista. :P
    Já havia baixado varias dist, e agora por ultimo tentei o debian e o ubuntu, o problema era que o ISO vinha com o xfonts-server corrompido + um outro pacote de fontes corrompido... até eu conseguir ver isso (sou noob :P ) e pensar em como rigir, fiquei achando q era algo mais grave. Apenas deletei o pacote q havia instalado do CD e deletei o CDROM da lista de servidores, dai ele baixou da net esses pacotes e funcionou.
    Bom, agora é aprender a mexer em tudo no linux.;
    O q ta dando trabalho agora eh colocar um drive da NVIDIA, conforme jah havia citado ai em cima, ele da erro na hora de descompactar e ou instalar pelo sh NVIDIA****

    vou procurar nos forum aqui como fazer isso.
    Ah! No ubuntu ele não pediu pra eu colocar uma senha root, como eu habilito o user pra ter privilegios de root???