Página 2 de 4 PrimeiroPrimeiro 1234 ÚltimoÚltimo
+ Responder ao Tópico



  1. E aí velinho;

    parece q tamos com o mesmo problema. Só pra setar, desative seu firewall e coloque no seu browser as configs do proxy e vê se navega. As regras que vc retirou do firewal desabilitaram o direcionamento ao proxy, funcionando apenas o NAT.

    Tenta ver dessa forma acima se seu proxy funciona.

  2. #7
    mcyberx
    pessoal, gostaria de aproveitar o gancho e dizer que achei bem mais simples fazer o mascaramento somente para a máquina proxy. aí as outras máquinas da rede aponta o gateway para ela fazendo assim um proxy transparente sem regras de iptables. vê se resolve o caso ok?

    se alguém tiver alguma opinião...



  3. Tentei como você me falou mas continua na mesma...
    Não navega em página alguma.

    Testei a navegação com o firewall que é o mesmo que esta com o squid e
    o mesmo navega normalmente.

    Dá a impressão que o IE não está encontrando o proxy.

    Só para constar

    Cliente
    ping 200.204.0.10 OK
    ping www.uol.com.br OK
    ping www.terra.com.br OK

    Servidor
    ping 200.204.0.10 OK
    ping www.terra.com.br OK
    ping www.uol.com.br OK

    Ai vem
    ping 192.168.0.3 (servidor para maquina interna) OK
    ping 192.168.0.1 (máquina interna para servidor) ERRO

    Pode ser por aí?

  4. olha o erro aki:
    #iptables -t nat -A PREROUTING -s $LAN_IP_NET -p tcp -i eth1 --dport 80 -j DNAT --to $FORWARD_IP:3128

    essa regra ta errada, issu faz com q se a pessoa acessar www.terra.com.br, a requisicao vai ser redirecionada para seu server com o squid, e nao eh isso q vc quer, vc quer apenas obrigar a PASSAR ATRAVES do proxy, a regra correta eh assim:

    iptables -t nat -A PREROUTING -S $LAN_IP_NET -p tcp -i eth1 --dport 80 -j REDIRECT --to 3128



  5. Ice fiz como voce falou e ainda assim não navega...
    fica na barra do IE conectando ao site 192.168.01.....

    Testei novamente retirando o proxy do navegador e comentando a regra iptables anterior mantendo o squid ativo e ai funciona tudo normalmente.

    Onde mais pode ser? :toim:

    Tenho que configurar alguma opção de dns no squid?

    Não achei nd sobre isso nos tutorias que encontrei.






Tópicos Similares

  1. Respostas: 9
    Último Post: 20-03-2015, 08:59
  2. Respostas: 9
    Último Post: 20-03-2015, 08:59
  3. Squid funciona... Mas terminais podem navegar sem ser pelo proxy
    Por vfsmount no fórum Servidores de Rede
    Respostas: 5
    Último Post: 28-11-2006, 00:18
  4. NÃO PASSAR PELO PROXY(3128)
    Por rogeriotux no fórum Servidores de Rede
    Respostas: 7
    Último Post: 19-02-2004, 14:32
  5. Respostas: 2
    Último Post: 04-10-2003, 21:46

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L