Página 5 de 5 PrimeiroPrimeiro 12345
+ Responder ao Tópico



  1. #81

    Padrão Problemas ao iniciar BIND (resolvido)

    :clap: Boa Jogada mazzi!!! :clap:

    Citação Postado originalmente por fpmazzi
    Citação Postado originalmente por jrctec
    Citação Postado originalmente por fpmazzi
    Posta ae o arquivos so synapse.com.br.hosts pra darmos uma olhada .. talvez o problema estaja la, ja ke o www nao resolve, o lablinux.synapse.com.br resolve, pois o mesmo esta no /etc/hosts, agora precisamos dar uma olhada no seu synapse.com.br.hosts...

    qualquer coisa entra em contato .. blz ...

    :good:
    tá assim:

    $ttl 38400
    synapse.com.br. IN SOA lablinux.synapse.com.br. root.lablinux.synapse.com.br. (
    1051034896
    10800
    36000
    604800
    38400 )
    synapse.com.br. IN A 192.168.0.254
    synapse.com.br. IN NS lablinux.synapse.com.br.
    synapse.com.br. IN MX 5 lablinux.synapse.com.br.
    www A 192.168.0.254
    Carinha da uma olhada no seu arquivo de zona, tem uma pequena falha, como o servidor vai ter dois nomes, lablinux (/etc/hosts) e www (ke esta no dns), o www tem ke ser um cname, tente colocar desta maneira:

    $ttl 38400
    synapse.com.br. IN SOA lablinux.synapse.com.br. root.lablinux.synapse.com.br. (
    1051034896
    10800
    36000
    604800
    38400 )
    synapse.com.br. IN A 192.168.0.254
    synapse.com.br. IN NS lablinux.synapse.com.br.
    synapse.com.br. IN MX 5 lablinux.synapse.com.br.
    www IN CNAME 192.168.0.254

    Tente e espero ke tenha ajudado ...

    abraços ...

    Posta ae o resultados ...

    :good:

  2. #82
    robsonzornitta
    Visitante

    Padrão eh verdade!!

    eh verdade ele teim que ser um cname mas pode deixar como eu fiz ai em cima os 2 daum certu!!!!!!!!!

    mas gostei da dica valeu pessoal!!!! :good:



  3. #83
    Visitante

    Padrão Problemas ao iniciar BIND (resolvido)

    en named.conf tiene que tener:

    options {
    ...
    pid-file "/var/run/named/named.pid";
    }

    tiene que tener permisos de escritura en /var/run/named

    recordar poner en /etc/init.d/bind9
    OPTS="-u [USUARIO]"

  4. #84
    Super_Diaulas
    Visitante

    Padrão Problemas ao iniciar BIND (resolvido)

    opa estou sem tempo para ler os newsletter do Under


    mas era fácil essa, o primeiro problema era q o named era inicializado em chroot ma configurado fora da jaula,..por isso arquivos com permissão negada ou não achada
    e a segunda era criar um CNAME apenas

    www IN CNAME 192.168.xx.xx



  5. #85
    fpmazzi
    Visitante

    Padrão Problemas ao iniciar BIND (resolvido)

    nao entendi ???

  6. #86
    Super_Diaulas
    Visitante

    Padrão Problemas ao iniciar BIND (resolvido)

    CNAME é um canonical name, um apelido

    tudo que vier para www.seudominio.com.br irá para o endereço de ip 192.168.x.x

    por exemplo

    se vc pinga seudominio.com.br, pingar com o www vai dar na mesma



  7. #87
    fpmazzi
    Visitante

    Padrão Problemas ao iniciar BIND (resolvido)

    Citação Postado originalmente por Super_Diaulas
    opa estou sem tempo para ler os newsletter do Under


    mas era fácil essa, o primeiro problema era q o named era inicializado em chroot ma configurado fora da jaula,..por isso arquivos com permissão negada ou não achada
    e a segunda era criar um CNAME apenas

    www IN CNAME 192.168.xx.xx
    oq eh cname eu sei entendi.. ja sabia rs .. oq nao entendi foi a primeira parte .. da jaula, chroot, como sei se o named ta em chroot, e como corrigi esse problema, eis a kestao, pq o meu dns qdo inicio ele com o service named start ele inicia, mas qdo do um service named status da a msg:
    rndc: connect failed: connection refused
    :toim:

  8. #88
    Super_Diaulas
    Visitante

    Padrão Problemas ao iniciar BIND (resolvido)

    seguinte

    quando vc roda o bind em chroot vc troca o path dele
    é meio fogo de explicar, mas tipo

    imagine que criou os diretórios assim


    se vc setar o chroot em /chroot/named.......... o named vai achar q o /
    é dentro de /chroot/named assim ele vai ter uma estrutura em baixo do /chroot/named como se fosse o próprio /

    Vai ter que criar toda a estrutura necessária do / embaixo do /chroot/named


    assim o named.conf dele na verdade fica em /chroot/named/etc/named.conf e não em /etc/named.conf, entendeu?

    para descobrir se está rodando em chroot o comando deve ser próximo disso:

    Bind 8

    named -u named -g named -c /chroot/etc/named.conf -x /chroot/var/named/run/named.pid -t /chroot/named/

    Bind 9

    named -u named -g named -t /chroot/named/

    não sei se está 100% correto o comando, mas é bem próximo.[/b]



  9. #89
    Super_Diaulas
    Visitante

    Padrão Problemas ao iniciar BIND (resolvido)

    seguinte

    quando vc roda o bind em chroot vc troca o path dele
    é meio fogo de explicar, mas tipo

    se vc setar o chroot em /chroot/named.......... o named vai achar q o /
    é dentro de /chroot/named assim ele vai ter uma estrutura em baixo do /chroot/named como se fosse o próprio /

    Vai ter que criar toda a estrutura necessária do / embaixo do /chroot/named


    assim o named.conf dele na verdade fica em /chroot/named/etc/named.conf e não em /etc/named.conf, entendeu?

    para descobrir se está rodando em chroot o comando deve ser próximo disso:

    Bind 8

    named -u named -g named -c /chroot/etc/named.conf -x /chroot/var/named/run/named.pid -t /chroot/named/

    Bind 9

    named -u named -g named -t /chroot/named/

    não sei se está 100% correto o comando, mas é bem próximo.[/b]

  10. #90
    fpmazzi
    Visitante

    Padrão Problemas ao iniciar BIND (resolvido)

    oK vo tenta dps retorno.....


    valews ....


    :clap: :good: