+ Responder ao Tópico



  1. #1
    milosevic86
    Visitante

    Padrão Conexao instavel atras do gateway...

    Estou com um problema serio aqui, jah faz 2 meses. Aqui em casa tem um servidor rodando slack10.1 + duas maquinas q acessam a internet atraves desse servidor . Compartilho a internet aqui usando o redirecionamento de pacotes do iptables.

    echo 1 > /proc/sys/net/ipv4/ip_forward
    iptables -t nat -A POSTROUTING -o ppp0 -j MASQUERADE

    (Todas as policys estao como accept, uma vez q ainda n resolvi esse problema).

    Nas duas makinas clientes, eu setei 192.168.0.1 (ip do servidor) como gateway, e no dns eu coloquei os que a brtelecom me passou.

    De maneira geral, a internet nas maquinas q estao atras do gateway funciona perfeitamente. Dá pra acessar o irc, navegar por paginas e etc... Porem a conexao eh muito instavel. Os nomes sempre sao resolvidos mas algumas paginas começam a ser carregadas e depois param, no meio do download.( Ex, site da globo.com, sites da microsoft, hotmail e etc...). Msn tb nao funciona, alguns jogos online tb nao.

    Andei procurando na net, e achei um cara com o mesmo problema, mas ele n conseguiu resolver. (tb achei um sujeito no irc, mas tb nada de solucao).
    http://listas.cipsga.org.br/pipermai...er/003725.html --> endereco do post de um cara com o mesmo problema.


    Não tenho nem ideia de como resolver isso. Quem sabe seja algum modulo que esteja faltando carregar. Se alguem tiver alguma ideia por favor responda. Valeu.

  2. #2

    Padrão Conexao instavel atras do gateway...

    Qual discador ppp q vc esta usando???

    Tive um problema parecido com este usando SuSE a um tempo atraz. Tem uns discadores, ou ate mesmo, versoes simplificadas de discadores q nao suportam nat.

    [] Dotta :twisted:



  3. #3

    Padrão Conexao instavel atras do gateway...

    completando,

    Nao sei s vc tem mais regras no seu iptables, mas vc vai precisar desta regras tb:

    Código :
    iptables -A INPUT -m state --state ESTABLISHED,RELATED -j ACCEPT
    iptables -A INPUT -m state --state NEW -i ethx -j ACCEPT
    iptables -A FORWARD -i ethx -o ppp0 -j ACCEPT
    iptables -t nat -A POSTROUTING -o ppp0 -j MASQUERADE

    PS: ethx = a sua eth1, eth1, etc da rede interna

    [] Dotta :twisted:

  4. #4
    milosevic86
    Visitante

    Padrão Conexao instavel atras do gateway...

    Eu tentei esses comandos... mas continuo com o mesmo problema. Quanto ao discador, eu uso um especifico para o meu modem (que eh usb). Eu peguei o driver na net (tive q recompilar kernel pra fazer funcionar), e ele vem com uma especie de discador junto.

    Site do driver/discador: speedtouch.sourceforge.net



  5. #5
    milosevic86
    Visitante

    Padrão Conexao instavel atras do gateway...

    Coloquei os logs do iptables só pra ser feita uma comparação. Quando uma makina cliente tenta acessar sem sucesso o site da microsoft (fica soh na tentativa... carregando mas n termina nunca) acontece o seguinte:

    May 14 04:13:16 darkstar kernel: ACESSANDO MICROSOFT IN=ppp0 OUT=eth0
    SRC=207.46.20.60 DST=192.168.0.2 LEN=48 TOS=0x00 PREC=0x00
    TTL=116 ID=14699 PROTO=TCP SPT=80 DPT=1293 WINDOW=16384 RES=0x00 ACK SYN
    URGP=0
    May 14 04:13:19 darkstar pppoa3[232]: Clp bit is ON

    Já quando acessa um site com sucesso (no caso o site do terra):

    May 14 04:12:36 darkstar kernel: ACESSANDO TERRA IN=ppp0 OUT=eth0
    SRC=200.176.3.142 DST=192.168.0.2 LEN=40 TOS=0x00 PREC=0x00 TTL=57 ID=29331
    DF PROTO=TCP SPT=80 DPT=1290 WINDOW=6432 RES=0x00 ACK FIN URGP=0
    May 14 04:12:36 darkstar pppoa3[232]: Clp bit is ON
    May 14 04:12:36 darkstar last message repeated 5 times

    PS: nao acredito q o problema pode estar na configuracao do cliente... esse makina q funciona como servidor rodando windows xp (soh compartilhando a internet funcionando como gateway) funciona tudo ok.

  6. #6

    Padrão Conexao instavel atras do gateway...

    Entao cara,

    Isso ta com cara q o seu discador esta dando pau com o NAT, tenta usar o rp-pppoe, mas eu nao seu se ele tem suporte para usb precisa dar uma olhada.

    [] Dotta :twisted: