+ Responder ao Tópico



  1. #1
    vandemberg
    Visitante

    Padrão "Invalid argument" - Após implantação do Patch-o-m

    Colegas,
    Estou aplicando o Patch-o-matic aqui no meu firewall pra bloquear de vez esse kazaa. Toda a instalação de certo, peguei o iptables-1.2.11 compilei, usei o pacote patch-o-matic-20030107 e compilei normal com suporte ao psd e string, recompilei meu kernel 2.4.20 ativando o suporte ao psd e strig e por ultimo compilei e instalei o ipp2p.06. Toda a instalação deu blza, consigo colocar as regras e tudo mais.
    O problema aparece quando eu vou ativar o MASQUERADE e o REDIRECT pra fazer meu proxy transparente. ele informa o seguinte:
    #iptables -t nat -A PREROUTING -s minha_lan -p tcp --dport 80 -j REDIRECT --to-port 3128
    iptables: Invalid argument
    E quando dou um boot pelo kernel sem compilação e utilizando o iptables nativo da instalação que é o 1.2.7 (red hat 9.0) os comandos são inseridos normalmente.
    Alguma dica?
    Grato a todos.

  2. #2

    Padrão "Invalid argument" - Após implantação do Patch-o-m

    troca --to-port pra soh --to



  3. #3
    vandemberg
    Visitante

    Padrão "Invalid argument" - Após implantação do Patch-o-m

    Mesmo erro amigo.

  4. #4

    Padrão "Invalid argument" - Após implantação do Patch-o-m

    vc compilo o novo iptables na mao neh... jah sei oq deve ser... vc esta com as 2 versoes do iptables na maquina, provavelmente uma esta em /usr/sbin e a outra em /usr/local/sbin, e qdo vc roda soh iptables ele pega a primeira...

    veja se eh isso mesmo

    find / -name iptables



  5. #5
    vandemberg
    Visitante

    Padrão "Invalid argument" - Após implantação do Patch-o-m

    Isso mesmo amigo.. tem as duas versões do iptables instalado na maquina.. ambos mostra o erro veja:
    (compilado na mão)# /usr/src/iptables/iptables -t nat -A POSTROUTING -s 10.20.30.0/24 -o eth0 -j MASQUERADE
    iptables: Invalid argument

    (instalado junto com o RH9)# /usr/local/sbin/iptables -t nat -A POSTROUTING -s 10.20.30.0/24 -o eth0 -j MASQUERADE
    iptables: Invalid argument

    Tipo como se o suporte ao mascaramento e ao redirect nao estivesse ativo na minha compilação, mas os modulos estão todos levantados. Realmente nao tenho idéia.

  6. #6

    Padrão "Invalid argument" - Após implantação do Patch-o-m

    o q retorn which iptables?



  7. #7
    vandemberg
    Visitante

    Padrão "Invalid argument" - Após implantação do Patch-o-m

    nao entendi 1c3_m4n !

  8. #8

    Padrão "Invalid argument" - Após implantação do Patch-o-m

    executa
    which iptables
    e me fala oq ele vai mostrar



  9. #9

    Padrão "Invalid argument" - Após implantação do Patch-o-m

    a eskece, viajei...

    deve te faltado alguma coisa no kernel mesmo, ativa todas as opcoes do iptables no kernel como built-in e nao como modulo, assim vc tem certeza de q ta carregando

  10. #10

    Padrão "Invalid argument" - Após implantação do Patch-o-m

    # modprobe ipt_MASQUERADE ?



  11. #11
    vandemberg
    Visitante

    Padrão "Invalid argument" - Após implantação do Patch-o-m

    Ice, essas opções psd e string no kernel não são disponiveis para serem ativados como build-in(*), apenas como modulo(M), assim foi feito.

    mistymst, levantei esse modulo separado mais deu o mesmo erro.

  12. #12

    Padrão "Invalid argument" - Após implantação do Patch-o-m

    Citação Postado originalmente por vandemberg
    Ice, essas opções psd e string no kernel não são disponiveis para serem ativados como build-in(*), apenas como modulo(M), assim foi feito.

    mistymst, levantei esse modulo separado mais deu o mesmo erro.
    tudo mas, mas nao sao elas q estao dando problemas, e sim as outras, eu me referia as opcoes nativas do iptables



  13. #13
    vandemberg
    Visitante

    Padrão "Invalid argument" - Após implantação do Patch-o-m

    Veja como está a configuração do kernel atualmente..
    <M> psd match support
    <M> String match support (EXPERIMENTAL)
    <M> Full NAT
    <M> MASQUERADE target support[*] NAT of local connections (READ HELP)

    Tentei alterar todos esses para buit-in mas não da certo...ele fica desativado ou via modulo.

  14. #14

    Padrão "Invalid argument" - Após implantação do Patch-o-m

    ele nao deixou colocar o masquerade como builtin?



  15. #15
    vandemberg
    Visitante

    Padrão "Invalid argument" - Após implantação do Patch-o-m

    Nao deixou. Quando preciono Y pra mudar para build-in ele me mostra a seguinte mensagem:
    "This feature depends on another which has been configured as a module. As a result, this feature will be built as a module."

  16. #16
    vandemberg
    Visitante

    Padrão "Invalid argument" - Após implantação do Patch-o-m

    Alguma dica !?!?!?!?!



  17. #17
    Super_Diaulas
    Visitante

    Padrão "Invalid argument" - Após implantação do Patch-o-m

    algum dos intes que foi colocado como M não deixa tru colocar com built em outro, vai na tentativa e erro para descobrir qual tem q ser built para deixar os outros built