+ Responder ao Tópico



  1. #1
    fliegerbr
    Visitante

    Padrão Problemas com CRON

    No Conectiva 9, inclui a seguinte linha no arquivo /etc/crontab, abaixo dos run-parts:

    30 2 * * * root rm -f -r /mnt/dados/publico/*

    A idéia é apagar todo o conteúdo da pasta /mnt/dados/publico diariamente, as 2h30min.

    Contudo, os arquivos continuam na pasta.

  2. #2
    winter_man
    Visitante

    Padrão Problemas com CRON

    Caro fliegerbr aparentemente seu crontab está configurado corretamente para a ação a qual vc quer realizar. Uma pergunta: esse diretório /mnt/dados é uma partição? se sim, ela está no /etc/fstab?

    Referente ao deamon do cron (crond) ele está rodando normalmente??



  3. #3
    fliegerbr
    Visitante

    Padrão Problemas com CRON

    Não havia verificado se o crond estava rodando. Como posso configurar para que ele execute automaticamente sempre que o sistema for iniciado? (Conectiva 9).

  4. #4

    Padrão Problemas com CRON

    provavelmente tem o service no conectiva 9

    execute o gerenciador de serviços e selecione o cron pra iniciar

    não sei qual é o gerenciado de serviços do conectiva



  5. #5
    fliegerbr
    Visitante

    Padrão Problemas com CRON

    Há sim o Service, mas por linha de comando não há como setar inicialização automática (nesta instalação acesso via SSH :-). Há outra maneira?

  6. #6
    Spelk
    Visitante

    Padrão Problemas com CRON

    Meu não sei como funciona esse comando no conectiva, mas tente com -Rf, então fica:


    30 2 * * * rm -Rf /mnt/dados/publico/*

    Caso não funcione, dê uma olhada no arquivo de log do cron, geralmente em /var/log/cron.



  7. #7
    Visitante

    Padrão Problemas com CRON

    No conectiva tinha o ntsysv que permite selecionar o software que sera inicializado...

    testa ai

    A Marcio

  8. #8
    winter_man
    Visitante

    Padrão Problemas com CRON

    Citação Postado originalmente por Anonymous
    No conectiva tinha o ntsysv que permite selecionar o software que sera inicializado...

    testa ai

    A Marcio
    Caro amigo fliegerbr, para fazer com que um determinado serviço seja iniciado no boot existem duas maneiras: Criando um script e adcionando-o nos diretórios /etc/rc.d + runlevel escolhida ou como nosso amigo Marcio mencionou executando o comando ntsysv.

    Qualquer dúvida posta aê...

    Espero ter ajudado...



  9. #9
    fliegerbr
    Visitante

    Padrão Problemas com CRON

    Pessoal, valeram as dicas, mas ainda não resolvi o problema.

    O serviço crond está ativo (verificado via service crond status), e a linha mencionada na primeira mensagem referente ao script funciona perfeitamente se executada manualmente.

    Coloquei outra linha no /etc/crontab para testar a execução, as 10h da manhã:
    * 10 * * * root echo "Testando crond"

    Teoricamente, deveria imprimir minuto a minuto a mensagem, até as 11h. Mas nada aparece no display.

    E agora? :-)

  10. #10
    Visitante

    Padrão Problemas com CRON

    Amigo, os comandos executados pelo cron, rodam em backgroud, vc teria q redirecionar a saida, não sei como faz pra redirecionar pra tela mas tipo, jogue pra um arquivo e veja ele depois...

    * 10 * * * echo "Testando" > /tmp/echo.txt 2



  11. #11
    fliegerbr
    Visitante

    Padrão Problemas com CRON

    A idéia do echo foi tirada de um tutorial em http://www.vivaolinux.com.br/artigos...hp?codigo=1976 mas tudo certo, fiz o teste com o redirecionamento e também não deu certo.

    No log do cron, ele recarrega o /etc/crontab toda vez que altero o mesmo, mas não aparece nenhuma mensagem referente ao comando de deleção ou ao de echo que usei para teste.

  12. #12
    Spelk
    Visitante

    Padrão Problemas com CRON

    Cara... Outra coisa que me ocorreu agora e que ninguem citou ainda.

    Se esse comando for a ultima linha do seu arquivo, não rodará, tem que haver pelo menos uma linha em branco no final do arquivo, então dê uns "ENTER"s e vê se ele roda.



  13. #13
    fliegerbr
    Visitante

    Padrão Problemas com CRON

    Boa, de fato com uma linha em branco no final do /etc/crontab funcionou legal... valeram as dicas!