Página 2 de 2 PrimeiroPrimeiro 12
+ Responder ao Tópico



  1. #6
    só pra reforçar:
    vc deve instalar o oracle client na maquina onde roda apache+php.

    Citação Postado originalmente por Anonymous
    O servidor oracle vc especifica nas variaveis do sistema.

    Esse caminho do configure é apenas para o php achar as bibliotecas para poder compilar.

    É o caminho onde vc instalou o oracle client.

    Citação Postado originalmente por whinston
    mas e se o oracle estiver em outro servidor ?
    como eu aponto este path ?

  2. vc deve ter o client do oracle pra acessar um server em outro pc...

    o seu php vai ser compilado com suporte a esse cliente q vc possui instalado...

    o seu php, vai usar esse client

    []'s



  3. #8
    whinston
    Citação Postado originalmente por demiurgo
    vc deve ter o client do oracle pra acessar um server em outro pc...

    o seu php vai ser compilado com suporte a esse cliente q vc possui instalado...

    o seu php, vai usar esse client

    []'s
    http://www.oracle.com/technology/sof...linuxsoft.html

  4. #9
    whinston
    Citação Postado originalmente por demiurgo
    vc deve ter o client do oracle pra acessar um server em outro pc...

    o seu php vai ser compilado com suporte a esse cliente q vc possui instalado...

    o seu php, vai usar esse client

    []'s
    Vixe cara, baixei o cliente que ta ali no link acima. Vide abaixo:
    -r--r--r-- 1 root root 1.5M Mar 7 18:28 classes12.jar
    -rwxrwxr-x 1 root root 13M Mar 7 18:28 libclntsh.so.10.1
    -r-xr-xr-x 1 root root 2.1M Mar 7 18:28 libnnz10.so
    -rwxrwxr-x 1 root root 891K Mar 7 18:28 libocci.so.10.1
    -rwxrwxr-x 1 root root 62M Mar 7 18:28 libociei.so
    -r-xr-xr-x 1 root root 96K Mar 7 18:28 libocijdbc10.so
    -r--r--r-- 1 root root 1.4M Mar 7 18:28 ojdbc14.jar

    E na hora de compilar, tá dando:
    configure: error: oci8/usr/local/clientoracle: invalid package name

    Alguma dica ?



  5. #10
    whinston
    Neste site:
    http://www.oracle.com/technology/sof...linuxsoft.html

    Peguei o pacote básico.
    É este mesmo ?






Tópicos Similares

  1. php com suporte a oracle
    Por slaxpunk no fórum Linguagens de Programação
    Respostas: 0
    Último Post: 05-06-2007, 11:21
  2. php com suporte a postgresql
    Por furazoio no fórum Linguagens de Programação
    Respostas: 1
    Último Post: 23-07-2005, 13:01
  3. Configurar php com suporte GD library
    Por rodrigohewitt no fórum Linguagens de Programação
    Respostas: 5
    Último Post: 06-05-2005, 12:35
  4. PostgreSQL Com Suporte PHP
    Por bouncer no fórum Servidores de Rede
    Respostas: 5
    Último Post: 09-06-2004, 14:49
  5. Instalando um apache com php e suporte a Oci8 num conectiva
    Por Futuremax no fórum Servidores de Rede
    Respostas: 0
    Último Post: 11-12-2002, 15:23

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L