Página 2 de 4 PrimeiroPrimeiro 1234 ÚltimoÚltimo
+ Responder ao Tópico



  1. Pessoal, acho q estou quase chegando lá.

    Já configurei o samba, cups e a impressora e não dá mais erro no log do cups, mas também não imprime.
    Gostaria de mais uma ajudinha. Segue abaixo as minhas configurações:

    SMB.CONF
    security = share
    load printers = yes
    printcap name = cups
    printing = cups

    [printers]
    comment = All Printers
    path = /var/spool/samba
    browseable = no
    # Set public = yes to allow user 'guest account' to print
    public = yes
    guest ok = yes
    writable = yes
    printable = yes
    #: printer admin = root

    [print$]
    comment = Printer Drivers
    path = /usr/local/share/cups/drivers
    browseable = yes
    guest ok = yes
    read only = no
    # write list = root


    MIMES.TYPES
    application/octet-stream


    MIMES.CONVS
    application/octet-stream application/vnd.cups-raw 0 -

    CUPSD.CONF
    <Location />
    Order Deny,Allow
    Deny From All
    Allow From 192.168.1.0/255.255.255.0
    </Location>

    Valew!

  2. Citação Postado originalmente por Pedro0278
    Pitsa...

    Não precisa do samba nao cara....

    Tenho impressora no servidor Linux e nao necessitou de Samba nao cara.
    o samba é pra deixar "a lá rede windows" .... da pra usar IPP se JetDirect tb né? sei que o windows suporta JetDirect, mas o IPP ele não suporta....

    Valois, adiocione no inicio das configurações a linha "cups options = raw" tb...



  3. Pessoal, Ta complicado!

    A impressão está chegando na impressora Windows mas não sai (e também não consigo deletar a impressão. Só consigo limpar, matando o processo spoolsv, limpando a impressão e carregando o processo novamente).

    Ague abaixo parte do log do Cups:
    [21/Jun/2005:18:26:20 -0300] [Job 20] hpijs: not found
    D [21/Jun/2005:18:26:20 -0300] [Job 20] GNU Ghostscript 7.07: Can't start ijs server "hpijs"
    D [21/Jun/2005:18:26:20 -0300] [Job 20] **** Unable to open the initial device, quitting.
    D [21/Jun/2005:18:26:20 -0300] [Job 20] renderer return value: 1
    D [21/Jun/2005:18:26:20 -0300] [Job 20] renderer received signal: 1
    D [21/Jun/2005:18:26:20 -0300] [Job 20] tail process done writing data to STDOUT
    D [21/Jun/2005:18:26:20 -0300] [Job 20] KID4 finished
    D [21/Jun/2005:18:26:20 -0300] [Job 20] KID4 exited with status 0
    D [21/Jun/2005:18:26:20 -0300] [Job 20] Process dying with "Possible error on renderer command line or PostScript error. Check options.", exit stat: 3
    D [21/Jun/2005:18:26:20 -0300] [Job 20] KID3 exited with status 3
    D [21/Jun/2005:18:26:20 -0300] [Job 20] Possible error on renderer command line or PostScript error. Check options.
    D [21/Jun/2005:18:26:20 -0300] [Job 20] Renderer exit stat: 3
    D [21/Jun/2005:18:26:20 -0300] [Job 20] Renderer process finished
    D [21/Jun/2005:18:26:20 -0300] [Job 20] Killing process 53840 (KID3)
    D [21/Jun/2005:18:26:20 -0300] [Job 20] Process dying with "Error closing renderer", exit stat: 3
    D [21/Jun/2005:18:26:20 -0300] [Job 20] Error closing renderer
    E [21/Jun/2005:18:26:20 -0300] PID 53838 stopped with status 3!
    D [21/Jun/2005:18:26:20 -0300] UpdateJob: job 20, file 0 is complete.
    D [21/Jun/2005:18:26:20 -0300] CancelJob: id = 20
    D [21/Jun/2005:18:26:20 -0300] StopJob: id = 20, force = 0
    D [21/Jun/2005:18:26:20 -0300] StopJob: printer state is 3
    D [21/Jun/2005:18:39:22 -0300] AcceptClient: 5 from 192.168.1.2:631.
    D [21/Jun/2005:18:39:22 -0300] ReadClient: 5 GET /printers/HP3740 HTTP/1.1
    D [21/Jun/2005:18:39:22 -0300] CGI /usr/local/libexec/cups/cgi-bin/printers.cgi started - PID = 53901
    I [21/Jun/2005:18:39:22 -0300] Started "/usr/local/libexec/cups/cgi-bin/printers.cgi" (pid=53901)
    D [21/Jun/2005:18:39:22 -0300] SendCommand: 5 file=8
    D [21/Jun/2005:18:39:22 -0300] AcceptClient: 7 from localhost:631.
    D [21/Jun/2005:18:39:22 -0300] ReadClient: 7 POST / HTTP/1.1
    D [21/Jun/2005:18:39:22 -0300] ProcessIPPRequest: 7 status_code=1
    D [21/Jun/2005:18:39:22 -0300] ReadClient: 7 POST / HTTP/1.1
    D [21/Jun/2005:18:39:22 -0300] ProcessIPPRequest: 7 status_code=1
    D [21/Jun/2005:18:39:22 -0300] ReadClient: 7 POST / HTTP/1.1
    D [21/Jun/2005:18:39:22 -0300] ProcessIPPRequest: 7 status_code=1
    D [21/Jun/2005:18:39:22 -0300] CloseClient: 7
    D [21/Jun/2005:18:39:22 -0300] ReadClient: 5 GET /favicon.ico HTTP/1.1
    D [21/Jun/2005:18:39:22 -0300] SendError: 5 code=404 (Not Found)
    D [21/Jun/2005:18:39:22 -0300] CloseClient: 5

  4. Seu serividor de impressão responde quando vc digita http://localhost:631?

    São Windows 98?



  5. Pessoal,

    Acabei de fazer funcionar, mas...
    Se eu mandar um teste de impressão pelo gerenciador do CUPS, a impressão chega na impressora ligada no WinXP mas nao imprime.No XP, adicionei uma impressora, como se fosse da rede \\servidorcups\impressora e dessa forma imprime. Estranho não?
    Outro problema é q parece q a impressora está imprimindo o preto com o cartucho colorido (hp 3745)
    Estou usando o drive HP-DeskJet_3740hpijs.ppd. Mesmo configurando dentro das opções do CUPS não funciona.

    Alguém tem uma idéia?


    Obrigado!






Tópicos Similares

  1. Imprimir do CUPS em impressora no Windows
    Por aprendiz_ce no fórum Servidores de Rede
    Respostas: 1
    Último Post: 02-03-2009, 11:33
  2. CUPS em impressora compartilhada no Windows
    Por ferpa no fórum Servidores de Rede
    Respostas: 0
    Último Post: 04-10-2005, 16:04
  3. problema no cups para impressora de rede em estação windows
    Por quecosuix no fórum Servidores de Rede
    Respostas: 3
    Último Post: 29-12-2004, 12:33
  4. cups com impressora na estação windows
    Por herrera no fórum Servidores de Rede
    Respostas: 1
    Último Post: 13-12-2003, 10:01
  5. Imprimir em impressora Windows
    Por no fórum Servidores de Rede
    Respostas: 1
    Último Post: 27-01-2003, 09:39

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L