+ Responder ao Tópico



  1. #1
    -thiago-
    Visitante

    Padrão eth0 e eth1 mudando sozinhas

    Fala pessoal, estou tendo um probleminha em um cliente, jah é a terceira vez que ocorre, as interfaces de redes estão mudando sozinhas do nada, pelo menos eh o q parece, de eth0 vai p/ eth1 e vice-versa, alguém já viu algo parecido, o q fazer ???

  2. #2
    -thiago-
    Visitante

    Padrão eth0 e eth1 mudando sozinhas

    Ah, esqueci de dizer, estou utilizando o Suse Linux Enterprise Server 9



  3. #3
    fabricio_
    Visitante

    Padrão eth0 e eth1 mudando sozinhas

    nao sei o motivo disso ... mas acho que se vc fixar os macs de cada placa no respectivo arquivo ( ifcfg-eth0 , ifcfg-eth1 ) creio que nao mude mais ...

  4. #4
    Kablu
    Visitante

    Padrão eth0 e eth1 mudando sozinhas

    Verifique a existência de algum arquivo ifcfg-eth0 ou ifcfg-eth1 dentro das pastas:

    /etc/sysconfig/networking/devices

    ou

    /etc/sysconfig/networking/profiles/default


    Se tiver pode estar se embaralhando pois existe mais de um arquivo de configuracao para cada placa.

    Abraço! :good:



  5. #5
    -thiago-
    Visitante

    Padrão eth0 e eth1 mudando sozinhas

    Citação Postado originalmente por Kablu
    Verifique a existência de algum arquivo ifcfg-eth0 ou ifcfg-eth1 dentro das pastas:

    /etc/sysconfig/networking/devices

    ou

    /etc/sysconfig/networking/profiles/default


    Se tiver pode estar se embaralhando pois existe mais de um arquivo de configuracao para cada placa.

    Abraço! :good:
    Achei estes arquivos...

    /etc/sysconfig/network # ls ifcfg*
    ifcfg-eth-id-00:0a:5e:06:a3:3a ifcfg-eth-id-00:e0:7d:e3:5e:f9 ifcfg-lo ifcfg.template

  6. #6
    -thiago-
    Visitante

    Padrão eth0 e eth1 mudando sozinhas

    O conteúdo dos mesmos:

    cat ifcfg-eth-id-00\:0a\:5e\:06\:a3\:3a
    BOOTPROTO='static'
    MTU=''
    REMOTE_IPADDR=''
    STARTMODE='onboot'
    UNIQUE='t2XO._iJPxW1IB2C'
    _nm_name='bus-pci-0000:02:09.0'
    BROADCAST='200.*.*.*'
    IPADDR='200.*.*.*'
    NETMASK='255.255.254.0'
    NETWORK='200.*.*.*'

    cat ifcfg-eth-id-00\:e0\:7d\:e3\:5e\:f9
    BOOTPROTO='static'
    BROADCAST='192.168.0.255'
    IPADDR='192.168.0.1'
    MTU=''
    NETMASK='255.255.255.0'
    NETWORK='192.168.0.0'
    REMOTE_IPADDR=''
    STARTMODE='onboot'
    UNIQUE='1HdK.IQxIdIhhuH7'
    _nm_name='bus-pci-0000:02:0b.0'


    Algo de errado ??



  7. #7
    Kablu
    Visitante

    Padrão eth0 e eth1 mudando sozinhas

    Verifique se o ip usado neles esta diferente do

    /etc/sysconfig/network-scripts/ifcfg-eth0

    /etc/sysconfig/network-scripts/ifcfg-eth1


    Se estiver diferente ta aí seu problema.
    Tente remover esses arquivos (guarde uma copia em outro dir antes) e veja o que acontece!


    Abraço! :good:

  8. #8
    -thiago-
    Visitante

    Padrão eth0 e eth1 mudando sozinhas

    Citação Postado originalmente por Kablu
    Verifique se o ip usado neles esta diferente do

    /etc/sysconfig/network-scripts/ifcfg-eth0

    /etc/sysconfig/network-scripts/ifcfg-eth1


    Se estiver diferente ta aí seu problema.
    Tente remover esses arquivos (guarde uma copia em outro dir antes) e veja o que acontece!


    Abraço! :good:
    Este caminho aí não existe na minha distro (Suse):
    find / -name ifcfg*
    find: /media/cdrom: No medium found
    find: /media/floppy: No medium found
    /etc/sysconfig/network/ifcfg-lo
    /etc/sysconfig/network/ifcfg.template
    /etc/sysconfig/network/ifcfg-eth-id-00:0a:5e:06:a3:3a
    /etc/sysconfig/network/ifcfg-eth-id-00:e0:7d:e3:5e:f9
    /usr/share/doc/packages/iproute2/ifcfg

    Achei este dir:
    /etc/sysconfig/network/scripts # ls -la if*
    lrwxrwxrwx 1 root root 11 2005-04-26 10:13 ifdown-802.1q -> ifup-802.1q
    lrwxrwxrwx 1 root root 11 2005-04-26 10:13 ifdown-autoip -> ifup-autoip
    -rwxr-xr-x 1 root root 7065 2004-07-01 09:36 ifdown-connection
    lrwxrwxrwx 1 root root 8 2005-04-26 10:13 ifdown-dsl -> ifup-dsl
    lrwxrwxrwx 1 root root 8 2005-04-26 10:13 ifdown-ppp -> ifup-ppp
    lrwxrwxrwx 1 root root 10 2005-04-26 10:13 ifdown-route -> ifup-route
    lrwxrwxrwx 1 root root 13 2005-04-26 10:13 ifdown-services -> ifup-services
    lrwxrwxrwx 1 root root 11 2005-04-26 10:13 ifstatus-802.1q -> ifup-802.1q
    lrwxrwxrwx 1 root root 11 2005-04-26 10:13 ifstatus-autoip -> ifup-autoip
    lrwxrwxrwx 1 root root 17 2005-04-26 10:13 ifstatus-connection -> ifdown-connection
    lrwxrwxrwx 1 root root 8 2005-04-26 10:13 ifstatus-dsl -> ifup-dsl
    lrwxrwxrwx 1 root root 8 2005-04-26 10:13 ifstatus-ppp -> ifup-ppp
    lrwxrwxrwx 1 root root 10 2005-04-26 10:13 ifstatus-route -> ifup-route
    lrwxrwxrwx 1 root root 13 2005-04-26 10:13 ifstatus-services -> ifup-services
    lrwxrwxrwx 1 root root 13 2005-04-26 10:13 ifstatus-wireless -> ifup-wireless
    -rwxr-xr-x 1 root root 2981 2004-07-01 09:36 ifup-802.1q
    -rwxr-xr-x 1 root root 5607 2004-07-01 09:36 ifup-autoip
    lrwxrwxrwx 1 root root 8 2005-04-26 10:13 ifup-dsl -> ifup-ppp
    -rwxr-xr-x 1 root root 3687 2004-07-01 09:36 ifup-ppp
    -rwxr-xr-x 1 root root 15855 2004-07-01 09:36 ifup-route
    -rwxr-xr-x 1 root root 3301 2004-07-01 09:36 ifup-services
    -rwxr-xr-x 1 root root 4078 2004-07-01 09:36 ifup-skel
    -rwxr-xr-x 1 root root 10678 2004-07-01 09:36 ifup-wireless



  9. #9
    Kablu
    Visitante

    Padrão eth0 e eth1 mudando sozinhas

    ishh... então não é isso não... :toim:

    vamos ver se algum especialista em suse resolve pra nós então...

    Abraço :good:

  10. #10
    haas
    Visitante

    Padrão eth0 e eth1 mudando sozinhas

    Isso ocorre durante a operação da máquina ou ele inverte as placas depois de um boot?



  11. #11
    -thiago-
    Visitante

    Padrão eth0 e eth1 mudando sozinhas

    Citação Postado originalmente por haas
    Isso ocorre durante a operação da máquina ou ele inverte as placas depois de um boot?
    Acredito que o servidor esteja reiniciando sozinho devido à problemas de energia no cliente, dei um uptime e constatei isto:
    10:52am up 2 days 1:55, 1 user, load average: 0.11, 0.07, 0.03

    O problema ocorreu realmente à dois dias atraz, então acredito que ele esteja invertendo depois do boot...

  12. #12
    -thiago-
    Visitante

    Padrão eth0 e eth1 mudando sozinhas

    up



  13. #13
    -thiago-
    Visitante

    Padrão eth0 e eth1 mudando sozinhas

    ei pessoal, vamos lá, socorro !


  14. #14
    Visitante

    Padrão eth0 e eth1 mudando sozinhas

    Instale outra distro.



  15. #15
    -thiago-
    Visitante

    Padrão eth0 e eth1 mudando sozinhas

    Citação Postado originalmente por Anonymous
    Instale outra distro.
    Bom dia Sr. "Visitante", este não eh o objetivo, pois tenho mais alguns servers com SLES 9 rodando perfeitamente, o objetivo aqui é descobrir a solução do problema, mas blz, pessoal, ainda não consegui descobrir nada...

  16. #16
    Celso_Suzuki
    Visitante

    Padrão eth0 e eth1 mudando sozinhas

    Oi,

    Já que voce tem outra máquinas com o SUSE, poderia verifcar como são os arquivos de configuração de rede ? Se são ifcfg-eth-MAC ou são ipcfg-eth0 ???
    É que se não me engano em algumas máquinas SUSE que instalei eram como ipcfg-eth0 e não ipcfg-ethMAC ..... Se bem que isto não deveria alterar, visto que voce está configurando por MAC.....
    Mas verifique, por favor.
    Eu concordo com os outro que no arquivo de configuração tenha o MAC, nunca tinha visto o seu caso em que o nome do arquivo estava o MAC.



  17. #17
    -thiago-
    Visitante

    Padrão eth0 e eth1 mudando sozinhas

    Citação Postado originalmente por Celso_Suzuki
    Oi,

    Já que voce tem outra máquinas com o SUSE, poderia verifcar como são os arquivos de configuração de rede ? Se são ifcfg-eth-MAC ou são ipcfg-eth0 ???
    É que se não me engano em algumas máquinas SUSE que instalei eram como ipcfg-eth0 e não ipcfg-ethMAC ..... Se bem que isto não deveria alterar, visto que voce está configurando por MAC.....
    Mas verifique, por favor.
    Eu concordo com os outro que no arquivo de configuração tenha o MAC, nunca tinha visto o seu caso em que o nome do arquivo estava o MAC.
    Fala Celso, obrigado pela atenção, acabei de verificar em outro server Suse que está perfeitamente funcionando, e é ifcfg-eth-MAC... :good:

  18. #18
    haas
    Visitante

    Padrão eth0 e eth1 mudando sozinhas

    Já experimentou desligar o sistema PNP da bios e atribuir um IRQ diferente para cada placa de rede?

    Eu experimentaria fazer isso primeiro, se não desse certo faria uma atualização da bios.

    Outra coisa, suas placas são do mesmo modelo? Já tive problemas de indentificação de placa de rede no Linux quando usava mais de uma, isso se fossem iguais. Substituí por placas melhores tipo 3com, daí ficou tudo funcionando!