+ Responder ao Tópico



  1. #1
    fabricio_
    Visitante

    Padrão erro ao compilar o kernel

    estou tentando compilar o kernel 2.6.12 no slackware 10.1
    qndo eu do o make aparece o seguinte erro
    Código :
    bash-3.00# make
      CHK     include/linux/version.h
      UPD     include/linux/version.h
      SPLIT   include/linux/autoconf.h -> include/config/*
      CC      arch/i386/kernel/asm-offsets.s
    In file included from include/linux/spinlock.h:12,
                     from include/linux/capability.h:45,
                     from include/linux/sched.h:7,
                     from arch/i386/kernel/asm-offsets.c:7:
    include/linux/thread_info.h: In function `thread_info_init':
    include/linux/thread_info.h:46: error: structure has no member named `generic'
    include/linux/thread_info.h:46: error: structure has no member named `generic'
    include/linux/thread_info.h:46: error: structure has no member named `generic'
    include/linux/thread_info.h:46: error: structure has no member named `generic'
    include/linux/thread_info.h:47: error: structure has no member named `generic'
    make[1]: ** [arch/i386/kernel/asm-offsets.s] Erro 1
    make: ** [arch/i386/kernel/asm-offsets.s] Erro 2




    o que faço ? ;/

  2. #2

    Padrão erro ao compilar o kernel

    Este erro aparece em que parte da compilação?

    Você chega a escolher as opções do make config?
    Até onde ele foi certinho até aparecer este erro?

    Abraços.



  3. #3
    fabricio_
    Visitante

    Padrão erro ao compilar o kernel

    jah consegui!
    apenas descompactei o source do kernel dnovo e foi ...

    mas agora esta dando esse erro no boot :
    Código :
    VFS: Cannot open root device or unknown-block (0,0)
    Please append a correct "root=" boot option
    Kernel Panic - not syncing : VFS : Unable to mount root fs on unknown-block(0,0)

    to usando grub e meu menu.lst eh esse
    Código :
     
        title Linux 2.6.12
         root (hd0,5)
         kernel (hd0,5)/boot/vmlinuz root=/dev/hda6
     
     
        title Linux 2.4.9
         root (hd0,5)
         kernel (hd0,5)/boot/vmlinuz.2.4.9 root=/dev/hda6
     
    # Para boot com Windows 9x, ME, NT, 2000, XP.
         title Windows XP
         unhide (hd0,1)
         rootnoverify (hd0,1)
         chainloader  +1
         makeactive

    alguem ajuda ? ;/

  4. #4
    fabricio_
    Visitante

    Padrão erro ao compilar o kernel

    recompilei o kernel e nada .... tb recompilei o 2.4.9 e tb dah a mesma coisa ..
    tah ficando dificil .. sera que nao tem um grupo de discussão sobre kernel nao ?? adoro grupos de discussao =D



  5. #5
    mcm
    Visitante

    Padrão erro ao compilar o kernel

    Cara, para que o kernel não dê kernel panic sem a utilização de initrd, você tem que adicionar como built-in o seguinte:

    - O chipset da sua controladora de discos
    - O seu filesystem
    - Drivers para seus discos (IDE ou SCSI).

    Essas partes sendo construídas no kernel como built-in, não haverá mais kernel panic por falta de módulo em boot.

    Qual seu FileSystem?

  6. #6
    fabricio_
    Visitante

    Padrão erro ao compilar o kernel

    ext3 , lembro de ter colocado built-in ... coloquei ext2 e ext3 como built-in , algum problema nisso ?
    tou no serviço qndo chegar em casa posto meu .config

    outra coisa , em casa eu testei com initrd e tb deu o mesmo problema :S



  7. #7
    fabricio_
    Visitante

    Padrão erro ao compilar o kernel

    jah arrumei , soh pra constar eh que eu estava tirando o suporte a ATA/IDE ...

    agora eu to com outro problema , nao to conseguindo ele aceitar LVM ewu crio o kernel com suporte a MD (raid) e LVM mas mesmo assim ele nao aceita .. qndo eu tento mexe em algo relacionado a LVM ele me da essa msg
    Código :
    [email protected]_:/39 vgdisplay 
    vgdisplay -- LVM driver/module not loaded?


    help ? ;D

  8. #8
    mcm
    Visitante

    Padrão erro ao compilar o kernel

    Cara, o suporte à carregamento automático de módulos está habilitado?

    Tente carregar o módulo de LVM antes do lvgdisplay.

    Vale lembrar que quando eu construí um kernel pra um servidor que usava LVM eu deixei o LVM como built-in (assim eu não ia precisar editar o initrd, essas coisas).

    []!



  9. #9
    fabricio_
    Visitante

    Padrão erro ao compilar o kernel

    Citação Postado originalmente por mcm
    Cara, o suporte à carregamento automático de módulos está habilitado?

    Tente carregar o módulo de LVM antes do lvgdisplay.

    Vale lembrar que quando eu construí um kernel pra um servidor que usava LVM eu deixei o LVM como built-in (assim eu não ia precisar editar o initrd, essas coisas).

    []!
    esta sim com suporte a carregamento habilitado ... eh estranho ateh , pq pra ativar o LVM vc ativa raid tb , e nao quero mexer com raid ...
    é igual suporte a disco SCSI q eu tiro e sempre qndo tah iniciando aparece uma msg falando sobre ...

    e como q eu carrego o modulo do LVM ?? desculpa sou novo nisso ;// :roll:

  10. #10
    Visitante

    Padrão erro ao compilar o kernel

    Citação Postado originalmente por fabricio_
    Citação Postado originalmente por mcm
    Cara, o suporte à carregamento automático de módulos está habilitado?

    Tente carregar o módulo de LVM antes do lvgdisplay.

    Vale lembrar que quando eu construí um kernel pra um servidor que usava LVM eu deixei o LVM como built-in (assim eu não ia precisar editar o initrd, essas coisas).

    []!
    esta sim com suporte a carregamento habilitado ... eh estranho ateh , pq pra ativar o LVM vc ativa raid tb , e nao quero mexer com raid ...
    é igual suporte a disco SCSI q eu tiro e sempre qndo tah iniciando aparece uma msg falando sobre ...

    e como q eu carrego o modulo do LVM ?? desculpa sou novo nisso ;// :roll:
    alguem tem ideia doq seja ?? jah habilitei no kernel ... como built in mesmo e mesmo assim nao vai ...
    e como eu carrego na mao o modulo do LVM ??