+ Responder ao Tópico



  1. #1

    Padrão ADSL - Help

    Boa tarde galera e um ótimo 7 de Setembro para todos.

    Vamos ao que enteressa...rs

    Coloquei uma ADSL com IP dinamico em meu servidor, agora toda vez que a criança muda de IP tenho que fazer ateraçções no route default (isto já estava na kra...rs).
    Como eu poderia fazer para solucionar este problema?

    Obs.: Meu servidor é OpenBSD

    Muito obrigado a todos

    PS.: Ei... antes que eu me esqueça ficou maneiro o forums agora

  2. #2

    Padrão ADSL - Help

    car...

    nesse caso vc cria a rota pela interface e nao pelo IP

    tipo...

    route add default gw ppp0

    valew



  3. #3

    Padrão ADSL

    Ok garoto muito obrigado...

    :clap: :clap: :clap:
    :good:

  4. #4
    slackrio
    Visitante

    Padrão adsl

    Eu tb uso Adsl e ip dinamico e faço da seguinte maneira

    no ppoe.conf la tem os dns (coloquei os da telemar) blz
    e no rc.local toda isso

    echo "Conectando a Internet ..."

    adsl-start

    # Ativando eth0 em 192.168.0.1 e servidor DHCP na rede interna

    ifconfig eth0 192.168.0.1 netmask 255.255.255.0 up
    dhcpd eth0

    # ativando o compartilhamento co da internet (pppoe) com as estacoes
    iptables -t nat -A POSTROUTING -o ppp0 -j MASQUERADE


    tenho duas placas de rede uma para ir direto ao modem adsl e a outra no hub indo para as maquinas

    no rc.inet1.conf nao coloca nenhum ip la deixa tudo em branco sem ips.



    desta forma meu server conecta normal e ainda as maquinas navegam tb
    e tenho apache com php rodando quando atualizo meu site pelo no-ip.com
    desta forma mesmo tendo ip diferente o usuario sempre achara minha pagina no ar assim que reiniciar o servidor tento ip diferente da adsl ( foi so um comentario fora a parte de como eu to usando ok)



  5. #5
    itamarjp
    Visitante

    Padrão ispbrasil

    Coloca o seu modem em modo router.

    http://www.abusar.org

  6. #6

    Padrão ADSL - Helpe

    Beleza galera.

    Uma outra coisa que eu fiz foi a seguinte:

    route add default 200.101.108.254

    (inet 200.96.162.209 --> 200.101.108.254 netmask 0xffffffff)

    adicionei o comando no meu rc.local
    Ficou legal...rs

    Pelo menos quando eu reiniciei a máquina não foi preciso readicionar e nestes dois dias não caiu mais.

    Parabens o para nois....rsrsrs



  7. #7

    Padrão Re: ADSL - Helpe

    Citação Postado originalmente por wellingtonpg
    Beleza galera.

    Uma outra coisa que eu fiz foi a seguinte:

    route add default 200.101.108.254

    (inet 200.96.162.209 --> 200.101.108.254 netmask 0xffffffff)

    adicionei o comando no meu rc.local
    Ficou legal...rs

    Pelo menos quando eu reiniciei a máquina não foi preciso readicionar e nestes dois dias não caiu mais.

    Parabens o para nois....rsrsrs
    cara...

    tipo... pelo q deu a tender vc colocou como gw padrão o endereço do provedor? foi isso??

    qdo a rota padrão era ppp0 não funcionou??

    e se os caras mudarem este enereço??

    valew