+ Responder ao Tópico



  1. #1
    Redy
    Visitante

    Padrão Erro na instalação do PHP 5.0.5

    Ta acontecendo um erro na instação do PHP 5.0.5, quando dou o comando ./configure aparece a seguinte mensagem:

    loading cache ./config.cache
    checking host system type... i686-pc-linux-gnu
    checking for gcc... gcc
    checking whether the C compiler (gcc ) works... yes
    checking whether the C compiler (gcc ) is a cross-compiler... no
    checking whether we are using GNU C... yes
    checking whether gcc accepts -g... yes
    checking whether gcc and cc understand -c and -o together... yes
    checking how to run the C preprocessor... gcc -E
    checking for AIX... no
    checking if compiler supports -R... no
    checking if compiler supports -Wl,-rpath,... yes
    checking for re2c... exit 0;
    checking whether ln -s works... yes
    checking for gawk... gawk
    checking for bison... no
    checking for byacc... no
    configure: warning: You will need bison if you want to regenerate the PHP parsers.
    checking for flex... lex
    checking for yywrap in -ll... no
    checking lex output file root... ./configure: line 2428: lex: command not found
    configure: error: cannot find output from lex; giving up


    O que posso fazer?
    O apache já está instalado a versão do apache é 2.0.54, a distribuição que está sendo usada é Mandriva Linux 2006 BETA, o computador é bom para o uso do servidor a configuração é:

    P4 3.0 HT - 1MB Cache
    1024 de Mémoria (Dual Channel)


    Bom a bastante para um servidor. Tenho o windows instalado só para imprimir documentos.

    Espero que me ajudem.

  2. #2
    Super_Diaulas
    Visitante

    Padrão Erro na instalação do PHP 5.0.5

    achoq é problema de dependencia...dê uma procurada no google



  3. #3
    Redy
    Visitante

    Padrão Não achei

    Não achei nada sobre. Qual outro jeito que eu posso instalar o PHP, o apache e o SQL já estão instalados, aguardo ajuda.

    Espero não ter que fazer esse servidor no Windows estou bem com linux por enquanto.

  4. #4
    Super_Diaulas
    Visitante

    Padrão Erro na instalação do PHP 5.0.5

    Vc não te nenhum gerenciador de pacotes
    tipo rpm ou apt no mandriva
    tenta por eles pelo visto falta algo relacionado ao lex



  5. #5

    Padrão Estranho

    ./configure sem nada ???


    ./configure --prefix=/usr --with-apxs2= ???
    manda o comando todo por favor fui

  6. #6
    Super_Diaulas
    Visitante

    Padrão Erro na instalação do PHP 5.0.5

    very good
    i have installed the programs bison, flex, and yacc.
    php is installed.
    big thx @ Jim ^^
    http://www.phpbuilder.com/lists/php-...03081/0052.php


    Sem querer ser chato, mas achei isso no google
    pelo visto vc precisa do bison, flex e yacc



  7. #7
    Super_Diaulas
    Visitante

    Padrão Re: Estranho

    Citação Postado originalmente por wps
    ./configure sem nada ???


    ./configure --prefix=/usr --with-apxs2= ???
    manda o comando todo por favor fui
    o que vem depois do configure são opções, na maioria das vezes não são necessários, pelo menos nunca vi uma opção do configure de outros softwares q seja necessário para instalar, salvo excessões como vc instalou o apache em outro local ou suporte á algum periférico...........

  8. #8
    Redy
    Visitante

    Padrão Tentei

    Tentei o configure de varios modos, tentei seguir varios artigos aqui do UnderLinux mas nada.



  9. #9
    Super_Diaulas
    Visitante

    Padrão Erro na instalação do PHP 5.0.5

    Citação Postado originalmente por Super_Diaulas
    very good
    i have installed the programs bison, flex, and yacc.
    php is installed.
    big thx @ Jim ^^
    http://www.phpbuilder.com/lists/php-...03081/0052.php


    Sem querer ser chato, mas achei isso no google
    pelo visto vc precisa do bison, flex e yacc
    vc leu meu post anterior?

  10. #10
    Redy
    Visitante

    Padrão Erro na instalação do PHP 5.0.5

    Super_Diaulas o problema era esse instalei o Bison, flex e lex e funcionou, desulpe por não responder, mas assim que instalei os programas e deu um ./configure funcionou. Fiz tudo certo na configuração do php mas quando fui testar uma página em PHP não funcionou, o que pode ser?



  11. #11
    Super_Diaulas
    Visitante

    Padrão Erro na instalação do PHP 5.0.5

    cara....vamos por partes.....

    OBS: Não manjo nada sobre PHP+APache+MYSQL, apenas instalei no meu micro em casa para aprender PHP

    vamos ver se o apache funfa, vai no console mesmo e digita

    lynx http://127.0.0.1/

    ele vai abrir um html do apache dizendo que funcionou, se vc não colocou nada no lugar, se colocou cria um html qualquer e vamos testar com ele

    depois tu pega teu script de php e faz isso no console

    # php /home/EU/meu_script.php

    ele vai rodar teu php.

    A partir destes testes poderemos descobrir onde está o problema.

  12. #12
    Redy
    Visitante

    Padrão Erro na instalação do PHP 5.0.5

    Esquece.



  13. #13
    Super_Diaulas
    Visitante

    Padrão Erro na instalação do PHP 5.0.5

    ???????????????


    Conseguiu?

  14. #14
    Redy
    Visitante

    Padrão Erro na instalação do PHP 5.0.5

    Desculpe, causa mais problemas. Já havia conseguido.



  15. #15
    Super_Diaulas
    Visitante

    Padrão Erro na instalação do PHP 5.0.5

    o único problema seria eu ficar sem saber se deu certo ou não, fora isso não existe problema algum........



  16. #16
    Redy
    Visitante

    Padrão Erro na instalação do PHP 5.0.5

    Cara, você me ajudou muito. Funcionou sim.