+ Responder ao Tópico



  1. #1

    Padrão Problemas com apt-get...

    Oi pessoal,

    Depois do último update nas listas do apt venho enfrentando um probleminha pra instalar os programas.

    Já tentei instalar 3 programas diferentes e é retornada a mensagem abaixo:

    [email protected]:/mnt/hdb2# apt-get -s install nrg2iso
    Lendo Lista de Pacotes... Pronto
    Construindo Árvore de Dependências... Pronto
    Os pacotes extra a seguir serão instalados:
    coreutils e2fslibs e2fsprogs initscripts libacl1 libblkid1 libc6 libc6-dev libss2 libuuid1 sysvinit
    Suggested packages:
    gpart e2fsck-static locales glibc-doc
    Os pacotes a seguir serão REMOVIDOS:
    initrd-tools
    Os NOVOS pacotes a seguir serão instalados:
    e2fslibs initscripts libacl1 libss2 libuuid1 nrg2iso
    6 pacotes atualizados, 6 novos instalados, 1 a serem removidos e 449 não atualizados.
    Remv initrd-tools (0.1.82 Debian:testing)
    E: Esta execução de instalação irá requerer remover temporariamente o pacote essencial e2fsprogs devido a um loop de Conflitos/Pré-Dependências. Isso geralmente é ruim, mas se você realmente quer fazer isso, ative a opção APT::Force-LoopBreak.
    E: Internal Error, Could not early remove e2fsprogs
    Todos os 3 programas citavam a remoção temporária do mesmo pacote (e2fsprogs). Estou com medo de fazer a instalação e ter problemas e também não tenho como fazer backup agora. O que devo fazer? Alguém já passou por isso?

  2. #2
    Visitante

    Padrão Re: Problemas com apt-get...

    Citação Postado originalmente por Lipse
    Oi pessoal,

    Depois do último update nas listas do apt venho enfrentando um probleminha pra instalar os programas.

    Já tentei instalar 3 programas diferentes e é retornada a mensagem abaixo:

    [email protected]:/mnt/hdb2# apt-get -s install nrg2iso
    Lendo Lista de Pacotes... Pronto
    Construindo Árvore de Dependências... Pronto
    Os pacotes extra a seguir serão instalados:
    coreutils e2fslibs e2fsprogs initscripts libacl1 libblkid1 libc6 libc6-dev libss2 libuuid1 sysvinit
    Suggested packages:
    gpart e2fsck-static locales glibc-doc
    Os pacotes a seguir serão REMOVIDOS:
    initrd-tools
    Os NOVOS pacotes a seguir serão instalados:
    e2fslibs initscripts libacl1 libss2 libuuid1 nrg2iso
    6 pacotes atualizados, 6 novos instalados, 1 a serem removidos e 449 não atualizados.
    Remv initrd-tools (0.1.82 Debian:testing)
    E: Esta execução de instalação irá requerer remover temporariamente o pacote essencial e2fsprogs devido a um loop de Conflitos/Pré-Dependências. Isso geralmente é ruim, mas se você realmente quer fazer isso, ative a opção APT::Force-LoopBreak.
    E: Internal Error, Could not early remove e2fsprogs
    Todos os 3 programas citavam a remoção temporária do mesmo pacote (e2fsprogs). Estou com medo de fazer a instalação e ter problemas e também não tenho como fazer backup agora. O que devo fazer? Alguém já passou por isso?
    Problemas com apt vixi nem sei muito mas tente remover os pacotes atualizados e depois instale-os novamente



  3. #3

    Padrão Problemas com apt-get...

    Olá! Eu já tive uns problemas com o APT, não me recordo se me retornavam esse erro, mas quando os tinha acabava resolvendo com o seguinte comando:

    apt-get -f install

    Ele resolvia as dependências que estavam com problema!

    Se isso não resolver, você pode tentar remover as entradas que foram recentemente adicionadas no sources.list e executar:

    apt-get clean
    apt-get update

    E ai você pode tentar instalar esse programa que você quer novamente!

    Caso continue tendo problemas, ai eu recomendo ir para o source do programa e compilar ele na mão!

    Bom, qualquer coisa poste ai!

    Falows... :good: :good:

    André

  4. #4

    Padrão Problemas com apt-get...

    Dei o apt-get -s install, aliás, já tinha dado esse comando antes, mas não há problemas pra corrigir.

    O negócio é o seguinte, pra instalar alguns pacotes, é preciso remover temporariamente um outro por questões de conflito. Só que esse pacote a ser removido, é essencial para o funcionamento do sistema, de acordo com o apt.

    O que eu quero saber é se esse tal pacote (e2fsprogs) é realmente tão essencial que não pode ser removido por alguns minutos e depois reinstalado?

    Bom, fico no aguardo.

    Mesmo assim, valeu pessoal.



  5. #5

    Padrão Problemas com apt-get...

    Mensagem repetida.

  6. #6
    fabriciolf
    Visitante

    Padrão Problemas com apt-get...

    Citação Postado originalmente por Lipse
    Dei o apt-get -s install, aliás, já tinha dado esse comando antes, mas não há problemas pra corrigir.

    O negócio é o seguinte, pra instalar alguns pacotes, é preciso remover temporariamente um outro por questões de conflito. Só que esse pacote a ser removido, é essencial para o funcionamento do sistema, de acordo com o apt.

    O que eu quero saber é se esse tal pacote (e2fsprogs) é realmente tão essencial que não pode ser removido por alguns minutos e depois reinstalado?

    Bom, fico no aguardo.

    Mesmo assim, valeu pessoal.

    meu caro Lipse...

    hj me confrontei com o mesmo problema ao tentar atualizar o clamav em um dos meus servidores...
    tudo o q a galera postou eu tb ja fiz... e NADA de dar certo..
    ja to com antipatia desse e2fsprogs kra!!!

    espero pode contar com a ajuda dos amigos,
    e se eu conseguir resolver, eu posto aki o resultado ok!

    [ ]´s



  7. #7
    Visitante

    Padrão Re: Problemas com apt-get...

    Estou passando por isso neste exato momento...
    olha.. estou perdido... não sei mais o que fazer!!!
    Já tentei de tudo!!!

  8. #8
    mmedinabr
    Visitante

    Padrão Apt-get e2fsprogrs - RESOLVIDO

    Olá,
    Pessoal, fiz uma instalacao nova e ao iniciar o apt-get upgrade, ocorreu a mesma mensagem de erro do apt-get e2fsprogs, depois de varios testes, observei que no arquivo /etc/apt/sources.list estava baixando a versao testing, alterei para stable e deu certo.
    olha ai o meu /etc/apt/sources.list
    #deb file:///cdrom/ sarge main
    deb http://mirrors.kernel.org/debian/ stable main
    deb-src http://mirrors.kernel.org/debian/ stable main
    deb http://security.debian.org/ stable/updates main

    após a alteracao, executei os seguintes comandos:
    apt-get clean
    apt-get -f install
    apt-get upgrade

    fiz uma instalacao e deu certo, espero ter ajudado.



  9. #9
    fabriciolf
    Visitante

    Padrão Re: Apt-get e2fsprogrs - RESOLVIDO

    Citação Postado originalmente por mmedinabr
    Olá,
    Pessoal, fiz uma instalacao nova e ao iniciar o apt-get upgrade, ocorreu a mesma mensagem de erro do apt-get e2fsprogs, depois de varios testes, observei que no arquivo /etc/apt/sources.list estava baixando a versao testing, alterei para stable e deu certo.
    olha ai o meu /etc/apt/sources.list
    #deb file:///cdrom/ sarge main
    deb http://mirrors.kernel.org/debian/ stable main
    deb-src http://mirrors.kernel.org/debian/ stable main
    deb http://security.debian.org/ stable/updates main

    após a alteracao, executei os seguintes comandos:
    apt-get clean
    apt-get -f install
    apt-get upgrade

    fiz uma instalacao e deu certo, espero ter ajudado.

    eu fiz um processo parecido... e deu certo tb...

    para atualizar qualquer pacote, esse e2fsprogs estava dando pau...
    dai fui no www.debian.org... e verifiquei quais pacotes faziam parte de suas dependencias..... e tinha alguns q naum haviam sido instalados..
    entao baixe-os e fiz a instalancao via dpkg!!

    pow.. foi show... depois de acertado...
    foi fazer o mesmo processo:
    #apt-get clean
    #apt-get -f install
    #apt-get upgrade


    e esta resolvido o problema... e pronto para instalar/atualizar os demais pacotes....

    espero que com isso os amigos que estava com esse mesmo problema consigam resolve-lo...

    postem ai depois..

  10. #10

    Padrão Problemas com apt-get...

    mmedinabr,

    Obrigado pela dica, mas pra mim não é interessante usar os pacotes do stable, até pq, alguns dos pacotes que quero instalar e estão dando erro, já são os que se encontram no stable. Mesmo assim, muito obrigado.

    fabriciolf,

    Vou tentar fazer o que vc fez, tomara que dê certo.

    Valeu pessoal.



  11. #11
    Visitante

    Padrão Re: Problemas com apt-get...

    Citação Postado originalmente por Lipse
    Oi pessoal,

    Depois do último update nas listas do apt venho enfrentando um probleminha pra instalar os programas.

    Já tentei instalar 3 programas diferentes e é retornada a mensagem abaixo:

    [email protected]:/mnt/hdb2# apt-get -s install nrg2iso
    Lendo Lista de Pacotes... Pronto
    Construindo Árvore de Dependências... Pronto
    Os pacotes extra a seguir serão instalados:
    coreutils e2fslibs e2fsprogs initscripts libacl1 libblkid1 libc6 libc6-dev libss2 libuuid1 sysvinit
    Suggested packages:
    gpart e2fsck-static locales glibc-doc
    Os pacotes a seguir serão REMOVIDOS:
    initrd-tools
    Os NOVOS pacotes a seguir serão instalados:
    e2fslibs initscripts libacl1 libss2 libuuid1 nrg2iso
    6 pacotes atualizados, 6 novos instalados, 1 a serem removidos e 449 não atualizados.
    Remv initrd-tools (0.1.82 Debian:testing)
    E: Esta execução de instalação irá requerer remover temporariamente o pacote essencial e2fsprogs devido a um loop de Conflitos/Pré-Dependências. Isso geralmente é ruim, mas se você realmente quer fazer isso, ative a opção APT::Force-LoopBreak.
    E: Internal Error, Could not early remove e2fsprogs
    Todos os 3 programas citavam a remoção temporária do mesmo pacote (e2fsprogs). Estou com medo de fazer a instalação e ter problemas e também não tenho como fazer backup agora. O que devo fazer? Alguém já passou por isso?

  12. #12

    Padrão Problemas com apt-get...

    Tente

    #apt-get install -o apt::Force-LoopBreak=true PACOTE

    Aqui resolveu



  13. #13
    Sorte
    Visitante

    Padrão Problemas com apt-get...

    Ai galera aproveitando esse topico.. gostari de Saber se qlguem qui ja colocou o APT no Red Hat 3 ES.. Se colocou como fex ? .


    Obrigado ... Pela AJuda .

  14. #14

    Padrão Problemas com apt-get...

    Citação Postado originalmente por Sorte
    Ai galera aproveitando esse topico.. gostari de Saber se qlguem qui ja colocou o APT no Red Hat 3 ES.. Se colocou como fex ? .


    Obrigado ... Pela AJuda .
    Cara cria outro tópico pra tua questão, pra não embaralhar as coisas..



  15. #15
    Famelix
    Visitante

    Padrão Problemas com apt-get...

    eu so to postando pra agaradecer o W00dy entrei nos canais da brasnet de linux, unix, e tudo mais, a galera n sabia nada de debian, de comando apt-get so sabia do slack installpkg pacote, eu to com o sistema famelix e aparece e2fsprogs q n pode ser instalado faz 1 mes, q n consigo, ja estava desistindo de sistema baseado no debian, sem palavras pra descrever tua ajuda W00dy, ajudou me pra kramba, se é o maximo, to instalando amsn, agora com o forceloopbreak=true demais cara, tinha uns 9 conhecido com o mesmo problema, mais eu se resolveu problema de 10 nego numa soh tacada, devo agradecer ao google tb por eu ter axado esse topico, to digitando mto pq realmente suei a camisa e n consegui resolver agora se vem coma solucao, isso ae rpz continua assim q se tem futuro :P :clap:

  16. #16

    Padrão Problemas com apt-get...

    Citação Postado originalmente por Famelix
    eu so to postando pra agaradecer o W00dy entrei nos canais da brasnet de linux, unix, e tudo mais, a galera n sabia nada de debian, de comando apt-get so sabia do slack installpkg pacote, eu to com o sistema famelix e aparece e2fsprogs q n pode ser instalado faz 1 mes, q n consigo, ja estava desistindo de sistema baseado no debian, sem palavras pra descrever tua ajuda W00dy, ajudou me pra kramba, se é o maximo, to instalando amsn, agora com o forceloopbreak=true demais cara, tinha uns 9 conhecido com o mesmo problema, mais eu se resolveu problema de 10 nego numa soh tacada, devo agradecer ao google tb por eu ter axado esse topico, to digitando mto pq realmente suei a camisa e n consegui resolver agora se vem coma solucao, isso ae rpz continua assim q se tem futuro :P :clap:

    Hehehehe..

    Agora me achei a bala que matou Kennedy.. hauahuahau

    Cadastre-se no fórum, participa conosco. 50% do que sei aprendí aqui!

    :good: :good:



  17. #17
    rherison jhones
    Visitante

    Padrão usei o stable

    usei o
    #apt-get -t stable install package
    daí ta instalando agora o cupsys fluxbox e hpijs no dizinha linux...
    o caso é que to tentando remasterizar o dizinha mas to tendo problemas....
    mas valeu...espero que dê tudso certo aki....
    quem quiser me postar pra dar umas dicas ou mesmo falar comigo sobre qualquer coisa mande um email para mim no endereço:
    [email protected]
    t+