+ Responder ao Tópico



  1. #1
    lfss232
    Visitante

    Padrão Proxy Squid Lento

    Pessoal,

    Depois de digitar o usuário e a senha do proxy, demora muito para aparecer o site, antes não era assim.

    Será que alguém poderia me ajudar??

    Obrigado,

    6)

  2. #2
    wrochal
    Visitante

    Padrão Proxy Squid Lento

    Caro,

    Pode ser duas coisas:

    DNS, CACHE ou LOGS.

    Primeiramente verifique o dns em seu proxy

    Limpe o Cache

    squid -z

    E depois os logs, coloque no squid.conf:

    logfile_rotate 10

    E execute squid -k rotate

    Será criado outros logs.

    Falou,



  3. #3
    lfss232
    Visitante

    Padrão Proxy Squid Lento

    desculpe amigo, mas em que lugar do squid.conf devo colocar o logfile_rotate 10??

    Obrigado,

  4. #4

    Padrão Proxy Squid Lento

    Como já foi dito, o problema pode ser o tamanho dos teus arquivos de log. O access.log, store.log etc...
    É bom dar uma limpada neles de tempos em tempos.

    O teu squid.conf já deve ter essa linha logfile_rotate 10 só que deve estar comentada, aí é só tirar o # do início.

    Outra coisa é você ir no diretório onde estão os logs, talvez seja /var/log/squid/ e limpar 'à unha' eles. Dá um cat >access.log ou copia eles pra um diretório de backup.

    Imagine que esse proxy seja usado por 10 micros, todos eles navegando, fazendo download de arquivos, imagens, etc... pra cada página que um usuário acessa, é criado várias linhas no access.log. Agora imagine isso sendo feito pra 10 usuários, com downloads e várias página abertas ao mesmo tempo. Dá pra ter uma noção do quanto a máquina sobre pra abrir os arquivos de log, gravar os novos dados, salvar e sair... por isso é importante a limpeza.

    Abraço.



  5. #5

    Padrão Proxy Squid Lento

    Galera, esse post já foi comentado aqui tem pouco tempo.
    Teve várias páginas de membros dando soluções.
    Passamos por isso tem cerca de uns 2 meses se não me engano.
    A nossa funcionava legal. TEmos 3 servidores Conectiva Linux 8 e todos funcionam legal.
    Mas de repente o servidor da Internet ficou do jeito que o nosso amigo comentou. Usuário autenticava e ficava um bom tempo esperando a página abrir. Usuários irritados e reclamando do cpd.
    Chamamos a BrasilTelecom. Os caras vieram e de cara entraram no modem (Alcatel Speed Touch Pro) via telnet. E de cara o funcionário da Operadora nos mostrou quase todas as seções do modem ocupadas por Spyware, vindas de e-mail recebidos por funcionários. Tentando fazer conexões. Aí virou um verdadeiro inferno na empresa. 80 estações windows que temos na rede. Segundo o funcionário da BrasilTelecom, o modem tem 254 seções para dividir as solicitações a internet. E quase todas as seções ocupadas por spyware. Sobrava em média 7 ou 8 seções para dividir as solicitações dos usuários para navegarem.
    Vacinamos todas as máquinas. Voltou a funcionar normal. Mas infelizmente a empresa não quer investir em anti-virus ou anti-spyware pago para termos atualizações.
    Mas já sabemos o que faz isso no servidor da internet. Outra coisa. Não sei qual o modem que vc utiliza. Mas no Alcatel tem uma opção que você entra nele e muda uma opção para firewalling para on. Não sei se isso tem em todos os modens.
    Vá em www.abusar.org . Lá tem um milhão de tutoriais e informações sobre os mais diversos modens utilizados no Brasil.
    Com certeza, podes ver que alguma que está acontecendo na sua rede está relacionada ao seu modem. E é uma dorzinha de cabeça nada gostosa de passar.
    Um grande abraço, caro amigo .........

  6. #6
    lfss232
    Visitante

    Padrão Proxy Squid Lento

    Pessoal,

    descomentei o logfile_totate 10

    mas não resolveu nada, continua igual, mas obrigado pela ajuda!!

    6)



  7. #7
    fpmazzi
    Visitante

    Padrão Proxy Squid Lento

    brother ew tive um problema parecido com este, oq fiz:
    1º parei o squid
    2º fui em /var/spool/squid e apaguei literalmente tudo.
    3º fui em /var/log/squid e tambem apaguei tudo na mão.
    4º digitei o comando. squid -z #Serve para recriar os diretorios de swap
    5º restartei o squid.

    No meu caso resolveu, ou seja meu cache estava lotado.

    Um abraço

    :clap:

  8. #8
    lfss232
    Visitante

    Padrão Proxy Squid Lento

    Cara,

    Estpu limpando meu cache diariamente, mas não está resolvendo, quando apareceu o problema, a primeira coisa que pensei foi nos caches, então limpei tudo, mas sem sucesso!

    Mas obrigado pela ajuda,

    6)



  9. #9

    Padrão Proxy Squid Lento

    Também cheguei a fazer essa limpeza.
    Infelizmente não resolveu. No início deu a falsa impressão de uma certa rapidez. Mas com cerca de 2 a 3 dias a net ficava lenta novamente.
    :roll: :roll: :roll: