Visite: BR-Linux ·  VivaOLinux ·  Dicas-L


Página 5 de 5 PrimeiroPrimeiro 12345
+ Responder ao Tópico

  1. #21
    Citação Postado originalmente por The-shadow
    o patch tem de ser aplicado ás sources do kernel, e dps recompilar com algumas opçoes que raramente vêm habilitados num kernel padrão, por isso é que mta gente n consegue por isso a funfar com sucesso!

    aproveito para dizer que o kernel 2.6, já traz suporte a essa coisa duma maneira mais facil, é o chamado "channel bonding" pode ser encontrado na config do kernel netse menu:
    "Device Drivers" -->"Network Device Suport" --> "Bonding driver support"
    o unico problema é que este metodo só funciona sobre a layer 3, ou seja, ethernet.. como por exemplo cable modems, se vc usar modems ADSL, o PPPoE, já funca na layer2, e assim o bonding já n vai funcionar.. entao o que vc pode fazer é substituir os modems ADSL, por um router/modem.. e ligar esses mesmos ao servidor via ethernet, ou mto me engano, ou desse jeito já funciona..
    é uma questao de experimentar
    Um abraço
    The Shadow,

    Verifiquei no meu kernel e essa opção já está habilitada. Estou usando apenas interfaces ethernet ligadas diretamente a roteadores e não funciona.

    A rota fica gravada e começa a dar problemas na navegação.

    Esterei testando esse patch nessa semana e retorno ao news as novidades.

    Att,

    Nataniel Klug


  2.    Publicidade


  3. Ae eu tava vendo esse script juntei cmo outros bati bati e montei um
    queria saber pq minha eth2 onde ta a adsl so funciona quando uso
    ip route add default table adsl nexthop via 192.168.0.254 dev eth1 \
    weight 1 nexthop via xxx.xxx.xxx.126 dev eth2 weight 1

    no caso eu nao queria fazer 1 requisicao em cada gw se eu nao coloco isso e dou ping ping -I eth2 da host nao encontrado colocando issu ele pinga o host so q nao abre os site qd a requisicao eh pelo gw da adsl.

    alguem sabe o q posso fazer?

  4. Citação Postado originalmente por Huntersc
    Ae eu tava vendo esse script juntei cmo outros bati bati e montei um
    queria saber pq minha eth2 onde ta a adsl so funciona quando uso
    ip route add default table adsl nexthop via 192.168.0.254 dev eth1 \
    weight 1 nexthop via xxx.xxx.xxx.126 dev eth2 weight 1

    no caso eu nao queria fazer 1 requisicao em cada gw se eu nao coloco isso e dou ping ping -I eth2 da host nao encontrado colocando issu ele pinga o host so q nao abre os site qd a requisicao eh pelo gw da adsl.

    alguem sabe o q posso fazer?
    Hunter,

    Tu já leu meu tutorial?

    http://www.cnett.com.br/nata/tutorial.html (ou .htm, ele tá no Wiki também).

    Um dos motivos para isso é que tu precisa criar uma tabela de roteamento padrão para cada uma das interfaces externas, onde existirá uma rota default para que aquela interface saiba quem é.

    Outro ponto é que com o ping -I você deve sempre dar preferência de ping para IPs e não domínios. Se usar domínio tenha certeza de que seu /etc/resolv.conf aponta para um servidor de nomes aberto.

    Além disso se você roda o servidor de nomes nessa máquina, ele precisa de um "nexthop" para poder contactar outro DNS e receber o endereço de determinado site/host.

    Att,

    Nataniel Klug


  5.    Publicidade