Página 2 de 3 PrimeiroPrimeiro 123 ÚltimoÚltimo
+ Responder ao Tópico



  1. #6
    pablito
    Citação Postado originalmente por Avenger
    Tem um post meu aqui que eu expliquei algumas coisas que têm que ser feitas quando se atualiza um spamassassin velho pelo mais novo (principalmente para se aproveitar o máximo dele). Apesar de eu não ter passado por esse problema, aquele post deve te ajudar com esse problema. Vou procurar e volto a postar aqui. (qualquer coisa, se eu demorar, busque por posts meus que contenham 'spamassassin' e 'CPAN'.
    Eu já atualizei o spamassassin, aquela messagem não esta mais aparecendo. Quanto a isto, parece que esta tudo beleza. Depois que fiz a atualização foi apagado o script que ficava em /etc/init.d/spamassassin.
    Agora o spam não está iniciando no boot...

    Citação Postado originalmente por Avenger
    Sobre o seu progresso, acho que ele não foi lá essas coisas de bom não, heim... Talvez seja bom você tirar aquilo do .qmail-default e deixar como estava antes. Aquele .qmail-default só é ativado quando o destinatário de um e-mail que esteja tentando entrar no seu MTA não existe.
    Tente o seguinte: entre no diretório de um dos usuários que você criou, e coloque aquela linha do spamc num .qmail ali no diretório do usuário: aí sim você vai ter o resultado que espera. Provavelmente agora seu spamassassin não esteja funcionando. O meu 3.1.0 eu inicio o spamd com os parâmetros: -s null -L -x -D -u spamc (tem um usuário spamc para o spamassassin).
    E eu pensando que tinha feito progresso, ehhehehehhe. Já tirei do .qmail-default e coloquei no .qmail do usuário.

    Citação Postado originalmente por Avenger
    O Ideal seria que o spamassassin fosse executado a partir do seu simscan. No meu caso, mesmo o qmail-scanner tem alguns testes, no qmail-scanner independente do spamassassin que testa algumas coisas sobre o resultado do spamc/spamd. (a partir dos quais eu fiz meu scriptzinho de marcar spam a partir do reverso).
    O que eu fiz foi colocar no /var/qmail/control/simcontrol isto:
    :clam=yes,spam=yes,spam_hits=5

    E nada dos spams serem marcados....

  2. #7
    pablito
    Resolvi abri o fonte do emails que chegam e olhe o que achei...

    X-Spam-Checker-Version: SpamAssassin 3.1.0 (2005-09-13) on meuhost
    X-Spam-Level: **
    X-Spam-Status: No, score=2.7 required=5.0 tests=FRONTPAGE,HTML_90_100,
    HTML_MESSAGE,HTML_TAG_EXIST_TBODY,MIME_HTML_ONLY,SPOOF_OURI
    autolearn=no version=3.1.0

    Pelo jeito o problema agora esta nas regras do spamassassin que não pontua suficiente os spams que estou recebendo..

    E ainda tem alguns emails(poucos) que não tem nenhuma "X-Spam" no fonte..



  3. #8
    Avenger
    Então... Caça o meu post, lá fala como você utilizar o máximo do spamassassin 3.1.0 -- quando você atualiza ele desabilita umas coisas básicas por causa de licensas.

  4. #9
    pablito
    Como meu SA já era a versão mais nova não fiz instalação nenhuma. Quando fui no /etc/mail/spamassassin/ eu não tinho o init.pre não existia, apenas o v310.pre então foi só renomear e fazer as alterações do seu post https://under-linux.org/modules.php?...5755&highlight

    Ah, também fui neste site e baixei algunas regras.

    http://www.sounerd.com.br/index.php?...=119&Itemid=43

    Pronto, depois disso tudo meu SA tá funcionando beleza !! No webmail criou sozinho uma pasta com o nome Spam, onde todos emails marcados como spam são colocados lá dentro. Qual o problema dessa configuração ? Quando o usuário baixa seus emails só vem o que estiver na pasta Inbox e caso um email for marcado como spam indevidamente o usuário não vai recebe-lo.

    Vai ter que ir no webmail pra checar ?? Acho que Isso não é solução tão boa...

    Aê Avenger, valeu pela ajuda. Espero que este tópico aqui venha ajudar outras pessoas também...



  5. #10
    Avenger
    Não, não vai ter que ir pro webmail checar não. A diferença é que seu webmail é espertinho e já separa (me fala qual é aí prá mim usar também!..) os spams dos mails bunitinhos pro cliente poder olhar. Isso é recurso do seu webmail, e não do MTA em si.

    Pros clientes a princípio -verem- um spam lá pelo outlook por exemplo, eles vão ter que ficar olhando o cabeçalho do e-mail caçando por 'X-Spam-Status: Yes'. O ruim do outlook é que nele não tem como filtrar esse X-Spam-Status prá jogar em outra pasta ou coisa assim. Acho que o outlook do office 2000/XP já traz esse recurso!..

    O que eu faço aqui, é o cliente que quiser, tem o spam filtrado pelo MTA. Daí o servidor quando vê que x-spam tá yes, ele deleta o e-mail e nem deixa o mail na caixa do cliente -- mas ele tem opção de desabilitar isso!..






Tópicos Similares

  1. SPAMASSASSIN não bloqueia spam?
    Por ricardohb no fórum Servidores de Rede
    Respostas: 1
    Último Post: 24-01-2006, 12:43
  2. SpamAssassin nao esta bloqueando !!!!
    Por Geromel no fórum Servidores de Rede
    Respostas: 6
    Último Post: 27-07-2005, 14:30
  3. Spamassassin instalado mas nao bloqueando spam
    Por no fórum Servidores de Rede
    Respostas: 4
    Último Post: 19-07-2005, 10:38
  4. spamassin não barra spam
    Por Mav3r1ck no fórum Servidores de Rede
    Respostas: 5
    Último Post: 12-05-2005, 20:58
  5. SpamAssassin não funciona direito
    Por Boitata no fórum Servidores de Rede
    Respostas: 0
    Último Post: 05-05-2005, 13:32

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L