+ Responder ao Tópico



  1. Seguinte... quando me sobrar um pouco de tempo, vou traduzir um pedaço daquele texto, que explica detalhadamente como seria a técnica do NAT no balanceamento.

    Mas por alto eh o seguinte: O firewall fica responsavel por cuidar das conexoes existentes E NAO O CACHE DE ROTAS! E esse eh o detalhe.

    iptables -t filter -A PREROUTING -m state --state RELATED,ESTABLISHED \
    -j ACCEPT

    familiarizados com essa linha?

    Qd eu tiver mais tempo eu traduzo boa parte daquele tutorial para as coisas ficarem mais claras.

    Mas, continuo dizendo: Uso e abuso (e nao sou o unico) do load balance, com NAT e funciona perfeitamente sem queda de MSN e etc. Esta operando ja fazem 6 meses. Fiz o mesmo sistema para um amigo meu que tem um provedor wireless e este tb esta funcionando 100%.

    Portanto, nao desistam! FUNCIONA!

    Att,

    Guilherme

  2. entao vcs têm uma opção no kernel que é "IP: equal cost multipath" marcada?
    creio que isso tb tem de estar activado...pkausa do problema da cache =/
    ou entao, desistam do iproute2 e utilizem o driver que vem no kernel 2.4 e 2.6 que serve para o mesmo efeito

    "bonding driver support"



    caso isso tb n funcione, meus caros.. FreeBSD + PF r0x .. esse n dá estes problemas todos, Um abraço



  3. Pessoal, entao posta ai os scritps de balanceamento de voces estão usando.

    Discordo do firewall em relaçao ao roteamento pois é no roteamento (apos PREROUTING) que a interface de saida é decidida.

    Caminho:

    PRE (raw/mangle/nat) --->> (ROUTER) --> FORWARD (mangle/filter) --> POST (mangle/nat)

  4. Citação Postado originalmente por PatrickBrandao
    Pessoal, entao posta ai os scritps de balanceamento de voces estão usando.

    Discordo do firewall em relaçao ao roteamento pois é no roteamento (apos PREROUTING) que a interface de saida é decidida.

    Caminho:

    PRE (raw/mangle/nat) --->> (ROUTER) --> FORWARD (mangle/filter) --> POST (mangle/nat)
    Patrick,

    Meus testes todos foram em cima desse modelo (algumas linhas estão comentadas pq eu tava testando algumas mudanças):

    Código :
    #!/bin/sh
     
    IPT="/usr/local/sbin/iptables"
    IP="/sbin/ip"
     
    # Tabelas usadas
    L1="link1"
    L2="link2"
    MAIN="principal"
     
    # Enderecamento
    GW1="200.163.208.1"
    GW2="10.1.1.1"
    IF1="eth0"
    IF2="eth3"
    IP1="200.163.208.6"
    IP2="10.1.1.10"
    NM1="255.255.255.0"
    NM2="255.255.255.0"
    NW1="200.163.208.0/26"
    NW2="10.1.1.0/24"
     
    # adicionando multipath route
    $IP route del default table $MAIN
    $IP route add default table $MAIN proto static nexthop via $GW1 dev $IF1 weight 1 nexthop via $GW2 dev $IF2 weight 1
     
    # adicionando rotas padroes das tabelas L1
    #$IP rule add prio 201 from $NW1 table $L1
    #$IP route add default via $GW1 dev $IF1 src $IP1 proto static table $L1
    #$IP route append prohibit default table $L1 metric 1 proto static
     
    # adicionando rotas padroes das tabelas L2
    #$IP rule add prio 202 from $NW2 table $L2
    #$IP route add default via $GW2 dev $IF2 src $IP2 proto static table $L2
    #$IP route append prohibit default table $L2 metric 1 proto static
     
    $IP route flush cache

    Além disso tentei também assim:

    Código :
    $IPT -t mangle -A PREROUTING -m layer7 --l7proto msnmessenger -j MARK --set-mark 3001
     
    $IP rule add fwmark 3001 lookup table $L2

    Com isso esperava que os pacotes do MSN fossem enviados para o link2, mas não funcionou. Estou tentando fazer um novo box, mais potente, para que eu possa testar com mais calma.

    PS.: Ambas as interfaces de saída dos links estão mascaradas usando -o <interface> -j MASQUERADE.

    Att,

    Nataniel Klug



  5. Citação Postado originalmente por LEE337


    preferí usar um router com 2 WAN da marca xincom www.xincom.com :good: , faz 3 semanas q esta online e sem problemas.. só deu um problema quando caiu um dos link.. os cliente navegavam a medias (acho q o problema era DNS).. actualmente coloquei 90% em WAN1 e 10% em WAN2... quando tiver mais trafego penso colocar em 50% e 50%.

    dé uma olhada nos Firmware Revision History do equipo...
    http://www.xincom.com/support/twr502/firmrev502.html

    e quando tiver possibilidade penso adquirir o Linksys-Cisco RV016 q tem 7 WAN cool)

    Abraços
    Lee
    onde vc comprou o xincom e quanto pagou?






Tópicos Similares

  1. dois links em um servidor
    Por palozo no fórum Redes
    Respostas: 6
    Último Post: 06-01-2010, 10:51
  2. Unindo dois links em um unico servidor
    Por carniello no fórum Servidores de Rede
    Respostas: 3
    Último Post: 08-05-2009, 15:35
  3. Dois links em um mk
    Por Taigrobo no fórum Redes
    Respostas: 3
    Último Post: 31-07-2008, 01:46
  4. Dois Links em um só
    Por admskill no fórum Redes
    Respostas: 3
    Último Post: 29-11-2007, 22:15
  5. 2 links em um só servidor!!!
    Por SilenT no fórum Servidores de Rede
    Respostas: 3
    Último Post: 16-09-2004, 10:28

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L