Página 2 de 2 PrimeiroPrimeiro 12
+ Responder ao Tópico



  1. #21
    mushroom-br
    Visitante

    Padrão Squid demorando p/ autenticar

    Existe a possibilidade de alguma maquina na tua rede estar respondendo as requisições feitas ao teu squid e assim atrasando o login dos teus usuários?
    A porta que tu está usando no squid é a padrão?

    Como está o cache do teu squid? tem espaço?
    já tentou limpar o cache e ver se tem alguma diferença?

  2. #22

    Padrão Squid demorando p/ autenticar

    Citação Postado originalmente por Drozzini

    Ai está meu squid.conf caso ajude:

    http://www.zenisys.com.br/Docs/squid.conf
    Bom primeiramente obrigado por estar tentando me ajudar.
    Mas veja bem, a autenticação em linha de comando já é demorada, quer dizer, o problema está antes mesmo de passar pelo squid.

    Deve ter alguma coisa no sistema operacional, alguma permissão, alguma coisa que ainda não me toquei.

    Mas por enquanto obrigado. E continuo aceitando sugestões!



  3. #23

    Padrão Squid demorando p/ autenticar

    Citação Postado originalmente por mushroom-br
    Existe a possibilidade de alguma maquina na tua rede estar respondendo as requisições feitas ao teu squid e assim atrasando o login dos teus usuários?
    A porta que tu está usando no squid é a padrão?

    Como está o cache do teu squid? tem espaço?
    já tentou limpar o cache e ver se tem alguma diferença?
    Acho que por enquanto podemos descartar a hipotese do erro estar no squid ou na rede.
    Pois quando rodo o comando ncsa_auth senhas (que é meu arquivo de senhas) ele demora também e não me retorna nada.
    Ou seja, autenticando em linha de comando, sem usar nada na rede, tudo localmente no servidor e sem passar também pelo squid, mesmo assim não funciona.

  4. #24
    mushroom-br
    Visitante

    Padrão Squid demorando p/ autenticar

    Cara, sera que não é tua placa de rede que foi para o espaço?



  5. #25

    Padrão Squid demorando p/ autenticar

    Citação Postado originalmente por mushroom-br
    Cara, sera que não é tua placa de rede que foi para o espaço?
    Mas fazendo a autenticação na linha de comando nem usa a placa de rede e não funciona. É tudo local.

  6. #26
    mushroom-br
    Visitante

    Padrão Squid demorando p/ autenticar

    Deixa eu ver se entendi, tu está fazendo isso remotamente né?
    Ninguem criou uma regra nova no firewall?
    To tentando imaginar qualquer hipótese, mesmo que absurda. Desculpe-me se estou sendo chato com tantas perguntas.
    Um abraço e não desita!!



  7. #27

    Padrão Squid demorando p/ autenticar

    Capaz, tenho é que te agradecer por estar tentando me ajudar.
    Mas é o seguinte, moro em Cuiabá e este servidor está em outra cidade, não tenho acesso remoto pois não configurei ela para isso pois esta maquina está atráz de um adsl com as portas bloqueadas e por questões de tempo não instalei o no-ip e mexi nas portas, mas irei fazer isso assim que conseguir resolver o problema do proxy que é o que mais estamos precidando por em funcionamento agora. Então toda vez que vou para lá o acesso é local mesmo. nada remoto.

    Ninguém criou nenhuma regra no firewall pois sou a única pessoa lá que tem acesso á máquina. Mas mesmo que tivesse regra de fw ñ iria interferir pois é só um comando no shell, não usa a rede até então.

    Qualquer sugestão é bem vinda.

  8. #28

    Padrão Squid demorando p/ autenticar

    +- o loopback tem q estar liberado, isso afeta o desempenho de algumas aplicações sim



  9. #29

    Padrão Squid demorando p/ autenticar

    Citação Postado originalmente por Drozzini
    +- o loopback tem q estar liberado, isso afeta o desempenho de algumas aplicações sim
    E como verifico isso?

  10. #30
    mushroom-br
    Visitante

    Padrão Squid demorando p/ autenticar

    Procura no teu script de firewall as seguintes regras:

    iptables -A INPUT -i lo -j ACCEPT
    iptables -A OUTPUT -s 127.0.0.1 -d 127.0.0.1 -j ACCEPT

    Elas que liberam o loopback




  11. #31

    Padrão Squid demorando p/ autenticar

    Ainda não to com nenhuma regra de firewall .
    Ainda assim para garantir dei um iptables -F mas o erro continua.

    Sugestões ?

  12. #32

    Padrão Squid demorando p/ autenticar

    Po cara! Sei o que pode ser não. Tem certeza que esse hardware está legal ? Não tem outra maquina pra colocar no lugar pro enquanto pra testar essa ?



  13. #33

    Padrão Squid demorando p/ autenticar

    Vou testar e posto os resultados.

    Obrigado a todos por enquanto!

  14. #34

    Padrão Squid demorando p/ autenticar

    Citação Postado originalmente por gustavo_marcon
    Vou testar e posto os resultados.

    Obrigado a todos por enquanto!
    Pessoal, coloquei a hd na minha maquina pessoal, mas o delay na autenticação continua.

    Ninguém suspeita o q pode ser? Já to ficando doido com isso!



  15. #35

    Padrão Squid demorando p/ autenticar

    Eu continuo com o problema.

    Pessoal, o problema é o seguinte, logo que é fornecido um nome de usuário e senha o squid demora para carregar o site se os dados para login forem corretos ou para retornar pedindo um user/senha válidos, caso os dados sejam incorretos.
    Mas apartir do momento que ele carregar a página tudo vai normalmente, o problema está justamento no logon.


    Pessoal, eu imploro, me ajudem, to precisando muito disso.
    Sábado agora é meu prazo para entregar este servidor ao cliente.

  16. #36

    Padrão Squid demorando p/ autenticar

    Realmente parece que tem algo de errado aí na configuração, porque vc não usa nada mais do que um arquivo com o ncsa, só o arquivo de senhas.

    Tente refazer o arquivos de senhas com o htpasswd -c /etc/squid/arquivo ou sei lá onde vc põe ...

    Dê um clean no diretório do ncsa dentro do fonte do squid e recompile o safado. reinstale o arquivo.

    Só imagino isso ou configuração do próprio squid, camarada.



  17. #37

    Padrão Squid demorando p/ autenticar

    auth_param basic program /usr/lib/squid/ncsa_auth /etc/squid/passwd
    auth_param basic children 5
    auth_param basic realm <<<<< Proxy Server Login >>>>>
    auth_param basic credentialsttl 2 hours
    auth_param basic casesensitive off

    authenticate_cache_garbage_interval 30 minutes
    authenticate_ttl 30 minutes

    Camarada, tente recriar o arquivo de senhas com o htpasswd -c /etc/squid/passwd (ou onde quer que seja que o seu arquivo esteja).
    Não use o passwd do etc, é melhor fazer um seu mesmo porque não é seguro.

    Remova o ncsa do local dele, recompile o safado do ncsa dentro do fonte do squid e reinstale.

    Só imagino isso cara, espero que te ajude.

    Que a força esteja com vc.

  18. #38

    Padrão Squid demorando p/ autenticar

    Pessoal, descobri o que estava causando esse delay na hora da autenticação.

    Foi só comentar a linha
    auth_param basic realm <<<<< Proxy Server Login >>>>>

    que funcionou.

    Será que não tenho como por uma frase personalizada?

    Fiz vários teste, é deixar descomentada a linha que dá o delay, comentar que funciona tudo normal.