+ Responder ao Tópico



  1. #1
    luisoft
    Visitante

    Padrão resolv.conf muda sozinho!!!

    ola,

    tenho um modem adsl dsl-500t configurado como dhcp server. Ele tem o ip 10.1.1.1 e meu linux normalmente fica com 10.1.1.2 (eth0).

    O problema eh que nao consigo navegar, pois no meu resolv.conf esta assim:

    nameserver 10.1.1.1

    ao inves dos dns do meu provedor! Sempre tenho que atualizar o arquivo, mas depois de alguns minutos volta ao 10.1.1.1

    Alguem sabe como resolver isso?

  2. #2

    Padrão resolv.conf muda sozinho!!!

    Cara,

    Pode ser o ppp ou dhcp q esta mudando seu resolv.conf. Eh bem provavel q seja o ppp. Da uma olhada nas configuracoes do ppp no /etc/ppp

    [] Dotta :twisted:



  3. #3
    luisoft
    Visitante

    Padrão resolv.conf muda sozinho!!!

    ja comentei a opcao usepeerdns do options do ppp e nada...

  4. #4

    Padrão resolv.conf muda sozinho!!!

    da uma olhada nas configuracoes das duas placas de rede para ver se nao esta pegando alguma coisa de dhcp...

    [] Dotta :twisted:



  5. #5
    luisoft
    Visitante

    Padrão resolv.conf muda sozinho!!!

    hmm.so tenho uma placa de rede.

  6. #6
    thiagog
    Visitante

    Padrão resolv.conf muda sozinho!!!

    quer uma dica de segurança;
    use portsentry e logwatch no seu servidor e evite surpresas..
    e tem tambem o "lsof"
    man lsof se nao tiver

    yum -y install lsof (se for CentOs ou se tiver yum instalado em seu sistema);

    http://freshmeat.net/projects/lsof/

    ate mais



  7. #7
    Waclawiak
    Visitante

    Padrão resp

    Coloque no arquivo de configuração da interface de rede.
    nopeerdns=yes

    isso fará com que o arquivo não mude mais

    Falo pelas distribuições baseadas em redhar e conectiva

  8. #8

    Padrão resolv.conf muda sozinho!!!

    cara...

    tbm tive este problema aqui no meu server...

    mudei algumas configurações no pppoe.conf e não resolveu...

    depois percebi q o arquivo /etc/resolv.conf era um link simbólico do /etc/ppp/resolv.conf

    apaguei este link e criei o arquivo real /etc/resolv.conf

    e fiz as configurações adequadas nele...

    depois disso não tive mais problemas com dns...

    valew



  9. #9

    Padrão resolv.conf muda sozinho!!!

    kra, aqui qdo tive problemas com o resolv.conf foi por causa do dns...

    era o dhcp do modem que mudava o dns da maquina..

    oque eu fiz foi reconfigurar meu dhcp do modem para entregar ip's de DNS validos para navegação, assim, acabei com o problema...


    []'s

  10. #10
    uncoded
    Visitante

    Padrão resolv.conf

    Porfavor...
    Peerdns=no
    somente isso...



  11. #11

    Padrão Re: resolv.conf

    Citação Postado originalmente por uncoded
    Porfavor...
    Peerdns=no
    somente isso...
    por favor....

    e qdo PEERDNS=no não resolve ???

    DNSTYPE=NOCHAGE não resolve ???

    outras coisas devem ser feitas pra resolver... assim vc descobre o pq de não funcionar as configurações...

  12. #12
    uncoded
    Visitante

    Padrão resolv.conf

    Somente o PEERDNS=no resolve,
    nunca vi NOPEERDNS=yes

    lei o man do rp-pppoe sobre o DNSTYPE=NOCHAGE, isso esta errado. o correto é DNSTYPE=NOCHANGE porém ele não resolve o seu problema, como eu disse,
    apenas PEERDNS=no

    flw. :good:



  13. #13

    Padrão resolv.conf muda sozinho!!!

    sim...

    é DNSTYPE=NOCHANGE, qdo digitei faltou o "N", para bom entendedor meia palavra basta...

    e como eu disse, "aqui" colocar PEERDNS=no não resolveu..

    valew

  14. #14
    uncoded
    Visitante

    Padrão resolv.conf

    td bem, sem problemas, deixando esse "ar" de lado.


    Vamos por partes,

    qual é sua distribuição?
    verique se a versão do seu rp-pppoe da sua distro não possuí nenhum tipo de bug em relação a isso, já tive dores de cabeça com a versão do rp-pppoe do RedHat9, digo bem bugado em relação ao LCP.
    tente fazer testes, e monitore o mtime do arquivo resolv.conf, exemplo, quando vc reconecta o adsl veja se ela esta sendo alterado, se for, pegue o arquivo que inicia a interface veja se existe algum problema para a leitura da opcao PEERDNS.
    se não coseguir identificar, temos outro passo, desligue o seu adsl ( adsl-stop na maioria dos casos).
    depois adsl-start e dê um ps -axf | grep ppp, veja as opções que são passadas e veja se peerdns está sendo passado.
    se não for isso, procure algo sobre dhcp-client que deve estar rodando em alguma ou na única interface de sua máquina e esta pegando o dns de outro lugar, tipicamente quando o resolv.conf é alterado pelo dhcp-client ele coloca em primeira linha "#resolv-conf ... by dhcp-client"


    espero que isso ajude a debugar o problema.

    flw :good:



  15. #15

    Padrão tsc tsc

    o kra quando se acha tem k da um pedala ou uma vuadora
    poe a humildade ae cara larga de se pela saco.

  16. #16

    Padrão Re: resolv.conf

    Citação Postado originalmente por uncoded
    td bem, sem problemas, deixando esse "ar" de lado.


    Vamos por partes,

    qual é sua distribuição?
    verique se a versão do seu rp-pppoe da sua distro não possuí nenhum tipo de bug em relação a isso, já tive dores de cabeça com a versão do rp-pppoe do RedHat9, digo bem bugado em relação ao LCP.
    tente fazer testes, e monitore o mtime do arquivo resolv.conf, exemplo, quando vc reconecta o adsl veja se ela esta sendo alterado, se for, pegue o arquivo que inicia a interface veja se existe algum problema para a leitura da opcao PEERDNS.
    se não coseguir identificar, temos outro passo, desligue o seu adsl ( adsl-stop na maioria dos casos).
    depois adsl-start e dê um ps -axf | grep ppp, veja as opções que são passadas e veja se peerdns está sendo passado.
    se não for isso, procure algo sobre dhcp-client que deve estar rodando em alguma ou na única interface de sua máquina e esta pegando o dns de outro lugar, tipicamente quando o resolv.conf é alterado pelo dhcp-client ele coloca em primeira linha "#resolv-conf ... by dhcp-client"


    espero que isso ajude a debugar o problema.

    flw :good:
    oo cara...

    agradeço por todas as dicas... :good:

    mas tipo.. eu não estou com problemas no resolv.conf no momento, eu apenas postei no tópico o q eu fiz para resolver o problema q "tive", e soh pra lembrar, quem postou o tópico não se manifestou novamente.. heheheeh

    valew