Página 3 de 4 PrimeiroPrimeiro 1234 ÚltimoÚltimo
+ Responder ao Tópico



  1. Citação Postado originalmente por uncoded
    Porfavor...
    Peerdns=no
    somente isso...
    por favor....

    e qdo PEERDNS=no não resolve ???

    DNSTYPE=NOCHAGE não resolve ???

    outras coisas devem ser feitas pra resolver... assim vc descobre o pq de não funcionar as configurações...

  2. #12
    uncoded
    Somente o PEERDNS=no resolve,
    nunca vi NOPEERDNS=yes

    lei o man do rp-pppoe sobre o DNSTYPE=NOCHAGE, isso esta errado. o correto é DNSTYPE=NOCHANGE porém ele não resolve o seu problema, como eu disse,
    apenas PEERDNS=no

    flw. :good:



  3. sim...

    é DNSTYPE=NOCHANGE, qdo digitei faltou o "N", para bom entendedor meia palavra basta...

    e como eu disse, "aqui" colocar PEERDNS=no não resolveu..

    valew

  4. #14
    uncoded
    td bem, sem problemas, deixando esse "ar" de lado.


    Vamos por partes,

    qual é sua distribuição?
    verique se a versão do seu rp-pppoe da sua distro não possuí nenhum tipo de bug em relação a isso, já tive dores de cabeça com a versão do rp-pppoe do RedHat9, digo bem bugado em relação ao LCP.
    tente fazer testes, e monitore o mtime do arquivo resolv.conf, exemplo, quando vc reconecta o adsl veja se ela esta sendo alterado, se for, pegue o arquivo que inicia a interface veja se existe algum problema para a leitura da opcao PEERDNS.
    se não coseguir identificar, temos outro passo, desligue o seu adsl ( adsl-stop na maioria dos casos).
    depois adsl-start e dê um ps -axf | grep ppp, veja as opções que são passadas e veja se peerdns está sendo passado.
    se não for isso, procure algo sobre dhcp-client que deve estar rodando em alguma ou na única interface de sua máquina e esta pegando o dns de outro lugar, tipicamente quando o resolv.conf é alterado pelo dhcp-client ele coloca em primeira linha "#resolv-conf ... by dhcp-client"


    espero que isso ajude a debugar o problema.

    flw :good:



  5. o kra quando se acha tem k da um pedala ou uma vuadora
    poe a humildade ae cara larga de se pela saco.






Tópicos Similares

  1. Problema com "resolv.conf"
    Por MVZS no fórum Servidores de Rede
    Respostas: 1
    Último Post: 07-03-2006, 12:19
  2. resolv.conf
    Por max_mori no fórum Servidores de Rede
    Respostas: 5
    Último Post: 06-09-2005, 21:30
  3. Diferenças entre Resolv.conf, hosts etc
    Por moisesbrandalise no fórum Servidores de Rede
    Respostas: 11
    Último Post: 27-04-2005, 08:28
  4. Problema no Resolv.conf no Conectiva 10
    Por andergom no fórum Servidores de Rede
    Respostas: 3
    Último Post: 21-11-2004, 00:13
  5. resolv.conf
    Por no fórum Servidores de Rede
    Respostas: 3
    Último Post: 12-11-2004, 12:29

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L