+ Responder ao Tópico



  1. #1
    jvdebian
    Visitante

    Padrão apt-get - erro na instalacao do sarg

    hello Guys!!

    Ai gente, eu estou tentando instalar o SARG no meu Servidor Debian, que por sinal ja esta rodando o SQUID, mas eu ja tentei Instalar o SARG usando apt-get e me uma mensagem de erro:

    ebserver:/tmp# apt-get -f install libc6
    Reading Package Lists... Done
    Building Dependency Tree... Done
    Sorry, libc6 is already the newest version.
    You might want to run `apt-get -f install' to correct these:
    Sorry, but the following packages have unmet dependencies:
    libdb1-compat: Depends: libc6 (>= 2.2.5-13) but 2.2.5-11.8 is to be installed
    sarg: Depends: libc6 (>= 2.3.2.ds1-21) but 2.2.5-11.8 is to be installed
    Depends: libgd2-noxpm (>= 2.0.33) but it is not going to be installed or
    libgd2-xpm (>= 2.0.33) but it is not installable
    Depends: ttf-bitstream-vera but it is not installable
    E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

    eu ja tentei baixar o pacote .Deb do sarg e instalar com o dpkg:

    webserver:/tmp# dpkg -i sarg_2.0.5.dfsg-1_i386.deb
    (Reading database ... 19486 files and directories currently installed.)
    Preparing to replace sarg 2.0.5.dfsg-1 (using sarg_2.0.5.dfsg-1_i386.deb) ...
    Unpacking replacement sarg ...
    dpkg: dependency problems prevent configuration of sarg:
    sarg depends on libc6 (>= 2.3.2.ds1-21); however:
    Version of libc6 on system is 2.2.5-11.8.
    sarg depends on libgd2-noxpm (>= 2.0.33) | libgd2-xpm (>= 2.0.33); however:
    Package libgd2-noxpm is not installed.
    Package libgd2-xpm is not installed.
    sarg depends on ttf-bitstream-vera; however:
    Package ttf-bitstream-vera is not installed.
    dpkg: error processing sarg (--install):
    dependency problems - leaving unconfigured
    Errors were encountered while processing:
    sarg
    webserver:/tmp#

    ja tentei baixar os pacotes tb ai continua dando erro de dependencias!!
    o q q e possivel de se fazer? por favor pessoal, manda uma luz ai!! brigadao!!!! t+

  2. #2
    wrochal
    Visitante

    Padrão apt-get - erro na instalacao do sarg

    Caro,

    Que versão do Debian você usa? E outra coisa porque você não usar o apt-get install sarg?

    Até,



  3. #3

    Padrão apt-get - erro na instalacao do sarg

    Pelo que entendi vc quer instalar o sarg mas ele tah pedindo a biblioteca libc6 >= 2.3.2.ds1-21 mas a sua versão eh 2.2.5-11.8. Daih vc tentou instalar a libc6 certo.

    Tente fazer isso:

    #apt-get install glibc
    (contém a libc6 e outras libs (é sempre bom ter atualizadas)

    daih de:

    #apt-get isntall sarg

    Lembrando que o sarg tem que ter instalado o apache com módulo php

  4. #4
    jvdebian
    Visitante

    Padrão apt-get - erro na instalacao do sarg

    Ae, qto a Versao do Debian, estou usando o 3.0.

    Eu jah tentei "apt-get install sarg" foi dai q tudo comecou tudo.

    ahh tb acabei de testar "apt-get install glibc" olha a resposta:

    webserver:~# apt-get install glibc
    Reading Package Lists... Done
    Building Dependency Tree... Done
    Package glibc has no available version, but exists in the database.
    This typically means that the package was mentioned in a dependency and
    never uploaded, has been obsoleted or is not available with the contents
    of sources.list
    E: Package glibc has no installation candidate

    tentei "apt-get update" e depois "apt-get install glibc" e a mensagem continua a mesma dizendo q o pacote nao tem candidato para instalacao!!! acho q jah esta na sua versao mais nova!!!

    resumindo... ainda nao consegui instalar o sarg!!!!

    webserver:~# apt-get install sarg
    Reading Package Lists... Done
    Building Dependency Tree... Done
    Sorry, sarg is already the newest version.
    You might want to run `apt-get -f install' to correct these:
    Sorry, but the following packages have unmet dependencies:
    libdb1-compat: Depends: libc6 (>= 2.2.5-13) but 2.2.5-11.8 is to be installed
    sarg: Depends: libc6 (>= 2.3.2.ds1-21) but 2.2.5-11.8 is to be installed
    Depends: libgd2-noxpm (>= 2.0.33) but it is not going to be installed or
    libgd2-xpm (>= 2.0.33) but it is not installable
    Depends: ttf-bitstream-vera but it is not installable
    E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).



  5. #5

    Padrão apt-get - erro na instalacao do sarg

    Antes você tem que atualizar para Sarge, com:

    Código :
    # apt-get -f dist-upgrade

    Mas antes você tem que ter os repositórios no seu /etc/apt/sources.list

    Então você instala o SARG.


    Abraços!

  6. #6

    Padrão apt-get - erro na instalacao do sarg

    Verifique o /etc/apt/souce.list

    comente tudo e coloque isso:

    Código :
    deb ftp://ftp.br.debian.org/debian/ unstable main non-free contrib

    Feito isso de um:
    #apt-get update
    #apt-get install glibc
    #apt-get install sarg



  7. #7

    Padrão apt-get - erro na instalacao do sarg

    Citação Postado originalmente por White_Tiger
    Verifique o /etc/apt/souce.list

    comente tudo e coloque isso:

    Código :
    deb ftp://ftp.br.debian.org/debian/ unstable main non-free contrib

    Feito isso de um:
    #apt-get update
    #apt-get install glibc
    #apt-get install sarg
    Utilizar repositórios unstable em um servidor de produção? Só se tiver titica na cabeça...

  8. #8
    jvdebian
    Visitante

    Padrão apt-get - erro na instalacao do sarg

    Ae, deixei soh aquele repositorio no sources.list e fiz o apt-get -f dist-upgrade e rolou, atualizou todos os pacotes do meu sistema e depois soh apt-get install sarg, ficou facil!!!!! Valeu pela dica hein, acho que agora nao quebro mais a cabeca com esse problema de conflito de versoes, soh manter o sistema atualizado neh!!


    Ahhh, eu usei a versao stable pra atualizar viu!! rsrsrsrs...

    abraco galera!!! valeuuuuuuu!!!!! :good:



  9. #9

    Padrão apt-get - erro na instalacao do sarg

    Também funciona. É que aqui onde eu trabalho como o povu diz "gostamos de trabalhar no crítico"

  10. #10

    Padrão apt-get - erro na instalacao do sarg

    Claro que funciona, mas ao contrário do povo daí, eu não gosto de trabalhar, hehehe.



  11. #11
    sadirj
    Visitante

    Padrão apt-get - erro na instalacao do sarg

    Pessoal, estou com um problemão aqui faz alguns dias...
    Toda vez que faço apt-get install, olhem o que acontece:

    Código :
    ntrj11:~# apt-get install samba-common
    Reading Package Lists... Done
    Building Dependency Tree... Done
    The following NEW packages will be installed:
      samba-common
    0 upgraded, 1 newly installed, 0 to remove and 3 not upgraded.
    Need to get 0B/1988kB of archives.
    After unpacking 4833kB of additional disk space will be used.
    Preconfiguring packages ...
    Authenticating /var/cache/apt/archives/samba-common_3.0.14a-3_i386.deb ...
    debsig: Origin Signature check failed. This deb might not be signed.
     
    dpkg: error processing /var/cache/apt/archives/samba-common_3.0.14a-3_i386.deb (--unpack):
     Verification on package /var/cache/apt/archives/samba-common_3.0.14a-3_i386.deb failed!
    Errors were encountered while processing:
     /var/cache/apt/archives/samba-common_3.0.14a-3_i386.deb
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    ntrj11:~#
    Isso acontece com qualquer pacote, não importa. Já passei por isso uma vez antes e um amigo por telefone (que não consigo mais contato) resolveu dizendo para eu excluir um determinado arquivo e aí tudo voltou a funcionar... só que não me lembro qual é esse arquivo.
    Alguém pode me ajudar com isso???

    Abraços.

  12. #12
    jvdebian
    Visitante

    Padrão apt-get - erro na instalacao do sarg

    ohhh xstefanox, bom cara... seguinte, tava lendo o seu guia aqui pra instalar e configurar o Squid, e o negocio e o seguinte, eu acho q no meu caso eu vou precisar de authenticacao mas vou tb precisar de acesso ah https, mesmo se eu redirecionar soh a porta 80 pro proxy ele nao vai passar https???
    tem alguma solucao?

    valeu !!!