+ Responder ao Tópico



  1. #1

    Padrão Porque ...-t nat -A POSTROUTING -o eth0 -j... não Nateia.

    Tenho um micro com duas interfaces de rede em uma delas vai um cabo de rede que vem de um modem router do velox com ip 192.168.254.7 fixei em uma das interfaces na eth0 na outra fixei 192.168.0.1 configurei esse micro como servidor DHCP e apliquei a regra Iptables: iptables -t nat -A POSTROUTING - o eth0 - j MASQUERADE mas não nateia no outro micro que eu tenho, windows xp, mas esse micro pega o ip certinho do DHCP mas não navega tem alguma coisa que possa ver porque não consigo roetar a internet?

  2. #2

    Padrão Porque ...-t nat -A POSTROUTING -o eth0 -j... não Nateia.

    cara...

    vc habilitou o ip_forward ???

    echo 1 > /proc/sys/net/ipv4/ip_forward

    e sua placa eth0 é a q está ligada a internet né?

    valew



  3. #3
    dinomaral
    Visitante

    Padrão Porque ...-t nat -A POSTROUTING -o eth0 -j... não Nateia.

    Olha só...
    Já que temos e podemos usar...
    Vc. pode adicionar um parâmetro na sua regra para somente quem tiver na sua rede interna 168.168.0.0/24 poder fazer NAT.
    iptables -t nat -A POSTROUTING -s 168.168.0.0/24 -o eth0 -j MASQUERADE
    Quanto ao WinXP, coloque um IP fixo nele.

    Dino

  4. #4

    Padrão Porque ...-t nat -A POSTROUTING -o eth0 -j... não Nateia.

    kra eu tive um problema desse uma vez e mudei a rota padrão e resolvel:

    #route del default
    #route add default pppo

    v direitinho, antes de fazer isso senao vc pode parar de receber sinal da net, no meu caso nem o meu servidor tava acessando a internet, se no seu caso o seu servidor ta acessando a internet entao vc nao precisara destes comandos....

    Valews



  5. #5

    Padrão Porque ...-t nat -A POSTROUTING -o eth0 -j... não Nateia.

    cara...

    o tuxson me fez lembrar uma coisa importante...

    se vc está usando conexão com discador pppoe então no lugar de eth+ vc coloca ppp+

    valew

  6. #6

    Padrão Porque ...-t nat -A POSTROUTING -o eth0 -j... não Nateia.

    putz...

    É isso mesmo kra tem esse detalhe mesmo q ate eu tinha esquecido...

    + valew mesmo espero q tenha resolvido...

    Até +...



  7. #7

    Padrão Porque ...-t nat -A POSTROUTING -o eth0 -j... não Nateia.

    Para habilitar ip_forward é só digitar isso que vc escreveu aí?
    echo 1 > /proc/sys/net/ipv4/ip_forward. Eu uso Slackware 10


    Citação Postado originalmente por lucianogf
    cara...

    vc habilitou o ip_forward ???

    echo 1 > /proc/sys/net/ipv4/ip_forward

    e sua placa eth0 é a q está ligada a internet né?

    valew

  8. #8

    Padrão Porque ...-t nat -A POSTROUTING -o eth0 -j... não Nateia.

    cara..

    no slackware 10.2 eu sei q tem o rc.ip_forward, ae é só dar permissão de executável para o arquivo e qdo o servidor inicia esta opção já fica setada..

    mas nada impede de vc usar este comando, fará a mesma coisa...

    valew