Página 2 de 2 PrimeiroPrimeiro 12
+ Responder ao Tópico



  1. Valeu pelas dicas GodZilla. Como estou em época de vestibular ainda não tive tempo para verificar isso.

    Tentei resolver via software e finalmente consegui descarregar o módulo maestro3, aí, com ele descarregado, consegui configurar o alsa. Agora tanto o alsa quanto o oss estão funcionando, porém, o filme continua na mesma.

    O estranho é que é sempre no mesmo ponto do som que acontece o problema, pois se eu atrasar/adiantar o som, o vídeo só apresenta problemas quando chegar no mesmo ponto. Isso faz parecer que o problema é no arquivo de vídeo, aí hoje peguei um outro filme e ele nem sequer abre. Já se eu desabilitar o som, e filme rola normal.

    Vou fazer mais alguns testes com outros filmes.

  2. Fiz mais alguns testes e descobri algo interessante. Quando o mplayer seleciona um codec chamado libmad (ele diz que é para mpeg layer 1, 2 e 3), o vídeo apresenta problemas, que são os casos que citei. Mas fiz testes com outros vídeos que usam codecs de áudio diferentes e esses vídeos, até mais pesados que os primeiros, rodam normalmente.

    Isso mostra que o problema é com os codecs de áudio para arquivos mpeg. A minha dúvida é: para se converter mp3 para outros formatos ou vice-versa, tb são usados esses codecs/libs? Se sim e se os problemas são justamente esses, por que isso começou acontecer agora e em qualquer distro que instalo, afinal, é um problema de software ou hardware?

    Codec selecionado pelo mplayer quando o vídeo dá problema:

    Trying to force audio codec driver family libmad...
    Opening audio decoder: [libmad] libmad mpeg audio decoder
    AUDIO: 48000 Hz, 2 ch, s16le, 128.0 kbit/8.33% (ratio: 16000->192000)
    Selected audio codec: [mad] afm:libmad (libMAD MPEG layer 1-2-3)
    Exemplo de codec selecionado pelo mplayer onde não há problemas:

    Trying to force audio codec driver family libmad...
    Opening audio decoder: [liba52] AC3 decoding with liba52
    No accelerated IMDCT transform found
    AC3: 2.0 (stereo) 48000 Hz 224.0 kbit/s
    Using MMX optimized resampler
    AUDIO: 48000 Hz, 2 ch, s16le, 224.0 kbit/14.58% (ratio: 28000->192000)
    Selected audio codec: [a52] afm:liba52 (AC3-liba52)

    Obrigado.






Tópicos Similares

  1. Driver de som
    Por dpcl no fórum Sistemas Operacionais
    Respostas: 5
    Último Post: 01-05-2007, 14:08
  2. Erro com Firebird ou Linux
    Por sandercomputacao no fórum Servidores de Rede
    Respostas: 6
    Último Post: 13-02-2006, 15:48
  3. driver de som
    Por Syconzito no fórum Servidores de Rede
    Respostas: 3
    Último Post: 24-07-2005, 10:13
  4. Drivers de Som
    Por agent_smith no fórum Servidores de Rede
    Respostas: 15
    Último Post: 31-07-2004, 15:41
  5. Problema com driver de Som!
    Por hydorn no fórum Servidores de Rede
    Respostas: 1
    Último Post: 03-02-2004, 21:31

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L