+ Responder ao Tópico



  1. #1

    Padrão acessar servidor Linux via ssh

    Galera, boa tarde a todos .............Estou tendo um problema de acessar de servidor Linux para servidor Linux aqui na empresa via ssh.
    Eu digito o comando :

    #ssh [email protected] e enter , aparece a seguinte mensagem :

    #permanently_set_uid : was enable to restore old [e]gid

    O que pode ser isso pessoal ??? Se eu acessar via o comando Putty pelo windows acesso normalmente. E quando eu acesso pelo Putty no windows, eu posso executar o comando ssh para outro servidor, que também funciona perfeito. Mas gostaria de saber porque de Linux para Linux acontece isso.

    Se alguém puder me dar alguma dica, desde já fico grato. Obrigado .... :toim: :toim: :toim:

  2. #2
    jlbavaresco
    Visitante

    Padrão comandos

    tenta
    slogin hostname opções
    ex slogin 192.168.0.250 -l root
    aqui funciona normal!
    Avise se conseguir!
    Boa sorte!



  3. #3

    Padrão acessar servidor Linux via ssh

    Vc alterou alguma coisa na configuração do ssh ??


    Fábio Jung

  4. #4
    cradiao
    Visitante

    Padrão /home/.ssh

    nesse subdiretorio existe um arquivo onde o ssh grava os ips com mac e blabla... deixa ele em branco pra testar...



  5. #5

    Padrão acessar servidor Linux via ssh

    Galera, obrigado pelas respostas.
    Tentei o comando slogin, mas também exibe a mesma mensagem.
    Vou ver o diretório que o amigo falou ....
    Um abraço a todos .....

  6. #6

    Padrão acessar servidor Linux via ssh

    Cradiao, boa tarde meu caro. Também olhei no diretório /home e não tem esse .ssh que você mencionou.
    Na verdade eu estou utilizando a configuração original do ssh, que é instalada no Slackware 10.1.
    O estranho é que pelo Putty, funciona perfeito mesmo .....
    Tem alguma sugestão ???? Obrigado amigo .... :good:



  7. #7

    Padrão acessar servidor Linux via ssh

    a maquina que tinha o IP do dominio mudou? se mudou vc precisa editar o arquivo /home/[user]/.ssh/know_hosts e apagar a linha dele de la

  8. #8

    Padrão acessar servidor Linux via ssh

    Na verdade amigo, eu nunca mexi no ssh. Do jeito que eu instalei o Slackware 10.1 , está original. Eu não alterei nada mesmo.
    Só que pelo Putty eu acesso normal. Mas quando estou por exemplo no servidor da Internet (192.168.1.1) e quero acessar o servidor de aplicativos (192.168.1.5) via ssh -l user_name 192.168.1.5 dá essa mensagem.
    Obrigado ......... :roll: :toim:



  9. #9

    Padrão acessar servidor Linux via ssh

    cara ssh [email protected]

    tem que funcionar

  10. #10

    Padrão acessar servidor Linux via ssh

    Douglas, fiz agora do jeito que você digitou [email protected] e dá essa mesma mensagem.
    Que treco mais doido ............. :roll: :roll: :roll:



  11. #11
    jlbavaresco
    Visitante

    Padrão tenta os meus conf

    cara tenta colocar os meus conf e vê se funciona

    /etc/ssh/ssh_config

    # $OpenBSD: ssh_config,v 1.19 2003/08/13 08:46:31 markus Exp $

    # This is the ssh client system-wide configuration file. See
    # ssh_config(5) for more information. This file provides defaults for
    # users, and the values can be changed in per-user configuration files
    # or on the command line.

    # Configuration data is parsed as follows:
    # 1. command line options
    # 2. user-specific file
    # 3. system-wide file
    # Any configuration value is only changed the first time it is set.
    # Thus, host-specific definitions should be at the beginning of the
    # configuration file, and defaults at the end.

    # Site-wide defaults for various options



    Host *
    ForwardAgent yes
    # ForwardX11 no
    ForwardX11Trusted yes
    RhostsRSAAuthentication yes
    RSAAuthentication yes
    PasswordAuthentication yes
    # HostbasedAuthentication no
    # BatchMode no
    # CheckHostIP yes
    # AddressFamily any
    # ConnectTimeout 0
    # StrictHostKeyChecking ask
    # IdentityFile ~/.ssh/identity
    # IdentityFile ~/.ssh/id_rsa
    # IdentityFile ~/.ssh/id_dsa
    Port 1222
    # Protocol 2,1
    # Cipher 3des
    # Ciphers aes128-cbc,3des-cbc,blowfish-cbc,cast128-cbc,arcfour,aes192-cbc,aes256-cbc
    # EscapeChar ~



    o outro

    /etc/ssh/sshd_config



    # $OpenBSD: sshd_config,v 1.59 2002/09/25 11:17:16 markus Exp $

    # This is the sshd server system-wide configuration file. See
    # sshd_config(5) for more information.

    # This sshd was compiled with PATH=/usr/bin:/bin:/usr/sbin:/sbin

    # The strategy used for options in the default sshd_config shipped with
    # OpenSSH is to specify options with their default value where
    # possible, but leave them commented. Uncommented options change a
    # default value.

    Port 1222
    #Protocol 2,1
    #ListenAddress 0.0.0.0
    #ListenAddress ::

    # HostKey for protocol version 1
    #HostKey /etc/ssh/ssh_host_key
    # HostKeys for protocol version 2
    #HostKey /etc/ssh/ssh_host_rsa_key
    #HostKey /etc/ssh/ssh_host_dsa_key

    # Lifetime and size of ephemeral version 1 server key
    #KeyRegenerationInterval 3600
    #ServerKeyBits 768

    # Logging

    # Logging
    #obsoletes QuietMode and FascistLogging
    #SyslogFacility AUTH
    #LogLevel INFO

    # Authentication:

    LoginGraceTime 600
    PermitRootLogin yes
    #StrictModes yes

    #RSAAuthentication yes
    #PubkeyAuthentication yes
    #AuthorizedKeysFile .ssh/authorized_keys

    # rhosts authentication should not be used
    #RhostsAuthentication no
    # Don't read the user's ~/.rhosts and ~/.shosts files
    #IgnoreRhosts yes
    # For this to work you will also need host keys in /etc/ssh/ssh_known_hosts
    #RhostsRSAAuthentication no
    # similar for protocol version 2
    #HostbasedAuthentication no
    # Change to yes if you don't trust ~/.ssh/known_hosts for
    # RhostsRSAAuthentication and HostbasedAuthentication
    #IgnoreUserKnownHosts no
    # To disable tunneled clear text passwords, change to no here!
    PasswordAuthentication yes
    #PermitEmptyPasswords no

    # Change to no to disable s/key passwords
    #ChallengeResponseAuthentication yes

    # Kerberos options
    #KerberosAuthentication no
    #KerberosOrLocalPasswd yes
    #KerberosTicketCleanup yes

    #AFSTokenPassing no

    # Kerberos TGT Passing only works with the AFS kaserver
    #KerberosTgtPassing no

    # Set this to 'yes' to enable PAM keyboard-interactive authentication
    # Warning: enabling this may bypass the setting of 'PasswordAuthentication'
    #PAMAuthenticationViaKbdInt no

    X11Forwarding yes
    #X11DisplayOffset 10
    #X11UseLocalhost yes
    #PrintMotd yes
    #PrintLastLog yes
    #KeepAlive yes
    #UseLogin no
    #UsePrivilegeSeparation yes
    #PermitUserEnvironment no
    #Compression yes

    #MaxStartups 10
    # no default banner path
    #Banner /some/path
    #VerifyReverseMapping no

    Subsystem sftp /usr/libexec/sftp-server


    Têm que funcionar, copiei do meu server agora!

    Qualquer coisa dá um toque e vamos resolver isso!

  12. #12

    Padrão acessar servidor Linux via ssh

    cara..

    se vc estiver logado como root neste micro apaga o arquivo known_hosts q fica dentro do diretório /root/.ssh

    caso vc esteja logado como outro usuário, dentro do diretório home dele tbm tem o diretório .ssh, e lá deve ter o arquivo... apaga e veja se vc consegue conectar..

    valew



  13. #13
    omaximo
    Visitante

    Padrão acessar servidor Linux via ssh

    Olá amigos,

    tente apenas isso:

    ssh ipdooutrolinux -l usuario[/list]

  14. #14

    Padrão acessar servidor Linux via ssh

    Galera, eu vou tentar fazer o que me passaram. De qualquer forma obrigado pelas dicas. Outra coisa, o arquivo ssh_config e o sshd_config, tem várias linhas comentadas, como foi exibido acima, pelo nosso amigo. Eu devo descomentá-las ??? E mais um pequeno detalhe : Eu andei instalando o OpenSuSE 10.0 e 10.1 no meu pc na empresa e andei tendo problemas com o KDE, que o acompanha. Até já postei isso aqui no Underlinux. Não sei se o esse KDE que vem com o OpenSuSE 10.0 e 10.1, tem algum bug. Mas trava direto. Qualquer coisa que eu faço no KDE, coisas corriqueiras, tipo acessar o konsole, plano de fundo, proteção de tela, configurar teclado, etc, trava. Aí fiz uma outra experiência hoje. Reinstalei o OpenSuSE 10.1 mas com o Gnome. Funcionou perfeito. E pasmem, acessei os nossos 2 servidores Slackware 10.1 via ssh, funcionou perfeito. E de qualquer um desses servidores, acessei o outro, também via ssh. Também maravilha. Acessamos também um outro servidor de outra empresa, via ssh usando ip fixo válido. Perfeitíssimo. Vai entender isso !!!!!!!!!!! Coisas de informática ???? Está sendo anunciado o KDE 3.5 aqui mesmo no Underlinux. Vou baixar os pacotes e tentar instalar no OpenSuSE 10.1 e ver no que dá.
    Mas valeu galera. Um grande abraço a todos ............ :roll: :toim: :roll:



  15. #15
    jlbavaresco
    Visitante

    Padrão Arquivo completo

    Olá amigo Aquele é o arquvo completo, e funciona da maneira que está ali
    É so copiar todo o conteudo em cima dos arquivos originais, ou copiar as linhas descomentadas que ira funcionar
    Tente e qualquer coisa dá um toque

  16. #16
    omaximo
    Visitante

    Padrão acessar servidor Linux via ssh

    Eu uso o OpenSuSE 10 em casa e não tive nenhum problema com o KDE, pode ser alguma coisa com sua máquina e/ou a instalação.

    As vezes a reinstalação corrige estes problemas, como por exemplo, instalei em outra máquina minha o Mandriva 2006.0 Free e tive problemas como o MySQL que não rodava de jeito nenhum, desinstalei ele instalei novamente aí funcionou que foi uma beleza.

    Quanto ao SSH, como já informei antes neste tópico, nunca tive problemas com ele executando da forma que mencionei.

    ssh 200.175.77.88 -l usuario



  17. #17

    Padrão acessar servidor Linux via ssh

    Omaximo, vou tentar fazer o que sugeriu. Mas já reinstalei o SuSE 10.1, 4 vezes. Reinstalei o SuSE 10.1, 2 vezes e não sei porque, mas o KDE, qualquer coisa que faço, simplesmente trava. Ele não trava de imediato. É sómente fazer qualquer coisa simples. Tipo, proteção de tela, konsole, plano de fundo, idioma, teclado e tempo depois ele trava. Sómente desligando a máquina e voltando, ele volta a funcionar. Aí é sómente entrar no KDE e trava tudo de novo. Coisas de infomática mesmo .........
    Mas valeu ......... :roll: