+ Responder ao Tópico



  1. #1
    maverick_cba
    Visitante

    Padrão Problemas na Instalação do Slackware 10.2

    Amigos, estou tendo um problema com meu slackware 10.2

    Tenho uma placa mãe ASUS P5GD2 DELUXE com disco IDE MAXTOR Y080L0 80GB ligado na IDE Primária como Master. Acontece que com o windows xp o reconhecimento do hd é feito nromalmente, mas durante a instalação do slackware 10.2 ele não reconhece meu hd. Já tentei todas as opções de kernel disponíveis na instalação inclusive a 2.6 testing e nada de detectar. Consequentemente ao executar o cfdisk ele me retorna a mensagem "FATAL ERROR: CANNOT OPEN DISK DRIVE".

    Para testar coloquei um hd velhinho de 7GB e o mesmo tb não foi reconhecido.

    Sei que minha placa possui alguns controladores RAID. Seria isso que está causando o problema?

    Preciso muito instalar esse slackware pois faz parte da minha monografia.

    Agradeço a ajuda que puderem dar.

  2. #2
    guigo10
    Visitante

    Padrão Problemas na Instalação do Slackware 10.2

    Tente usar o fdisk.
    fdisk/dev/hda



  3. #3
    maverick_cba
    Visitante

    Padrão Problemas na Instalação do Slackware 10.2

    Não funcionou....

    Alguem tem alguma sugestão?

  4. #4
    kiaulinux
    Visitante

    Padrão slackware

    verificou as configurações de sua Bios e se usa apenas um cabo para hd e cdrom?



  5. #5
    DMaretta
    Visitante

    Padrão Setup

    O problema pode estar no setup da placa. Outra maneira de resolver é criar uma partição com o Fips (baixe de http://www.igd.fhg.de/~aschaefe/fips/ ) e depois ver se o instalador do Slack reconhece a partição que deverá se chamar hda2 (hda1 será a partição do XP).
    O Fips é não-destrutivo, mas não custa nada fazer um backup dos arquivos importantes antes de usá-lo.
    O instalador do Slack - até onde eu sei - não cria partições, apenas reparticiona e formata partições existentes no disco, ou um disco inteiro e sem outro sistema instalado. Uns 20GB darão para o teste.
    Se conseguir fazer o Slack reconhecer o teclado abnt2, me avise!!!.

  6. #6

    Padrão Problemas na Instalação do Slackware 10.2

    se vc quer saber como está o reconhecimento de dispositivos pelo kernel, rode um dmesg. Verifique na saída se consta alguma referencia a controladora raid. Eu me lembro que as P4P800 (antecessoras das P5) tinham uma controladora IDE raid e uma duas controladoras IDE simples, verifique se a sua placa não tem uma controladora RAID ide onboard, se tiver, procure um kernel com suporte. Quanto ao teclado ABNT2 altere o rc.keymap



  7. #7
    zeramos
    Visitante

    Padrão Tente isto, verifique ...

    Em qual IDE esta ligado seu HD

    Eu possuo a seguinte configuração:

    IDE 1 - master : 1 hd 40gb - acesso através de cfdisk /dev/hda
    hda1 primeira partição hda2 segunda partição

    IDE 1 - slave : 1 hd 80gb - acesso através de cfdisk /dev/hdb
    hdb1 primeira partição hdb2 segunda partição

    IDE 2 - master : 1 hd 80gb - acesso através de cfdisk /dev/hdc

    Blz !!!!!

  8. #8
    maverick_cba
    Visitante

    Padrão Problemas na Instalação do Slackware 10.2

    Pessoal, depois de quebrar muita cabeça, descobri que o kernel que vem com o slackware 10.2 não dá suporte a controladora ITE8212F que é a minha controladora IDE RAID. Descobri também que para faze-la funcionar eu teria que baixar o kernel 2.6.11 e aplicar o patch 2.6.11-ac7 feito pelo nosso amigo Alan Cox direto no kernel source. Com isso eu teria a opção de carregar o driver da controladora ITE no kernel source.

    Bom pra fazer isso eu tive que colocar meu HD numa outra máquina e instalar o slackware. Blz instalei e recompilei o kernel 2.6.11 com os devidos patchs e opções ativas.

    Mas para minha infelicidade acabei conseguindo outro problema. A minha placa de vídeo uma GEFORCE 6800 GT 512 RAM PCIEX não exibe imagem alguma ao inicializar o linux. Sendo que quando dou boot pelo velho 2.4 a imagem volta ao normal.

    Durante a compilação do kernel 2.6 eu ativei as opções de FrameBuffer direto no kernel, depois tentei carregar o .config original do kernel 2.4 e mesmo assim após várias recompilações continuo sem imagem com o kernel 2.6.

    Alguem tem alguma sugestão?



  9. #9
    maverick_cba
    Visitante

    Padrão Problemas na Instalação do Slackware 10.2

    Pessoal, alguem já passou pelo problema de ficar sem imagem durante o boot do slackware ou outra distro?

    Agradeço a ajuda que poderem dar.