Página 3 de 4 PrimeiroPrimeiro 1234 ÚltimoÚltimo
+ Responder ao Tópico



  1. poste aqui o arquivo de configuração da wlan.

  2. #12
    sadirj
    Código :
    #!/bin/sh
     
    IWPRIV="/usr/local/sbin/iwpriv"
     
    case "$1" in
            start)
                    $IWPRIV wlan0 wlan_para ssid2scan=localdomain
                    $IWPRIV wlan0 wlan_para basicrates=0x3
                    $IWPRIV wlan0 wlan_para networktype=infra
                    $IWPRIV wlan0 wlan_para oprates=0x3
                    $IWPRIV wlan0 wlan_para wepmode=off
                    $IWPRIV wlan0 wlan_para encmode=off
                    $IWPRIV wlan0 enable
    /sbin/ifup wlan0
     
                ;;
            stop)
     
            /sbin/ifdown wlan0
                    $IWPRIV wlan0 disable
     
                ;;
            *)
                    echo "Usage: /etc/init.d/wlan-realtek.init {start|stop}"
                ;;
    esac
    exit 0

    Aqu está o conteúdo do arquivo que "levanta" a placa REALTEK (RTL8180).
    Esse arquivo é carregado na inicialização antes das configurações de rede, de forma que, no arquivo /etc/network/interfaces eu possa setar configurações ip dela.
    Aguardo retorno e mais uma vez, obrigado.



  3. nesta opção:
    $IWPRIV wlan0 wlan_para networktype=infra
    mude para:
    $IWPRIV wlan0 wlan_para networktype=master

    Veja se funciona, caso nao funcione, comente essa linha e use:
    $IWPRIV wlan0 wlan_para mode=master

  4. #14
    sadirj
    Tentei as duas formas mas não funcionou. depois que carrego modulo e "estarto" a placa aparece o seguinte no /var/log/messages:

    Código :
    Nov 23 14:40:59 hermes kernel: RTL8180:  ------ Enable wlan driver ------
    Nov 23 14:40:59 hermes kernel: RTL8180: WLAN driver version 1.3
    Nov 23 14:40:59 hermes kernel: RTL8180: wireless LAN controller RTL8180 + philips RF.
    Nov 23 14:40:59 hermes kernel: RTL8180: PHILIPS_Config()
    Nov 23 14:40:59 hermes kernel: RTL8180: PHILIPS_Config() - Analog mode
    Nov 23 14:40:59 hermes kernel: RTL8180: ENABLE_RTL_DCST
    Nov 23 14:40:59 hermes kernel: RTL8180:  Set dot11PrivacyInvoked = 0.
    Nov 23 14:40:59 hermes kernel: RTL8180:  encryptmode = RTL_ENC_NONE
    Nov 23 14:40:59 hermes kernel: RTL8180:  wepkeymode = WEP_MODE_OFF
    Nov 23 14:41:02 hermes kernel: RTL8180: Start an IBSS network at channel 11
    Nov 23 14:41:02 hermes kernel: IBSSJoin(): Please check out the following ...
    Nov 23 14:41:02 hermes kernel: IBSSJoin(): BSSID = 0x02:0xe0:0x4f:0x2f:0x16:0x97
    Nov 23 14:41:02 hermes kernel: IBSSJoin(): SSID = aptest2
    Nov 23 14:41:02 hermes kernel: IBSSJoin(): dot11BeaconPeriod = 100
    Nov 23 14:41:02 hermes kernel: IBSSJoin(): dot11DtimPeriod = 0
    Nov 23 14:41:02 hermes kernel: IBSSJoin(): dot11OperationalRates = 0x03
    Nov 23 14:41:02 hermes kernel: IBSSJoin(): mCap = 0x02
    Nov 23 14:41:02 hermes kernel: RTL8180: Act_UpdateBeaconFrame......
    Nov 23 14:41:02 hermes kernel: RTL8180: TIM_setup......
    Nov 23 14:41:07 hermes kernel: RTL8180: Searching IBSS...
    Nov 23 14:41:10 hermes kernel: RTL8180: Start an IBSS network at channel 11
    Nov 23 14:41:10 hermes kernel: IBSSJoin(): Please check out the following ...
    Nov 23 14:41:10 hermes kernel: IBSSJoin(): BSSID = 0x02:0xe0:0x4f:0x2f:0x16:0x97
    Nov 23 14:41:10 hermes kernel: IBSSJoin(): SSID = aptest2
    Nov 23 14:41:10 hermes kernel: IBSSJoin(): dot11BeaconPeriod = 100
    Nov 23 14:41:10 hermes kernel: IBSSJoin(): dot11DtimPeriod = 0
    Nov 23 14:41:10 hermes kernel: IBSSJoin(): dot11OperationalRates = 0x03
    Nov 23 14:41:10 hermes kernel: IBSSJoin(): mCap = 0x02
    Nov 23 14:41:10 hermes kernel: RTL8180: Act_UpdateBeaconFrame......
    Nov 23 14:41:10 hermes kernel: RTL8180: TIM_setup......

    E fica assim direto, em um loop infinito. Parece que tem que compilar o modulo denovo com alguma opção... eu segui o passo-a-passo do Eduardo Mota, o único que consegui fazer funcionar. Segue o link:

    http://www.emota.com.br/wireless/rtl8180.html

    Obrigado mais uma vez.



  5. acho que falei asneira antes ops:

    use assim:
    iwpriv wlan0 disable -> desliga antes
    OS OUTROS COMANDOS...
    #iwpriv wlan0 drv_para apclient_enable=1 -> modo cliente
    iwpriv wlan0 drv_para apclient_enable=0 -> modo AP
    OS OUTROS COMANDOS...
    iwpriv wlan0 enable -> liga

    Se não funcionar, então essa placa que voce usa, ou os drivers que instalou não possui a opção.






Tópicos Similares

  1. AP Linux com placa de wireless sem usar cartoes
    Por digowebnet no fórum Redes
    Respostas: 5
    Último Post: 11-04-2007, 07:18
  2. Duvidas Ap Linux
    Por valeonline no fórum Redes
    Respostas: 4
    Último Post: 16-10-2006, 21:17
  3. Respostas: 5
    Último Post: 09-03-2006, 07:20
  4. ap linux
    Por tuxbrasil no fórum Redes
    Respostas: 3
    Último Post: 27-12-2005, 11:06
  5. AP LINUX ROR
    Por Mandrak no fórum Redes
    Respostas: 2
    Último Post: 20-04-2004, 17:53

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L