+ Responder ao Tópico



  1. #1
    mestre_dos_magos
    Visitante

    Padrão AP LINUX

    Olá amigos, gostaria de tirar uma dúvida, pois não acho em lugar nenhum... todo mundo faz ap linux com placas PCMCIA Orinoco etc.. Com placas PCI como a zinwell ou D-LINK.. é recomendavel ?




    Valeus...

  2. #2
    Visitante

    Padrão prezado

    dependerá única e exclusivamente de sua distro. Se o hard for homologado, já é. Se não, já era.

    []'s.



  3. #3
    mestre_dos_magos
    Visitante

    Padrão AP LINUX

    A distro que eu uso é a slack... recomendavel no sentido de render bem ne, apesar que o hard homologado ser muito importante

  4. #4
    xargs -n 1 kill -9 Avatar de sergio
    Ingresso
    Jan 2004
    Localização
    Capital do Triângulo
    Posts
    5.202
    Posts de Blog
    9

    Padrão AP LINUX

    usando placas RTL8181 os próprios comandos privados tem a opção MASTER, que faz com que se tornem APs. As placas da DLINK com chipset Atheros e eu acho (não tenho certeza mesmo) que as com chipset ACX111 também consegue modo MASTER. Além desses quase todas as placas/cartões com chipset Prism/Prism II é possível fazer modo AP com o hostAP.



  5. #5
    mestre_dos_magos
    Visitante

    Padrão AP LINUX

    Valeu Sergio, so mais uma duvida.... á uns tempos atras tive a aportunidade de ver aqui no forum uma foto dum AP Linux que vc fez.. Usou as placas PCMCIA etc... e usou no lugar do HD algo como um cartão de memoria.. qual nome e espeficicações daquela peça ? e onde adquiriu ? funciona bem com linux nele? tentei achar denovo o topico mas nao conseguir..hehe se poder falar valeu!

  6. #6



  7. #7
    xargs -n 1 kill -9 Avatar de sergio
    Ingresso
    Jan 2004
    Localização
    Capital do Triângulo
    Posts
    5.202
    Posts de Blog
    9

    Padrão AP LINUX

    mestre_dos_magos aquele é um cartão flash de 128 MB da Sandisk, igual aos de algumas cameras fotograficas, e está com um adaptador para ligar o mesmo na IDE. Vc encontra na www.cfide.com.br com o Bruno
    Funciona tranquilo no linux, BSD e até windows(eecaaaa!).

  8. #8
    sadirj
    Visitante

    Padrão AP LINUX

    Citação Postado originalmente por laerciok
    https://under-linux.org/modules.php?name=Forums&file=viewtopic&t=33313&highlight=linuxap
    Voce sabe dizer se a RTL8180 finciona em modo AP??? tenho uma instalada em um debian aqui em casa, mas não consigo fazê-lo funcionar como AP... o que eu fiz e errado? tem que compilar alguma coisa no kernel???

    Kernel 2.4.20 (único que eu consegui fazer funfar)
    debian 3.0 r0
    K6-II 500 / 64MB / 6.4GB

    alguém sabe ou pode me ajudar?


    Abraços.



  9. #9
    xargs -n 1 kill -9 Avatar de sergio
    Ingresso
    Jan 2004
    Localização
    Capital do Triângulo
    Posts
    5.202
    Posts de Blog
    9

    Padrão AP LINUX

    os comandos privados do chipset RTL possuem a opção master, não sei se todos as marcas que usam esse chipset disponibilizam o mesmo. Se usar o ndiswrapper esse comando não vai estar disponível, pois estará usando os drivers do windows.

  10. #10
    sadirj
    Visitante

    Padrão AP LINUX

    Citação Postado originalmente por sergio
    os comandos privados do chipset RTL possuem a opção master, não sei se todos as marcas que usam esse chipset disponibilizam o mesmo. Se usar o ndiswrapper esse comando não vai estar disponível, pois estará usando os drivers do windows.
    Voce poderia me dizer extamente onde coloco a opção MASTER ou me dar um exemplo? se não for pedir demais...

    Obrigado.



  11. #11
    xargs -n 1 kill -9 Avatar de sergio
    Ingresso
    Jan 2004
    Localização
    Capital do Triângulo
    Posts
    5.202
    Posts de Blog
    9

    Padrão AP LINUX

    poste aqui o arquivo de configuração da wlan.

  12. #12
    sadirj
    Visitante

    Padrão AP LINUX

    Código :
    #!/bin/sh
     
    IWPRIV="/usr/local/sbin/iwpriv"
     
    case "$1" in
            start)
                    $IWPRIV wlan0 wlan_para ssid2scan=localdomain
                    $IWPRIV wlan0 wlan_para basicrates=0x3
                    $IWPRIV wlan0 wlan_para networktype=infra
                    $IWPRIV wlan0 wlan_para oprates=0x3
                    $IWPRIV wlan0 wlan_para wepmode=off
                    $IWPRIV wlan0 wlan_para encmode=off
                    $IWPRIV wlan0 enable
    /sbin/ifup wlan0
     
                ;;
            stop)
     
            /sbin/ifdown wlan0
                    $IWPRIV wlan0 disable
     
                ;;
            *)
                    echo "Usage: /etc/init.d/wlan-realtek.init {start|stop}"
                ;;
    esac
    exit 0

    Aqu está o conteúdo do arquivo que "levanta" a placa REALTEK (RTL8180).
    Esse arquivo é carregado na inicialização antes das configurações de rede, de forma que, no arquivo /etc/network/interfaces eu possa setar configurações ip dela.
    Aguardo retorno e mais uma vez, obrigado.



  13. #13
    xargs -n 1 kill -9 Avatar de sergio
    Ingresso
    Jan 2004
    Localização
    Capital do Triângulo
    Posts
    5.202
    Posts de Blog
    9

    Padrão AP LINUX

    nesta opção:
    $IWPRIV wlan0 wlan_para networktype=infra
    mude para:
    $IWPRIV wlan0 wlan_para networktype=master

    Veja se funciona, caso nao funcione, comente essa linha e use:
    $IWPRIV wlan0 wlan_para mode=master

  14. #14
    sadirj
    Visitante

    Padrão AP LINUX

    Tentei as duas formas mas não funcionou. depois que carrego modulo e "estarto" a placa aparece o seguinte no /var/log/messages:

    Código :
    Nov 23 14:40:59 hermes kernel: RTL8180:  ------ Enable wlan driver ------
    Nov 23 14:40:59 hermes kernel: RTL8180: WLAN driver version 1.3
    Nov 23 14:40:59 hermes kernel: RTL8180: wireless LAN controller RTL8180 + philips RF.
    Nov 23 14:40:59 hermes kernel: RTL8180: PHILIPS_Config()
    Nov 23 14:40:59 hermes kernel: RTL8180: PHILIPS_Config() - Analog mode
    Nov 23 14:40:59 hermes kernel: RTL8180: ENABLE_RTL_DCST
    Nov 23 14:40:59 hermes kernel: RTL8180:  Set dot11PrivacyInvoked = 0.
    Nov 23 14:40:59 hermes kernel: RTL8180:  encryptmode = RTL_ENC_NONE
    Nov 23 14:40:59 hermes kernel: RTL8180:  wepkeymode = WEP_MODE_OFF
    Nov 23 14:41:02 hermes kernel: RTL8180: Start an IBSS network at channel 11
    Nov 23 14:41:02 hermes kernel: IBSSJoin(): Please check out the following ...
    Nov 23 14:41:02 hermes kernel: IBSSJoin(): BSSID = 0x02:0xe0:0x4f:0x2f:0x16:0x97
    Nov 23 14:41:02 hermes kernel: IBSSJoin(): SSID = aptest2
    Nov 23 14:41:02 hermes kernel: IBSSJoin(): dot11BeaconPeriod = 100
    Nov 23 14:41:02 hermes kernel: IBSSJoin(): dot11DtimPeriod = 0
    Nov 23 14:41:02 hermes kernel: IBSSJoin(): dot11OperationalRates = 0x03
    Nov 23 14:41:02 hermes kernel: IBSSJoin(): mCap = 0x02
    Nov 23 14:41:02 hermes kernel: RTL8180: Act_UpdateBeaconFrame......
    Nov 23 14:41:02 hermes kernel: RTL8180: TIM_setup......
    Nov 23 14:41:07 hermes kernel: RTL8180: Searching IBSS...
    Nov 23 14:41:10 hermes kernel: RTL8180: Start an IBSS network at channel 11
    Nov 23 14:41:10 hermes kernel: IBSSJoin(): Please check out the following ...
    Nov 23 14:41:10 hermes kernel: IBSSJoin(): BSSID = 0x02:0xe0:0x4f:0x2f:0x16:0x97
    Nov 23 14:41:10 hermes kernel: IBSSJoin(): SSID = aptest2
    Nov 23 14:41:10 hermes kernel: IBSSJoin(): dot11BeaconPeriod = 100
    Nov 23 14:41:10 hermes kernel: IBSSJoin(): dot11DtimPeriod = 0
    Nov 23 14:41:10 hermes kernel: IBSSJoin(): dot11OperationalRates = 0x03
    Nov 23 14:41:10 hermes kernel: IBSSJoin(): mCap = 0x02
    Nov 23 14:41:10 hermes kernel: RTL8180: Act_UpdateBeaconFrame......
    Nov 23 14:41:10 hermes kernel: RTL8180: TIM_setup......

    E fica assim direto, em um loop infinito. Parece que tem que compilar o modulo denovo com alguma opção... eu segui o passo-a-passo do Eduardo Mota, o único que consegui fazer funcionar. Segue o link:

    http://www.emota.com.br/wireless/rtl8180.html

    Obrigado mais uma vez.



  15. #15
    xargs -n 1 kill -9 Avatar de sergio
    Ingresso
    Jan 2004
    Localização
    Capital do Triângulo
    Posts
    5.202
    Posts de Blog
    9

    Padrão AP LINUX

    acho que falei asneira antes ops:

    use assim:
    iwpriv wlan0 disable -> desliga antes
    OS OUTROS COMANDOS...
    #iwpriv wlan0 drv_para apclient_enable=1 -> modo cliente
    iwpriv wlan0 drv_para apclient_enable=0 -> modo AP
    OS OUTROS COMANDOS...
    iwpriv wlan0 enable -> liga

    Se não funcionar, então essa placa que voce usa, ou os drivers que instalou não possui a opção.

  16. #16
    sadirj
    Visitante

    Padrão AP LINUX

    Sergio meu caro, valeu!!!! agora sim funcionou! vc tem uma lista completa dos comandos? o arquivo de exemplo que vem com ele não tinha essa opção que vc passou pra mim e que fez funcionar. Manda a lista ou melhor, me diz onde eu pego, que aí eu posso configurar de acordo com minhas necessidades.

    Desculpe pelo incômodo e mais uma vez, Muito Obrigado!



  17. #17
    xargs -n 1 kill -9 Avatar de sergio
    Ingresso
    Jan 2004
    Localização
    Capital do Triângulo
    Posts
    5.202
    Posts de Blog
    9

    Padrão AP LINUX

    sadirj, não tenho lista não... eu quase não uso RTL aqui(somente umas ovislink com linux), por isso vacilei no comando que passei primeiro... Na verdade esse comando que passei e funcionou é daqui mesmo (forum wireless), dica postada pelo aheringer. Quanto aos outros comandos possiveis tenta ae:
    #man iwpriv
    #iwpriv --help
    e a propria documentação que veio com os drivers que você compilou.