Página 5 de 5 PrimeiroPrimeiro 12345
+ Responder ao Tópico



  1. skysilva e denilson

    Tem que ter algum bug nesta versao que estou usando, porque estou tentanto usar o monowall com 2 placas de rede com fio e nao estou conseguindo navegar na internet.
    O que poderia ser? Nao estou usando a conexao wireless OPT1 para tentar resolver o problema usando a LAN e a WAN.

    Laercio

    <?xml version="1.0" ?>
    - <m0n0wall>
    <version>1.6</version>
    <lastchange>1134095805</lastchange>
    - <system>
    <hostname>m0n0wall</hostname>
    <domain>local</domain>
    <dnsallowoverride />
    <username>admin</username>
    <password>$1$2xGLA75j$W/jiJc00HYBZX7kFjxjQv0</password>
    <timezone>America/Sao_Paulo</timezone>
    <time-update-interval>300</time-update-interval>
    <timeservers>pool.ntp.org</timeservers>
    - <webgui>
    <protocol>http</protocol>
    <port />
    </webgui>
    <dnsserver>192.168.1.1</dnsserver>
    <dnsserver>192.168.1.101</dnsserver>
    </system>
    - <interfaces>
    - <lan>
    <if>sis0</if>
    <ipaddr>192.168.3.1</ipaddr>
    <subnet>24</subnet>
    <media />
    <mediaopt />
    </lan>
    - <wan>
    <if>dc0</if>
    <mtu />
    <media />
    <mediaopt />
    <spoofmac />
    <ipaddr>192.168.1.251</ipaddr>
    <subnet>21</subnet>
    <gateway>192.168.1.1</gateway>
    </wan>
    - <opt1>
    <descr>OPT1</descr>
    <if>wi0</if>
    - <wireless>
    <standard />
    <mode>hostap</mode>
    <ssid>lasewi</ssid>
    <stationname>kleberlx100</stationname>
    <channel>1</channel>
    <wep />
    </wireless>
    <ipaddr>192.168.4.1</ipaddr>
    <subnet>24</subnet>
    <bridge />
    <enable />
    </opt1>
    </interfaces>
    <staticroutes />
    <pppoe />
    <pptp />
    <bigpond />
    - <dyndns>
    <type>dyndns</type>
    <username />
    <password />
    <host />
    <mx />
    <server />
    <port />
    </dyndns>
    <dnsupdate />
    - <dhcpd>
    - <lan>
    - <range>
    <from>192.168.3.2</from>
    <to>192.168.3.10</to>
    </range>
    <enable />
    <defaultleasetime />
    <maxleasetime />
    </lan>
    - <opt1>
    - <range>
    <from>192.168.4.150</from>
    <to>192.168.4.151</to>
    </range>
    <defaultleasetime />
    <maxleasetime />
    <enable />
    </opt1>
    </dhcpd>
    - <pptpd>
    <mode />
    <redir />
    <localip />
    <remoteip />
    </pptpd>
    - <dnsmasq>
    <enable />
    </dnsmasq>
    - <snmpd>
    <syslocation />
    <syscontact />
    <rocommunity>public</rocommunity>
    </snmpd>
    - <diag>
    - <ipv6nat>
    <ipaddr />
    </ipv6nat>
    </diag>
    <bridge />
    <syslog />
    - <nat>
    - <advancedoutbound>
    <enable />
    </advancedoutbound>
    </nat>
    - <filter>
    - <rule>
    <type>pass</type>
    <interface>lan</interface>
    - <source>
    <network>lan</network>
    </source>
    - <destination>
    <any />
    </destination>
    <log />
    <descr>Default LAN -> any</descr>
    </rule>
    </filter>
    <shaper />
    <ipsec />
    <aliases />
    <proxyarp />
    <wol />
    </m0n0wall>

  2. Laércio, nunca testei com 2 placas de rede, não sei como ele se comporta... É até um teste que eu quero fazer ainda...

    Sobre o controle de banda, vou tentar exemplificar aqui. Vamos liberar 64 Kbps para um cara chamado joao:

    1 - na ficha pipes, adicione um pipe com bandwidth 64 e a descrição "pipe joao", por exemplo. Os coutros campos ficam e branco normalmente.

    2 - na ficha queues, adicione um queue com referência no "Pipe 1 (pipe joao)"; o campo weight vc pode entrar com valor de 1 a 100. Como você não deve ter clientes preferenciais, isto é, cada um é tão importante quanto o outro, você deve sempre colocar os valores iguais para todos. Por exemplo, se vc colocar weight=1 para o João, coloque 1 para todos os clientes, o importante é que todos tenham o mesmo valor. Mask pode ficar none e Description vc coloca "queue joao".

    3 - na ficha rules, vc terá q adicionar 2 rules para cada cliente, uma para download e outra para upload. O Target será o queue do clientes - ATENÇÃO - não é o pipe, é o queue. Escolha a interface do cliente, protocolo normalmente "any", e aqui vem a diferença das duas rules: uma será SOURCE type "single host or alias", com o IP do cara. A outra rule será DESTINATION type "single host or alias", com o IP do cara. Os outros campos podem ficar com os valores padrão, e o description vc entra com o nome do cliente. Uma rule é download e a outra é upload.

    Não tem erro!



  3. skysilva e denilson

    Ate que enfim consegui fazer o monowall funcionar como queria.
    Agradeço a ajuda de voces.
    Dois motivos me levaram a apanhar:
    1 - Como eu queria distribuir o sinal por um cartao wireless meu primeiro erro foi achar que eu poderia ligar a porta LAN do monowall na minha rede e distribuir o sinal por ela. Isto nao é possivel, ou seja, a porta LAN so pode ser usada para configurar o monowall ou se voce for cliente de uma rede a porta LAN vai ser usada para distribuir o sinal na rede local.
    2 - Usei como base a pagina http://socalfreenet.org/standardapm0n0wall , onde diz para habilitar "Enable advanced outbound NAT". Isto estava impossibiltando a distribuicao do sinal, mas nao sei extamente o que significa.

    Fiz o teste de usar duas placas de rede local uma LAN e outra na WAN e funciona perfeitamente.
    Acrescentei uma placa wireless como OPT1 e consegui navegar a contento.
    Fiz o teste do controle de banda explicado pelo Denilson e tambem funcionou perfeitamente.
    So meu restou uma duvida: no status da interface OPT1 e WAN aparecem colisoes de pacotes. O que seria? é normal? como resolve?
    Obrigado.


    Laercio

  4. Fico feliz q tenha conseguido!

    Sobre as colisões, veja minhas estatísticas:

    WAN:
    In/out packets 4682432/4377871 (3.50 GB/1.14 GB)
    In/out errors 0/0
    Collisions 62007

    OPT1:
    In/out packets 4586679/4713971 (1.18 GB/3.47 GB)
    In/out errors 0/0
    Collisions 188927

    Na verdade, eu acho o seguinte (me corrijam se eu estiver errado, pelo amor de Deus!):

    No tráfego da WAN, em 4.64 Gb de tráfego, tive 62 Kb de colisão... na OPT1, de 4.65 Gb tive 188 Kb de colisão... E em nenhuma das duas tem erro de entrada/saída. Nesse caso, eu acho que a colisão é bem pequena. Acho que pra dar problema, os valores devem ser maiores...

    Sobre o teste com 2 placas de rede, uma como LAN e outra como WAN, pra mim foi ótimo saber que funciona, esse é um teste q sempre quis fazer.

    Um abraço!



  5. #25
    Citação Postado originalmente por laerciok
    Denilson

    Voce quer dizer que se eu colocar o endereco IP da wan como 192.168.1.100, deixar o gateway 192.168.1.1 e remover as "static routes" deve funcionar?
    Eu tinha esta configuracao originalmente, mas acho que estavam faltando entao as regras de firewall para permitir a entrada da rede 192.168.1.0 pela porta wan.
    estou certo?
    Obrigado.

    Laercio






Tópicos Similares

  1. alias de placa de rede no m0n0wall
    Por itagildo no fórum Sistemas Operacionais
    Respostas: 0
    Último Post: 13-04-2006, 13:11
  2. Respostas: 0
    Último Post: 19-03-2006, 22:29
  3. m0n0wall
    Por rps67 no fórum Sistemas Operacionais
    Respostas: 2
    Último Post: 11-03-2006, 19:27
  4. M0n0wall+wireless
    Por sergio no fórum Redes
    Respostas: 0
    Último Post: 12-09-2005, 22:09
  5. m0n0wall primeiro contato
    Por skysilva no fórum Servidores de Rede
    Respostas: 5
    Último Post: 22-06-2005, 21:19

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L