+ Responder ao Tópico



  1. #1

    Padrão dois pcs em rede no slack

    Ola a todos, antes de mais nada queria dizer q ja fiz varias buscas pela net, ateh encontrei algumas respostas, mas nenhuma delas resolveu meu problema.

    Eu estou querendo ligar dois pcs em rede usando slackware 10.2 nos dois.
    Nao tenho hub portanto estou utilizando um cabo crossover.
    Na maquina servidor:
    eth0 pega adsl e ta com ip 192.168.1.1 e netmask 255.255.255.0
    eth1 vai pra rede com o ip 192.168.1.5 e netmask 255.255.255.0
    depois de configurar isto e os hostnames eu dou o comando:
    /etc/rc.d/rc.inet1 start

    na maquina cliente:
    eth0 q vai pra rede com ip 192.168.1.2 e netmask 255.255.255.0
    depois de configurar os hostnames dou o comando:
    /etc/rc.d/rc.inet1 start

    Depois de tudo isso eu rodo o ifconfig nas duas maquinas pra verificar se os ips estao corretos, e estao, mas ao tentar pingar as maquina eu recebo a respota:
    bash-3.00# ping 192.168.1.2
    PING 192.168.1.2 (192.168.1.2) 56(84) bytes of data.
    From 192.168.1.1 icmp_seq=1 Destination Host Unreachable
    quando tento pingar do server para o client, e a mesma coisa acontece ao tentar pingar do cliente pro servidor.
    A internet ta funcionando normalmente no servidor.

    O que falta configurar nesta rede?

    agradeço antecipadamente

  2. #2

    Padrão Re: dois pcs em rede no slack

    Citação Postado originalmente por carne_de_passaro
    Ola a todos, antes de mais nada queria dizer q ja fiz varias buscas pela net, ateh encontrei algumas respostas, mas nenhuma delas resolveu meu problema.

    Eu estou querendo ligar dois pcs em rede usando slackware 10.2 nos dois.
    Nao tenho hub portanto estou utilizando um cabo crossover.
    Na maquina servidor:
    eth0 pega adsl e ta com ip 192.168.1.1 e netmask 255.255.255.0
    eth1 vai pra rede com o ip 192.168.1.5 e netmask 255.255.255.0
    depois de configurar isto e os hostnames eu dou o comando:
    /etc/rc.d/rc.inet1 start

    na maquina cliente:
    eth0 q vai pra rede com ip 192.168.1.2 e netmask 255.255.255.0
    depois de configurar os hostnames dou o comando:
    /etc/rc.d/rc.inet1 start

    Depois de tudo isso eu rodo o ifconfig nas duas maquinas pra verificar se os ips estao corretos, e estao, mas ao tentar pingar as maquina eu recebo a respota:
    bash-3.00# ping 192.168.1.2
    PING 192.168.1.2 (192.168.1.2) 56(84) bytes of data.
    From 192.168.1.1 icmp_seq=1 Destination Host Unreachable
    quando tento pingar do server para o client, e a mesma coisa acontece ao tentar pingar do cliente pro servidor.
    A internet ta funcionando normalmente no servidor.

    O que falta configurar nesta rede?

    agradeço antecipadamente

    faz o seguinte...poe ip na eth1 192.168.2.1 e faz o NAT...

    iptables -t nat -A POSTROUTING -o eth0 -s 192.168.2.0/24 -j MASQUERADE (a eth0 nesse caso eh a interface que recebe adsl)
    e no cliente poe 192.168.2.2...

    outra coisa q vc pode verificar e se as luzes das placas de rede acendem no momento em q vc conecta o cabo....caso não..verifique os cabos...

    espero ter ajudado...abraços...



  3. #3

    Padrão dois pcs em rede no slack

    Ola Mr_Dom, olha eu fiz o seguinte agora:
    eu colocquei os respectivos ips q vc disse nas placas de redes, colcando os no /etc/rc.d/rc.inet1
    e depois no server eu fiz o nat q vc me passou, mas mesmo assim nao funcionou.
    e desculpe a ignorancia, o ip 192.168.2.0 eh pra placa que recebe a adsl correto?
    pois foi o q fiz e ainda assim nada

    Os cabos estão ok, pois foram testados.
    Tem mais alguma outra ideia?

    valew pela força!!

  4. #4

    Padrão dois pcs em rede no slack

    Citação Postado originalmente por carne_de_passaro
    Ola Mr_Dom, olha eu fiz o seguinte agora:
    eu colocquei os respectivos ips q vc disse nas placas de redes, colcando os no /etc/rc.d/rc.inet1
    e depois no server eu fiz o nat q vc me passou, mas mesmo assim nao funcionou.
    e desculpe a ignorancia, o ip 192.168.2.0 eh pra placa que recebe a adsl correto?
    pois foi o q fiz e ainda assim nada

    Os cabos estão ok, pois foram testados.
    Tem mais alguma outra ideia?

    valew pela força!!


    seria mais ou menos assim...

    a eth0 recebe da adsl...(isso vc ja deve ter configurado)
    a eth1 seria a que espalha, intaum seria...

    IPADDR="192.168.2.1"
    NETMASK="255.255.255.0"

    use o NAT pra passar a net da adsl pra outras ifaces...

    iptables -t nat -A POSTROUTING -o eth0 -s 192.168.2.0/24 -j MASQUERADE


    no cliente use o seguinte..

    IPADDR="192.168.2.2"
    NETMASK="255.255.255.0"
    GATEWAY="192.168.2.1"

    a meu ver..tem q fungar...so o hostname ta configurado conforme vc me falou....

    qualquer coisa posta ae o resultado...e posta tmb o resultado do comando ifconfig e do comando iptables -t nat -L das duas maquinas......

    abraços e até mais...



  5. #5

    Padrão dois pcs em rede no slack

    Velho ta dificil aqui, eu acabei de fazer isso q vc falou e tb nao funcionou
    a eth0 q recebe a internet esta funcionando corretamente (estou conectado agora por ela) abaixo segue o resultado do ifconfig da maquina servidora:

    bash-3.00# ifconfig
    eth0 Link encap:Ethernet HWaddr 00:0E:A6:78:77:BB
    inet addr:192.168.2.0 Bcast:192.168.2.255 Mask:255.255.255.0
    inet6 addr: fe80::20e:a6ff:fe78:77bb/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:586 errors:0 dropped:0 overruns:0 frame:0
    TX packets:577 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:455556 (444.8 Kb) TX bytes:63165 (61.6 Kb)
    Interrupt:3 Base address:0x8400

    eth1 Link encap:Ethernet HWaddr 00:02:2A4:B5:43
    inet addr:192.168.2.1 Bcast:192.168.2.255 Mask:255.255.255.0
    inet6 addr: fe80::202:2aff:fed4:b543/64 Scope:Link
    UP BROADCAST MULTICAST MTU:1500 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
    Interrupt:11 Base address:0x8000

    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    inet6 addr: ::1/128 Scope:Host
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:2 errors:0 dropped:0 overruns:0 frame:0
    TX packets:2 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:100 (100.0 b) TX bytes:100 (100.0 b)

    ppp0 Link encap:Point-to-Point Protocol
    inet addr:200.161.165.20 P-t-P:200.100.11.72 Mask:255.255.255.255
    UP POINTOPOINT RUNNING NOARP MULTICAST MTU:1492 Metric:1
    RX packets:550 errors:0 dropped:0 overruns:0 frame:0
    TX packets:538 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:3
    RX bytes:441214 (430.8 Kb) TX bytes:49862 (48.6 Kb)

    agora o ifconfig da maquina cliente:

    bash-3.00# ifconfig
    eth0 Link encap:Ethernet HWaddr 000:09F:90:1E
    inet addr:192.168.2.2 Bcast:192.168.2.255 Mask:255.255.255.0
    UP BROADCAST MULTICAST MTU:1500 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:0 (0.0 Kb) TX bytes:0 (0.0 Kb)
    Interrupt:1 Base address:0xd400

    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:2 errors:0 dropped:0 overruns:0 frame:0
    TX packets:2 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:100 (100.0 b) TX bytes:100 (100.0 b)

    e agora o resultado do iptables t nat -L das duas maquinas (estao iguais):

    bash-3.00# iptables -t nat -L
    Chain PREROUTING (policy ACCEPT)
    target prot opt source destination

    Chain POSTROUTING (policy ACCEPT)
    target prot opt source destination
    MASQUERADE all -- 192.168.2.0/24 anywhere

    Chain OUTPUT (policy ACCEPT)
    target prot opt source destination


    ufa! eh isso, velho ja nao sei mais o q fazer, ah antes q eu me esqueça o resultado do ping do servidor pro cliente:

    bash-3.00# ping 192.168.2.2
    PING 192.168.2.2 (192.168.2.2) 56(84) bytes of data.
    From 192.168.2.0 icmp_seq=1 Destination Host Unreachable
    From 192.168.2.0 icmp_seq=2 Destination Host Unreachable
    From 192.168.2.0 icmp_seq=3 Destination Host Unreachable

    --- 192.168.2.2 ping statistics ---
    3 packets transmitted, 0 received, +3 errors, 100% packet loss, time 2014ms
    , pipe 3

    eh isso

    obrigado

  6. #6

    Padrão dois pcs em rede no slack

    cara, já pensou na hipótese do cabo não estar com a pinagem correta ou com algumas pontas soltas? tenta usar um testador que conheca cabo cross pra ver!!!



  7. #7

    Padrão dois pcs em rede no slack

    bom velho, vou tentar testar este cabo, pode ser isso mesmo pq eu acho q a configuraçao esta correta. Mas eu pensei comigo, o modem q eu uso nao eh roteador, soh tem uma entrada RJ-45, ele veio com um cabo (apararentemente cross - vem escrito "patch cable UTP CAT-5")ok, dae ontem à noite eu crimpei um cabo cross pra tentar ligar meu outro pc em rede (conexao pc-pc)configurei tudo e nao pingava de jeito nenhum. Dae eu tive a ideia de trocar os cabos: colocar o q veio no modem pra placa q distribui a rede e o cabo q eu crimpei eu liguei no modem e na eth0 para ter acesso à internet, e funcionou normalmente, ou seja, eu concluo q meu cabo foi crimpado corretamente não é?

    Eu nao entendo muita coisa de redes, mas eu acho q se o cabo funcionou no modem nao pode ser problema dele certo? Me corrija se eu estiver errado por favor!

    Mesmo assim, meu camarada tem uns cabos de rede q ele pegou na empresa dele e assim q ele chegar vou pedir emprestado e testar tudo denovo, vamos ver no q da

    mesmo assim valeu pela atençao!!!

    abraços

  8. #8

    Padrão dois pcs em rede no slack

    fala!

    bom.. tenho uma idéia para você! deixe somente uma placa de rede em cada micro e configure ip fixo em cada uma! assim você testa com ping e não tem como ter erro.. desse modo você testa o cabo e a comunicação entre eles!

    outra.. sempre que vejo configuração de compartilhamento, o micro com duas placas de rede fica com subnets diferente! exemplo:

    servidor
    eth0 : 192.168.x.1 [internet]
    eth1 : 192.168.z.1 [rede]

    outros micros da rede
    eth0 : 192.168.z.???

    esse configuração de colocar subnets diferente no servidor é necessária? pelo que percebi você deixou as duas placas do servidor na mesma sub..

    abraços..



  9. #9

    Padrão dois pcs em rede no slack

    Só complementando um pouco o que os amigos colocaram acima a sua eth0 está com o ip 192.168.2.0 o que está incorreto.

  10. #10

    Padrão dois pcs em rede no slack

    _N30_ vc matou a charada!!!!
    era isso mesmo era soh trocar a subrede das placas do servidor!!!
    agora eles estao pingando um com o outro, mas surgiu um pequeno problema:
    a internet nao esta compartilhada, mas eu acho isso deva ser mais facil de configurar.

    muito obrigado mesmo pela informaçao, nunca mais vou esquecer isso!!

    Obrigado a vcs dois q me ajudaram e um abraçao pra vcs!!



  11. #11

    Padrão dois pcs em rede no slack

    nod3vic3 eu ja corrigi esse ip, obrigado
    agora soh falta o compartilhamento

  12. #12

    Padrão dois pcs em rede no slack

    blz amigo!

    estamos aki para compartilhar o conhecimento.. eu é que tenho que tomar vergonha e deixar de usar roteador+hub e estudar mais iptables!! rs..
    quando encontrar a resposta poste os resultados..

    abraços e boas festas



  13. #13

    Padrão dois pcs em rede no slack

    Citação Postado originalmente por carne_de_passaro
    Velho ta dificil aqui, eu acabei de fazer isso q vc falou e tb nao funcionou
    a eth0 q recebe a internet esta funcionando corretamente (estou conectado agora por ela) abaixo segue o resultado do ifconfig da maquina servidora:

    bash-3.00# ifconfig
    eth0 Link encap:Ethernet HWaddr 00:0E:A6:78:77:BB
    inet addr:192.168.2.0 Bcast:192.168.2.255 Mask:255.255.255.0
    inet6 addr: fe80::20e:a6ff:fe78:77bb/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:586 errors:0 dropped:0 overruns:0 frame:0
    TX packets:577 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:455556 (444.8 Kb) TX bytes:63165 (61.6 Kb)
    Interrupt:3 Base address:0x8400

    eth1 Link encap:Ethernet HWaddr 00:02:2A4:B5:43
    inet addr:192.168.2.1 Bcast:192.168.2.255 Mask:255.255.255.0
    inet6 addr: fe80::202:2aff:fed4:b543/64 Scope:Link
    UP BROADCAST MULTICAST MTU:1500 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
    Interrupt:11 Base address:0x8000

    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    inet6 addr: ::1/128 Scope:Host
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:2 errors:0 dropped:0 overruns:0 frame:0
    TX packets:2 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:100 (100.0 b) TX bytes:100 (100.0 b)

    ppp0 Link encap:Point-to-Point Protocol
    inet addr:200.161.165.20 P-t-P:200.100.11.72 Mask:255.255.255.255
    UP POINTOPOINT RUNNING NOARP MULTICAST MTU:1492 Metric:1
    RX packets:550 errors:0 dropped:0 overruns:0 frame:0
    TX packets:538 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:3
    RX bytes:441214 (430.8 Kb) TX bytes:49862 (48.6 Kb)

    agora o ifconfig da maquina cliente:

    bash-3.00# ifconfig
    eth0 Link encap:Ethernet HWaddr 000:09F:90:1E
    inet addr:192.168.2.2 Bcast:192.168.2.255 Mask:255.255.255.0
    UP BROADCAST MULTICAST MTU:1500 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:0 (0.0 Kb) TX bytes:0 (0.0 Kb)
    Interrupt:1 Base address:0xd400

    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:2 errors:0 dropped:0 overruns:0 frame:0
    TX packets:2 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:100 (100.0 b) TX bytes:100 (100.0 b)

    e agora o resultado do iptables t nat -L das duas maquinas (estao iguais):

    bash-3.00# iptables -t nat -L
    Chain PREROUTING (policy ACCEPT)
    target prot opt source destination

    Chain POSTROUTING (policy ACCEPT)
    target prot opt source destination
    MASQUERADE all -- 192.168.2.0/24 anywhere

    Chain OUTPUT (policy ACCEPT)
    target prot opt source destination


    ufa! eh isso, velho ja nao sei mais o q fazer, ah antes q eu me esqueça o resultado do ping do servidor pro cliente:

    bash-3.00# ping 192.168.2.2
    PING 192.168.2.2 (192.168.2.2) 56(84) bytes of data.
    From 192.168.2.0 icmp_seq=1 Destination Host Unreachable
    From 192.168.2.0 icmp_seq=2 Destination Host Unreachable
    From 192.168.2.0 icmp_seq=3 Destination Host Unreachable

    --- 192.168.2.2 ping statistics ---
    3 packets transmitted, 0 received, +3 errors, 100% packet loss, time 2014ms
    , pipe 3

    eh isso

    obrigado

    amigo, to vendo q vc ta usando ppp0...tenta usar assim o NAT no servidor....no cliente naum eh necessário...

    iptables -t nat -A POSTROUTING -o ppp0 -s 192.168.2.0/24 -j MASQUERADE


    se vc tiver a adsl ligada na eth1 deixe ela sem ip e use ip
    192.168.2.1 na eth0 que é ligada na placa de rede do cliente ae no cliente use ip 192.168.2.2...

    me corrijam se eu estiver errado....abraços e até mais..

  14. #14
    Fabio_Laé
    Visitante

    Padrão dois pcs em rede no slack

    Primeiramente, um roteador serve para conectar(rotear pacotes) subredes diferentes. (Não era pq vc estava usando a mesma subrede que o ping nao tava funcionando, concorda?)

    Segundo, seu ping não estava funcionando simplesmente por causa que a sua eth0 estava igual 192.168.2.0 e quando o final é zero(0) representa o ip da rede e não de uma estação.

    Terceiro, tenta deixar a sua eth externa pra receber o ip via dhcp do seu modem.

    Abraços,

    Fabio Laé



  15. #15

    Padrão dois pcs em rede no slack

    olha pessoal, a rede ta ok mas o compartilhamento de internet nao.
    estes comandos do iptables q foram passados nao deu certo aqui.
    Soh mais uma duvida besta: se eu deixo a eth0(adsl) sem ip, eu devo colocar qual ip pra gateway no cliente? seria o ip da eth1 q espalha a rede?

  16. #16

    Padrão dois pcs em rede no slack

    pessoal o problema do compartilhamento foi resolvido, uma pessoa me ajudou no irc.

    Eu tive q descomentar as linhas referentes a compartilhamento no /etc/rc.d/rc.modules, mudar nesse arquivo o q estava EXTERNAL=eth0 pra ppp0
    e jo cliente o resolv.conf tava errado, dae eu coloquei um dns valido e pronto, funcionou!

    Obrigado pela ajuda de vcs!!

    abraços



  17. #17

    Padrão dois pcs em rede no slack

    falae!!

    só um detalhe.. como você está configurando o dns do cliente? eu estava com um problema parecido: ele só pingava ips! mas num carregava nenhuma página... entaum configurei o dns corretamente e a net ficou perfeita!

  18. #18

    Padrão dois pcs em rede no slack

    ihhh! já resolveu...