Página 2 de 2 PrimeiroPrimeiro 12
+ Responder ao Tópico



  1. #21

    Padrão conectividade no freebsd

    Nao, do jeito como eu coloquei ali em cima.
    6)

  2. #22

    Padrão conectividade no freebsd

    kra nada velho só funciona com essa regra aqui:



    #ipfw add 2 allow tcp from 200.199.219.2 to any 80
    #ipfw add 3 fwd 127.0.0.1,3128 tcp from any to any 80


    só que tá sem o trecu da caixa



  3. #23

    Padrão conectividade no freebsd

    ok.. vamos por passos entao....

    nao esqueceu do "gateway_enable=yes" no rc.conf?
    está com o kernel compilado com a opcao de divert ? (IPDIVERT)?

    se sim, verifique a rota default da maquina

    IP Publico: 200.193.50.5 (rl1)
    IP Interno: 192.168.1.0 (rl0)

    vamos para as regras (supondo as informacoes acima)

    /sbin/natd -s -m -n rl1
    ipfw add 5 skipto 50 tcp from 192.168.1.0/24 to 200.201.0.0/16
    ipfw add 10 fwd localhost,3128 tcp from any to not me 80 via rl0
    ipfw add 50 divert 8668 ip from any to any via rl1
    ipfw add 60 allow ip from any to any

    Tenta aí, se nao funcionar, é pq nao é do firewall.
    6)

  4. #24

    Padrão conectividade no freebsd

    meu rc.conf:

    defaultrouter="200.199.219.1"
    natd_enable="YES"
    natd_interface="rl0" interface da net
    firewall_enable="YES"
    firewall_type="OPEN"
    gateway_enable="YES"
    ifconfig_rl0="inet 200.199... netmask 255.255.255.192"
    ifconfig_rl1="inet 192.168.0.1 netmask 255.255.255.252"
    ifconfig_rl1_alias0="inet 192.168.1.1 netmask 255.255.255.252"
    ifconfig_rl1_alias1="inet 192.168.2.1 netmask 255.255.255.252"
    inetd_enable="YES"
    sshd_enable="YES"
    keymap="br275.iso.acc"
    squid_enable="YES"

    não deu certo ele bloqueia todos os sites

    :good:



  5. #25

    Padrão conectividade no freebsd

    Bem, altere os seguintes parametros no seu rc.conf:

    (remova o natd_interface, e deixe somente isso aí)

    natd_enable=YES
    natd_flags="-s -m -n rl0"

    (altere o firewall_type para
    firewall_type=/etc/firesetup


    agora crie o arquivo /etc/firesetup com essas regras (sem o ipfw na frente de cada regra)


    -f flush
    disable one_pass
    add 5 skipto 50 tcp from 192.168.1.0/24 to 200.201.0.0/16
    add 10 fwd localhost,3128 tcp from any to not me 80 via rl1
    add 50 divert 8668 ip from any to any via rl0
    add 60 allow ip from any to any


    nao esqueca de apagar as regras que voce criou na inicializacao (para nao sobreescrever essas novas)

    6)

  6. #26

    Padrão conectividade no freebsd

    opa agora ele passo pelo proxy normalmente, mas o site da caixa não funciona




    tamos quase chegando lá


    :cry: :cry: :cry: :cry: :good: :good:



  7. #27

    Padrão conectividade no freebsd

    :good: :good: :good: :good: :good: :good: :good: :good:




    GrayFox kra ce é o máximus velho deu certo eu fiz o seguinte

    -f flush
    disable one_pass
    add 5 skipto 50 tcp from 192.168.0.0/16 to 200.201.174.0/24
    add 10 fwd localhost,3128 tcp from any to not me 80 via rl1
    add 50 divert 8668 ip from any to any via rl0
    add 60 allow ip from any to any



    hehehehe dai funcionaoooo legal velho Graças a Deus

  8. #28

    Padrão conectividade no freebsd

    Parabens,

    Se quiser mais informações, leia o handbook, tem muita coisa interessante por lá.

    Estou tirando uma rapida ferias de 1 semana, daqui a 1 semana estou devolta.

    Um abraço.
    6)