+ Responder ao Tópico



  1. #1

    Padrão PORQUE iptables -t nat -A... NÃO ROTEIA A INTERNET?

    Prezados amigos, sou novo no mundo linux, e estou querendo adentrar neste universo, tenho bastante experiência em redes, mas estou abituado com ambiente windows.

    Montei um abiente em casa para começar a estudar e instalei um computador P233, 64ram, hd8gb, duas interfaces ethernet eth0, eth1 realteck, SO Salackware 10.

    Depois de caçar em vários tutoriais na internet configurei ele como servidor DHCP e no meu outro computador tenho windows xp recebendo IP do servidor dhcp em linux que habilitei, isso funciona na boa agora o compartilhamento de internet não funciona nem por um decreto.

    Na eth0 eu pluguei o cabo de rede da internet que é um modem speedstream 5200 roteado ou seja ele manda para eth0 um ip assim 192.168.254.7 eu fixei esse ip na eth0, e na eth1 fixei 192.168.0.1
    usando ifconfig eth1 192.168.0.1 netmask 255.255.255.0 up, e coloco no rc.local pra quando reiniciar o micro não ter que refazer isso e lanço o comando iptables -t nat -A POSTROUTING -o eth0 -j MASQUERADE o comando aceita na boa mas quando vou pra máquina windows não entra na internet de jeito nenhum tentei acessar site pelo IP pra ver se poderia ser alguma coisa de DNS mas mesmo assim não vai, já usei um comando, um tal de modeprobe no iptables pra ver se dava algum erro mas não apareceu nenhum gostaria de saber se existe mais algum teste que eu possa fazer pra saber porque minha internet não roteia.

  2. #2
    Moderador Avatar de Bruno
    Ingresso
    Nov 2002
    Localização
    Guarapuava-PR
    Posts
    3.923
    Posts de Blog
    1

    Padrão PORQUE iptables -t nat -A... NÃO ROTEIA A INTERNET?

    este comando só faz que toda sua rede sai com o ip da eth0 isto naum vai fazer navegar
    vc tem que habilifar o ip_forward



  3. #3

    Padrão PORQUE iptables -t nat -A... NÃO ROTEIA A INTERNET?

    Como eu habilito o ip_forward, sem querer incomoda-lo?

  4. #4
    Moderador Avatar de Bruno
    Ingresso
    Nov 2002
    Localização
    Guarapuava-PR
    Posts
    3.923
    Posts de Blog
    1

    Padrão PORQUE iptables -t nat -A... NÃO ROTEIA A INTERNET?

    /etc/rc.d/rc.ip_forward start



  5. #5

    Padrão PORQUE iptables -t nat -A... NÃO ROTEIA A INTERNET?

    Obrigado pela ajuda, mas como eu sou muito leigo em linux é só eu digitar essa linha logado como root?

  6. #6

    Padrão PORQUE iptables -t nat -A... NÃO ROTEIA A INTERNET?

    Sem querer abusar vc tem msn? eu poderia adiciona-lo na minha lista?



  7. #7

    Padrão PORQUE iptables -t nat -A... NÃO ROTEIA A INTERNET?

    Citação Postado originalmente por vioflas
    Sem querer abusar vc tem msn? eu poderia adiciona-lo na minha lista?
    Cara sem querer ser chato são atitudes como essas que acabam com o espirito do forum, pois em vez de discutir assim voce vai pro msn do cara e acaba com o forum, por isso acho que voce devia aprender mais o conceito de comunidade.

    falows

  8. #8

    Padrão PORQUE iptables -t nat -A... NÃO ROTEIA A INTERNET?

    Cara teste o que o amigo falou e poste seus resultados no Forum, assim mais alguém acaba aprendendo.



  9. #9
    Moderador Avatar de Bruno
    Ingresso
    Nov 2002
    Localização
    Guarapuava-PR
    Posts
    3.923
    Posts de Blog
    1

    Padrão PORQUE iptables -t nat -A... NÃO ROTEIA A INTERNET?

    amigo vamos pelo forum pois varias pessoas passom pelo que vc ta passando



    digita isto no terminal

  10. #10

    Padrão PORQUE iptables -t nat -A... NÃO ROTEIA A INTERNET?

    Bem vou fazer o que vocês disseram vou digitar isso lá no terminal e vou ver o que vai dar, valeu obrigado.

    desculpe o incomodo.



  11. #11
    fisiconuclear18
    Visitante

    Padrão PORQUE iptables -t nat -A... NÃO ROTEIA A INTERNET?

    cara digita assim como root
    echo 1 > /proc/sys/net/ipv4/ip_forward
    E deu isso habilita o roteamento

  12. #12
    fisiconuclear18
    Visitante

    Padrão PORQUE iptables -t nat -A... NÃO ROTEIA A INTERNET?

    cara digita assim como root
    echo 1 > /proc/sys/net/ipv4/ip_forward
    E deu isso habilita o roteamento



  13. #13

    Padrão PORQUE iptables -t nat -A... NÃO ROTEIA A INTERNET?

    É pra colocar esse comando rc.local para toda vez que inicializar o computador executar este comando.

  14. #14
    Moderador Avatar de Bruno
    Ingresso
    Nov 2002
    Localização
    Guarapuava-PR
    Posts
    3.923
    Posts de Blog
    1

    Padrão PORQUE iptables -t nat -A... NÃO ROTEIA A INTERNET?

    vc pode fazer assim
    chmod 755 /etc/rc.d/rc.ip_forward
    assim vc ativa ele para inicar toda vez que a maquina for iniciada



  15. #15
    Visitante

    Padrão PORQUE iptables -t nat -A... NÃO ROTEIA A INTERNET?

    Ok, valeu mesmo pela ajuda acho que depois de todas essas dicas não tem como não rotear.

    Desde já agradeço a colaboração de todos os participantes do forum.

  16. #16

    Padrão PORQUE iptables -t nat -A... NÃO ROTEIA A INTERNET?

    Olá amigo faz assim vai lá no em etc/rc.d/rc.local onde "rc.local' é uma especie de autoexec.bat. Ele é executado toda a vez que a maquina ligar.
    faz assim:
    ifconfig eth0 x.x.x.x netmask x.x.x.x
    ifconfig eth1 x.x.x.x netmask x.x.x.x
    route add default gw x.x.x.x ip do seu modem
    iptables -t nat -A POSTROUNTING -o eth1 -j MASQUERADE
    onde eth1 é a placa ligada no modem.

    feito isso concerteza vai funfa.



  17. #17

    Padrão PORQUE iptables -t nat -A... NÃO ROTEIA A INTERNET?

    amigo!
    sempre que tiver dúvidas venha ao forum.. estamos dispostos a ajudar! mas sempre lembre de usar a pesquisa do forum e os manuais oficiais da sua distro! e sempre dizer que distro está usando.. ajuda mto! semana passada outro amigo teve a mesma dúvida..
    é possível deixar os ips fixos sem que seja preciso colocar os comandos para levantar os ipd no rc.local!

    enfim, fiz exatamente essa configuração nesta semana! qualquer dúvida entre em contato..
    abraços..

  18. #18

    Padrão PORQUE iptables -t nat -A... NÃO ROTEIA A INTERNET?

    Pessoal deu certo, quando cheguei em casa a primeira coisa que fiz foi testar a parada o comando que deu certo foi o echo 1 > /proc/...

    mas o parceiro que passou a outro dica complementou pra mim que da outra forma eu teria que dar a permissão no arquivo assim: chmod +x /etc/rc.d/rc.ip_forward