Página 2 de 2 PrimeiroPrimeiro 12
+ Responder ao Tópico



  1. #6
    MarcoNascimento
    Já consegui resolver o problema do Lilo, eu estava tentando editar o Lilo entrando no root com o comando "su", quando abri um terminal já como root, ele aceitou as alterações.
    Quanto ao modem, o que está acontecendo é o seguinte, ao dar o comando "make install" nas linhas finais começaram a surgir os seguintes erros:

    softserial.c:100: error: structure has no member named `table'

    softserial.c:115: warning: assignment from incompatible pointer type

    softserial.c: In function `softserial_open':

    softserial.c:161: error: `MOD_IN_USE' undeclared (first use in this function)
    softserial.c:161: error: (Each undeclared identifier is reported only once

    softserial.c:161: error: for each function it appears in.)

    softserial.c:163: error: `MOD_INC_USE_COUNT' undeclared (first use in this functi
    on)
    softserial.c:169: error: structure has no member named `device'

    softserial.c:169: error: request for member `minor_start' in something not a structure or union

    softserial.c:177: error: structure has no member named `normal_termios'

    softserial.c:187: error: structure has no member named `tqueue'

    softserial.c:188: error: structure has no member named `tqueue'

    softserial.c:189: error: structure has no member named `session'

    softserial.c:189: error: structure has no member named `session'

    softserial.c:190: error: structure has no member named `pgrp'

    softserial.c:190: error: structure has no member named `pgrp'

    softserial.c:205: error: `MOD_DEC_USE_COUNT' undeclared (first use in this function)
    softserial.c: In function `softserial_close':

    softserial.c:222: error: `MOD_IN_USE' undeclared (first use in this function)
    softserial.c:224: error: `MOD_DEC_USE_COUNT' undeclared (first use in this function)
    make[1]: ** [softserial.o] Erro 1

    make[1]: Leaving directory `/home/kurumin/Meus Documentos/Arquivos/Intel537/intel-537EP_secure-2.27.39.0/serialdrv'

    make: ** [537] Erro 2
    kurumin@kurumin:~/Meus Documentos/Arquivos/Intel537/intel-537EP_secure-2.27.39.0$

    Obrigado.
    MarcoNascimento

  2. vc baixa esse driver: http://linmodems.technion.ac.il/pack...-2.60.80.0.tgz

    Como vc é iniciante, e vai ter mesmo q criar um script pra nao ter q recriar o link simbolico toda vez q rebootar, crie logo o script q faz tudo.
    Faça assim:
    Abra o kedit (menuk/editores) e copie e cole isso daqui:
    É recomendado q vc esteja usando o navegador Firefox.....

    #!/bin/sh
    tar -zxvf intel-537-2.60.80.0.tgz
    cd intel-537-2.60.80.0
    make clean
    make 537
    sudo make install
    sudo rm -f /dev/ham
    sudo rm -f /dev/modem
    sudo mknod /dev/ham c 240 1
    sudo ln -s /dev/ham /dev/modem
    sudo chmod ugo+rwx /dev/modem
    sudo chmod 666 /dev/modem

    sudo echo 'rm -f /dev/modem' >> /etc/init.d/modem-intel
    sudo echo 'ln -s /dev/ham /dev/modem' >> /etc/init.d/modem-intel

    sudo ln /etc/init.d/modem-intel /etc/rc5.d/S9999modem-intel
    sudo chmod +x /etc/init.d/modem-intel


    Dae salve na mesma pasta onde vc salvou o driver com um nome qualquer: "modemintel" por exemplo
    Depois entre nessa pasta, click F4 (q vai abrir o konsole nessa pasta)
    sudo su
    chmod +x modemintel
    ./modemintel

    Pronto! o seu driver deve está instalado....

    OBS: se o seu modem for o EP, repare q vc tem q corrigir o nome do driver q vc baixou....
    Ao inves de
    #!/bin/sh

    tar -zxvf intel-537-2.60.80.0.tgz

    Vc coloca:
    #!/bin/sh

    tar -zxvf intel-537EP-2.60.80.0.tgz

    Tenta ae

    para mais informações, este texto foi retirado de : http://www.kuruminlinux.com.br/comun...1c3b76e7be3414



  3. #8
    MarcoNascimento
    mbyte, não sei se eu sou leigo demais no Linux ou se isso está mesmo complicado, não deu certo novamente, veja se dá pra descobrir o que deu errado:


    root@kurumin:/home/kurumin/Meus Documentos/Arquivos/Intel537EP# ./modemintel
    intel-537EP_secure-2.60.80.0/
    intel-537EP_secure-2.60.80.0/537_boot
    intel-537EP_secure-2.60.80.0/537_inst
    intel-537EP_secure-2.60.80.0/config_check
    intel-537EP_secure-2.60.80.0/coredrv/
    intel-537EP_secure-2.60.80.0/coredrv/537core.lib
    intel-537EP_secure-2.60.80.0/coredrv/afedsp_int.c
    intel-537EP_secure-2.60.80.0/coredrv/afedsp_int.h
    intel-537EP_secure-2.60.80.0/coredrv/clmmain.c
    intel-537EP_secure-2.60.80.0/coredrv/coredrv.c
    intel-537EP_secure-2.60.80.0/coredrv/hamcore.h
    intel-537EP_secure-2.60.80.0/coredrv/hamdefs.h
    intel-537EP_secure-2.60.80.0/coredrv/locks.c
    intel-537EP_secure-2.60.80.0/coredrv/lock_lin.h
    intel-537EP_secure-2.60.80.0/coredrv/Makefile
    intel-537EP_secure-2.60.80.0/coredrv/rts.c
    intel-537EP_secure-2.60.80.0/coredrv/rts.h
    intel-537EP_secure-2.60.80.0/coredrv/softcore.h
    intel-537EP_secure-2.60.80.0/coredrv/softserial.c
    intel-537EP_secure-2.60.80.0/coredrv/softserial.h
    intel-537EP_secure-2.60.80.0/coredrv/softserial_io.c
    intel-537EP_secure-2.60.80.0/coredrv/softserial_ioctl.c
    intel-537EP_secure-2.60.80.0/coredrv/sys_ver.h
    intel-537EP_secure-2.60.80.0/coredrv/task.c
    intel-537EP_secure-2.60.80.0/coredrv/tasker.h
    intel-537EP_secure-2.60.80.0/coredrv/uart.c
    intel-537EP_secure-2.60.80.0/coredrv/uart.h
    intel-537EP_secure-2.60.80.0/coredrv/wwh_dflt.c
    intel-537EP_secure-2.60.80.0/coredrv/wwh_dflt.h
    intel-537EP_secure-2.60.80.0/hamregistry
    intel-537EP_secure-2.60.80.0/license.txt
    intel-537EP_secure-2.60.80.0/makefile
    intel-537EP_secure-2.60.80.0/readme.txt
    intel-537EP_secure-2.60.80.0/usrsound
    cd coredrv; make clean
    make[1]: Entering directory `/home/kurumin/Meus Documentos/Arquivos/Intel537EP/intel-537EP_secure-2.60.80.0/coredrv'
    rm -f *.ko *.o *~ core
    make[1]: Leaving directory `/home/kurumin/Meus Documentos/Arquivos/Intel537EP/intel-537EP_secure-2.60.80.0/coredrv'
    rm -f *.o *.ko
    Module precompile check
    Current running kernel is: 2.6.11-kanotix-7
    /lib/modules... autoconf.h exists
    diff: /boot/vmlinuz.autoconf.h: Arquivo ou diretório não encontrado
    autoconf.h matches running kernel
    diff: /boot/vmlinuz.version.h: Arquivo ou diretório não encontrado
    version.h matches running kernel
    2.6.11-kanotix-7
    make[1]: Entering directory `/home/kurumin/Meus Documentos/Arquivos/Intel537EP/intel-537EP_secure-2.60.80.0/coredrv'
    make -C /lib/modules/2.6.11-kanotix-7/build SUBDIRS=/home/kurumin/Meus Documentos/Arquivos/Intel537EP/intel-537EP_secure-2.60.80.0/coredrv modules
    make[2]: Entering directory `/usr/src/kernel-headers-2.6.11-kanotix-7'
    make[2]: *** Sem regra para processar o alvo `Documentos/Arquivos/Intel537EP/intel-537EP_secure-2.60.80.0/coredrv'. Pare.
    make[2]: Leaving directory `/usr/src/kernel-headers-2.6.11-kanotix-7'
    make[1]: ** [537core_26] Erro 2
    make[1]: Leaving directory `/home/kurumin/Meus Documentos/Arquivos/Intel537EP/intel-537EP_secure-2.60.80.0/coredrv'
    2.6.11-kanotix-7
    Failed to build driver
    rm -f /etc/hamregistry.bin
    bash 537_inst
    running kernel 2.6.11-kanotix-7
    installing hamregistry, used for persistant storage
    installing usrsound, a soft buzzer
    installing 537 module
    install: impossível fazer stat em `Intel537.ko': Arquivo ou diretório não encontrado
    make: ** [install] Erro 1
    ln: `/etc/rc5.d/S9999modem-intel': Arquivo já existente
    root@kurumin:/home/kurumin/Meus Documentos/Arquivos/Intel537EP#


    Obrigado.
    MarcoNascimento

  4. #9
    wsf
    olá,
    tenho o mesmo problema com o modem Intel 537EP, exatamente igual ao do colega MarcoNascimento

    por isso me ingressei no forum, e peço que me ajudem a configurar esse modem, pois estou começando no mundo linux agora também.

    wsf









Tópicos Similares

  1. LILO após instalação de win 98
    Por duker no fórum Servidores de Rede
    Respostas: 2
    Último Post: 20-08-2004, 06:43
  2. instalação de programas no linux
    Por rodrigonascimento no fórum Redes
    Respostas: 1
    Último Post: 01-05-2004, 12:32
  3. Instalação de Impressora no modo texto
    Por cassioat no fórum Servidores de Rede
    Respostas: 2
    Último Post: 12-01-2004, 21:09
  4. Instalação de qmail no redhat 8.0
    Por no fórum Servidores de Rede
    Respostas: 1
    Último Post: 26-06-2003, 04:55
  5. Instalação de Programas no Linux
    Por Policena no fórum Servidores de Rede
    Respostas: 4
    Último Post: 09-09-2002, 16:25

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L