+ Responder ao Tópico



  1. #1
    miqueias
    Visitante

    Padrão Preciso de ajuda no Squid........não esta compartilhando....

    Pessoal estou com problemas em colocar um servidor squid no ar. No conectiva 10
    As duas placas de rede estão configuradas corretamente
    eth0 (acesso a internet wan) 192.168.0.100
    eth1 (acesso a rede interna lan) 192.168.0.101

    segue abaixo a configuração dos arquivos necessarios.......

    /etc/sysconfig/network
    NETWORKING=yes
    # FORWARD_IPV4=no # not used anymore. see /etc/sysctl.conf
    HOSTNAME="miqueias.decco"
    GETWAY=192.168.0.101
    GETWAYDEV=eth1

    /etc/sysctl.conf
    # If active, enablles IPv4 packet forwarding
    net.ipv4.ip_forward = 1

    /etc/firewall (permissão de execução)
    #!/bin/bash

    #faz o redirecionamento para o squid
    iptables -t nat -A PREROUTING -i eth0 -p tcp --dport 80 -j REDIRECT --to-port 3128
    iptables -t nat -A POSTROUTING -o ppp0 -j MASQUERADE
    echo 1 > /proc/sys/net/ipv4/ip_forward
    echo "internet up"

    /etc/rc.d/rc.local
    sh /etc/firewall

    /etc/squid/squid.conf
    #>>>>>>>>>>>>>>>>>>>>>configureções basicas
    http_port 3128
    cache_mem 32 MB
    maximum_object_size 16000 KB
    cache_dir ufs /var/cache/squid 1000 16 256
    cache_access_log /var/log/squid/access.log
    cache_log /var/log/squid/cache.log
    cache_store_log /var/log/squid/store.log
    emulate_httpd_log on


    #>>>>>>>>>>>>proxy transparente
    httpd_accel_host virtual
    httpd_accel_port 80
    httpd_accel_with_proxy on
    httpd_accel_uses_host_header on

    #>>>>>>>>>>>> ACL GERAIS
    acl all src 0.0.0.0/0.0.0.0
    acl manager proto cache_object
    acl localhost src 127.0.0.1/255.255.255.255
    acl to_localhost dst 127.0.0.0/8
    acl SSL_ports port 443 563
    acl Safe_ports port 80
    acl Safe_ports port 21
    acl Safe_ports port 443 563
    acl Safe_ports port 210
    acl Safe_ports port 280
    acl Safe_ports port 591
    acl Safe_ports port 777
    acl Safe_ports port 1025-65535
    acl micro arp 000:09:F0:0A:06
    acl CONNECT method CONNECT

    #>>>>>>>>>>>>Diretivas http_access
    http_access allow manager localhost
    http_access deny manager
    http_access deny !Safe_ports
    http_access deny CONNECT !SSL_ports
    http_access allow micro
    http_access deny all

    Pessoal não estou conseguindo acessar na maquina cliente
    É necessario rotear alguma coisa no servidor da placa de rede eth1 para a eth0?
    Percebam que estou usando o acl arp (MAC ADDRESS) e na instalação foi compilado para tal serviço
    Agradeço pela ajuda
    Miqueias

  2. #2
    max_mori
    Visitante

    Padrão Preciso de ajuda no Squid........não esta compartilhando....

    $iptables -t nat -A POSTROUTING -o $internet -j MASQUERADE


    mais a liberação da porta para o squid para rede local



  3. #3

    Padrão Preciso de ajuda no Squid........não esta compartilhando....

    Estas linhas do proxy transparentes devem ser as ultimas linhas do arquivo squid.conf

    #>>>>>>>>>>>>proxy transparente
    httpd_accel_host virtual
    httpd_accel_port 80
    httpd_accel_with_proxy on
    httpd_accel_uses_host_header on

  4. #4
    frugoni
    Visitante

    Padrão Preciso de ajuda no Squid........não esta compartilhando....

    nao sei se to enganado mas ta meio estranho esses ips na msm faixa nao?



  5. #5
    Visitante

    Padrão Preciso de ajuda no Squid........não esta compartilhando....

    é...eu tb num sei se eu to errado...mas se o kmarada ae copio e colo a configuração...acho q essas linhas ake taum meio erradas:

    GETWAY=192.168.0.101
    GETWAYDEV=eth1


  6. #6
    miqueias
    Visitante

    Padrão Preciso de ajuda no Squid........não esta compartilhando....

    Citação Postado originalmente por Anonymous
    é...eu tb num sei se eu to errado...mas se o kmarada ae copio e colo a configuração...acho q essas linhas ake taum meio erradas:

    GETWAY=192.168.0.101
    GETWAYDEV=eth1

    Amigo me explique o que está errado.? Por favor ?
    esse conteudo esta no arquivo network, indicando que o eth1 com ip 192.168.0.101 e o gatway, se estiver errado, qual é o correto?



  7. #7
    miqueias
    Visitante

    Padrão Preciso de ajuda no Squid........não esta compartilhando....

    Citação Postado originalmente por max_mori
    $iptables -t nat -A POSTROUTING -o $internet -j MASQUERADE


    mais a liberação da porta para o squid para rede local
    Amigo na acl Safe_ports port 1025-65535, já não indica a liberação da porta 3128 do squid ?

  8. #8
    miqueias
    Visitante

    Padrão Preciso de ajuda no Squid........não esta compartilhando....

    Citação Postado originalmente por frugoni
    nao sei se to enganado mas ta meio estranho esses ips na msm faixa nao?
    essas são as configurações das placas de redes ---eth0 (192.168.0.100) recebendo conexão de ip dinamico speedy (200.......) e eth1 (192.168.0.101) enciando e recebendo pacotes para a rede interna lan
    Essas placas precisavam ser configuradas não é ?
    Miqueias



  9. #9

    Padrão Preciso de ajuda no Squid........não esta compartilhando....

    ó mano...

    refaça as configurações de uma das interfaces ....
    pois seu servidor está roteando sua rede para ela mesma ...

    tente outra faixa de ips...

    geralmente eu uso uma subrede com apena dois ip ´s na devicxe de wan

    ex:

    eth1 10.130.0.1 /30 roteador 10.130.0.2/30 ( device de rede para rede externa WAN )

    eth0 192.168.0.254 /24 ( gateway da rede interna LAN )

    não sei se estou errado mais no seu squid.conf
    não estaria faltando a acl redelocal src ?

    qual quer coisa posta ai....
    falow....................................

    ai fica mais simples ...

  10. #10
    Moderador Avatar de Bruno
    Ingresso
    Nov 2002
    Localização
    Guarapuava-PR
    Posts
    3.925
    Posts de Blog
    1

    Padrão Preciso de ajuda no Squid........não esta compartilhando....

    é vdd rootmaster naum pode ter a mesma rage de ip em interface diferentes sobre a acl ele tem sim e ta fazendo por ARP