+ Responder ao Tópico



  1. #1
    cag
    Visitante

    Padrão Problema estranho com ncsa_auth.

    Bom Dia,

    Estou utilizando a última versão do squid com autenticação ncsa_auth.

    Está funcionando normalmente a autenticação mas quando eu deleto um usuário do arquivo (htacess) o mesmo funciona normalmente.

    Ou seja, quando eu apago um usuário o mesmo consegue navegar normalmente.

    Realmente é estranho isso, mas quando eu reinicio o squid (service squid restart) volta ao normal e o usuário que eu deletei não consegue navegar.

    Não sei se existe algum parametro para não acontecer isso, porque é complicado toda vez reiniciar o squid após excluir o usuário.

    Tentei (squid -k reconfigure, service squid reload) mas mesmo assim o usuário navega.
    Só volta ao normal quando reinicia.

    Estou colocando dessa maneira a autenticação:

    Código :
    auth_param basic program /usr/lib/squid/ncsa_auth /home/httpd/users
    auth_param basic children 5
    auth_param basic realm Intranet
    auth_param basic credentialsttl 2 hours

    Obs: Antes quando eu utilizava a autenticação com pam_auth não acontecia este problema.

    valeu

  2. #2

    Padrão Re: Problema estranho com ncsa_auth.

    O squid tem que ler novamente o arquivo users e comparar com os usuarios criado no sistema pra verificar que realmente o usuario foi deletado, normal isso !!!


    Valeu !!!



  3. #3
    cag
    Visitante

    Padrão Problema estranho com ncsa_auth.

    Complicado ...
    Para reiniciar o squid leva um tempo...
    Toda vez que apagar um usuário toda rede fica parada um certo tempo.

  4. #4
    fabiolima
    Visitante

    Padrão Problema estranho com ncsa_auth.

    realmente comigo eu uso autenticação no active directory do window server 2003 e quando quero negar um acesso a internet após a alteração preciso reiniciar o squid pra ele ler os arqwuivos novamente o estranho é que o seu squid demorar pra reiniciar aki ele é bem rápido, vc usa algum script pra iniciar ou reiniciar o squid???



  5. #5
    cag
    Visitante

    Padrão Problema estranho com ncsa_auth.

    utilizo o script do init.d (service squid restart).
    Leva +- 30 segundos para reiniciar.

  6. #6

    Padrão squid

    Usa
    #service squid reload
    Assim ele apenas relê os arquivos de configuração.



  7. #7
    cag
    Visitante

    Padrão Problema estranho com ncsa_auth.

    acho que você não leu o primeiro post hehe...
    Com reload os usuários continuam navegando.

    Só volta ao normal reiniciando.

  8. #8

    Padrão squid

    Desculpe foi mal, mas tenho clientes utilizando dessa forma, fiz um menu pra eles adiconarem e remover os usuários e com o reload funciona, para de naegar sim.
    mas foi mal........



  9. #9
    fabiolima
    Visitante

    Padrão Problema estranho com ncsa_auth.

    cara posta seu script do init.d pra gente dar uma olhada
    quem sabe tem alguma coisa a mais, sei lá se vc puder posta ai

    falou

  10. #10
    cag
    Visitante

    Padrão Problema estranho com ncsa_auth.

    para adicionar usuários funciona, até para adicionar palavras proibidas etc... (squid -k reconfigure) ou reload.

    Mas na hora que exclui é o problema...
    Antes autenticando com o módulo PAM funcionava na boa.
    Agora com htpasswd só reiniciando o squid.

    Faz alguns testes, cadastra 3 usuários depois digite "htpasswd arquivo -D primeirousuario"

    Depois abre o navegador, vai continuar navegando na boa...

    Mas se reiniciar, dai sim não navega mais.



  11. #11
    Luzumba
    Visitante

    Padrão Problema estranho com ncsa_auth.

    qual a versão do teu squid ?
    ja verificou se existe algum bug nessa versão ?
    ou algo referente a isso ?
    Não deveria acontecer isso, afinal imagina se vc. tivesse 50000 usuarios em cima ?
    e tivesse que administrar varias contas, tipo apagar alterar, etc ?
    pode ser até algum pid persistente, daqueles que nau,m querem ir embora...
    ou quem sabe o arquivo esta sendo usado por outro processo ou programa ?
    qqr. duvida contate !

  12. #12
    cag
    Visitante

    Padrão Problema estranho com ncsa_auth.

    é exatamento isso que está acontecendo...
    Não é 5000 usuários, mas é 70.

    Reiniciar o squid cada vez que excluir um usuário é complicado.

    Olha é a última versão do squid, atualizei agora mesmo.

    Se alguém quiser fazer alguns testes...
    É só cadastrar alguns usuários, depois excluir.

    Abre o navegador que o mesmo continua navegando na boa.

    Depois reinicia o squid que volta ao normal.



  13. #13
    fabiolima
    Visitante

    Padrão Problema estranho com ncsa_auth.

    é verdade meu squid é a ultima versão tb, e só funciona depois de reiniciar o server

  14. #14

    Padrão Problema estranho com ncsa_auth.

    Aparentemente é uma falha do squid.
    Testei aqui na maquina reserva e realmente o usuário continua usando.

    mas eu defini que quem não fizer parte dos grupos não tem acesso, então não preciso nem tirar do passwd, só do grupo.

    http_access deny all

    Talvez isso resolva.

    :good:



  15. #15

    Padrão Problema estranho com ncsa_auth.

    Você está retirando o usuário do grupo de acesso, ou só o nome do htpasswd? Tem que tirar os dois... retestei aqui e o usuário caiu.

    [ ]´s


    :good:

  16. #16
    cag
    Visitante

    Padrão Problema estranho com ncsa_auth.

    por usuário, eu só coloco por grupo os administradores.
    valeu



  17. #17

    Padrão Problema estranho com ncsa_auth.

    kill -HUP squid

    Depois de 30 segundos ele volta a funcionar !!

  18. #18
    cag
    Visitante

    Padrão Problema estranho com ncsa_auth.

    o problema que 30 segundos é muito tempo.

    Vai ficar 30 segundos 70 micros parado, e o tempo todo precisa de internet...

    O Sistema não funciona sem internet.



  19. #19

    Padrão Problema estranho com ncsa_auth.

    Ah eo que queria dizer era killall squid. Como uso pacotes tarball, o squid tem o script chamdo RunCache que inicia o suid caso ele seja "stopado"

    Bom ... eu não conheço outra forma sem reiniciar !

    Se alguem conhece, por favor poste !!

  20. #20

    Padrão Problema estranho com ncsa_auth.

    Estranho , eu quando faço alguma manutenção nos usuários do squid, eu excluo, altero, etc, etc. Depois executo um ps -aux | grep squid. Aí vejo o número do processo , e executo um kill -HUP número_do_processo. É rápido a execução desse comando. Não sei se é esse o seu caso.
    Um grande abraço ........ :good: