+ Responder ao Tópico



  1. #1
    fpmazzi
    Visitante

    Padrão Sera que estou certo?

    Pessoal, a algum tempo venho percebendo uma certa mensagem no meu servidor de internet, oq ocorre é o seguinte:

    O meu servidor vem rodando certinho, de repente oq acontece, a net para ou seja nao consigo acessar nada, somente o MSN continua no ar, ae tento entar no servidor usando SSH (putty) e ele nao me da acesso, oq faço vou no servidor localmente e ao liberar a tela vejo a seguinte mensagem:

    end_request I/O error, dev 03:03 (hda), sector 46688
    end_request I/O error, dev 03:03 (hda), sector 1208
    end_request I/O error, dev 03:03 (hda), sector 46688
    end_request I/O error, dev 03:02 (hda), sector 46688


    uma em seguida da outra, se tento entar em outra tty, usando ctrl+alt+Fn, ele ta normal, digito o nome do usuario e ja começa a aparecer os erros novamente.


    Isto seria um erro de Hardware? HD com pane?

  2. #2
    Avatar de thiagoacsp
    Ingresso
    Oct 2005
    Localização
    São Bernardo do Campo, Brazil, Brazil
    Posts
    231

    Padrão Sera que estou certo?

    creio que possa ser ja tento passar o fsck.extn no HD e tb marcar os badbloks com fsck.ext3 -c -C -v -y /dev/...
    Blz mas da uma pesquisada na net nao estou muito certo mas eh um caminho.



  3. #3
    fpmazzi
    Visitante

    Padrão Sera que estou certo?

    passei um fsck.ext3 /dev/hda e aparecew isto, oq pode ser, tentei ler, mas como sou pessimo de ingles, mas ja to procurando um bom curso, nao entendi alguem pode me ajudar?



    [[email protected] root]# fsck.ext3 -c /dev/hda4
    e2fsck 1.32 (09-Nov-2002)
    /dev/hda4 is mounted.

    WARNING!!! Running e2fsck on a mounted filesystem may cause
    SEVERE filesystem damage.

    Do you really want to continue (y/n)? yes

    Couldn't find ext2 superblock, trying backup blocks...
    fsck.ext3: Bad magic number in super-block while trying to open /dev/hda4

    The superblock could not be read or does not describe a correct ext2
    filesystem. If the device is valid and it really contains an ext2
    filesystem (and not swap or ufs or something else), then the superblock
    is corrupt, and you might try running e2fsck with an alternate superblock:
    e2fsck -b 8193 <device>

    [[email protected] root]#

  4. #4

    Padrão Re: Sera que estou certo?

    Citação Postado originalmente por fpmazzi

    Isto seria um erro de Hardware? HD com pane?
    Amigão acredito que sejao HD, aconteceu algo parecido em setembro do ano passado e era realmente o HD.

    Se sua máquina for DELL, vá no site deles e baixe um utilitário par testar a máquina.

    Outra coisa, pode ser a temperatura também.

    Flw !



  5. #5
    fpmazzi
    Visitante

    Padrão Sera que estou certo?

    ola amigo, nao pode ser temperatura, pq to com um p-100 com 64 Mem. de RAM, a makina esta aberta e cooler funcionando normalmente, e se ja dew pra ver nao eh um del ... alguem tem alguma iedia ... mais comncreta?!

  6. #6
    luiz_iniciante
    Visitante

    Padrão Sera que estou certo?

    Cara o melhor a fazer é troca o HD mesmo.



  7. #7

    Padrão Sera que estou certo?

    soh pra completar, NUNCA passe o fsck com teu disco montado, vc pode danificar tudo, qdo for fazer fsck manualmente remonte o disco como (ro).
    E geralmente erro de I/O nao eh pau do filesystem nao, eh badblock ou qq outro erro fisico msm

  8. #8

    Padrão Sera que estou certo?

    Amigo, eh lamentavel, participar de um forum onde os participantes ao inves de ajudarem, so pioram mais a situacao...pq q o cara vem aki so falr besteira...
    Mermao, o q esta aocntecendo no seu servidor eh pura e simplesmente a morte do seu HD....corre, faz um back up antes q ele morra de vez....ja passei por isso diversas vezes....memso sintoma...daki ha algum tempo vc nao terra mais acesso via ssh, vera uma serie de erros na tela e caso a makina reboot....ela nao mas ira voltar.....
    Amigao...TROCA O HD E PONTO FINAL...

    DEPOIS Q VC TORCAR O HD...LEVANTA ELE EM OUTRA MAKINA E DA UM
    fsck -y / pra ver se salva alguma coisa

    abracos

    Citação Postado originalmente por fpmazzi
    ola amigo, nao pode ser temperatura, pq to com um p-100 com 64 Mem. de RAM, a makina esta aberta e cooler funcionando normalmente, e se ja dew pra ver nao eh um del ... alguem tem alguma iedia ... mais comncreta?!



  9. #9

    Padrão Sera que estou certo?

    Foda foi o bonito ali em cima ter mandado um usuário obviamente leigo nesse assunto rodar "fsck" em um disco sem nem sugerir a remontagem somente para leitura do mesmo :P

    fpmazii, vou traduzir, em 2 linguas, só um pedaço pra você:
    "WARNING!!! Running e2fsck on a mounted filesystem may cause SEVERE filesystem damage. "
    = "AVISO!!! Rodar o e2fsck em um sistema de arquivos montado pode causar danos SEVEROS ao sistema de arquivos"
    = "Se rodar esssa porra num sistema de arquivos montado pode dar merda, e das grandes :P ops, yes? se fudeu!"

    Então, antes que tudo piore, faz backup do que "restou" e troca de HD o mais urgente possivel.

  10. #10
    bonny
    Visitante

    Padrão Sera que estou certo?

    ja aconteceu comigo varias vezes isso, nao so com HD mas com cd-rom tambem, seu hd foi pro caralho, compra outro.



  11. #11

    Padrão Sera que estou certo?

    Tive problemas semelhantes, as menságens eram as mesmas. Resolvi o problema trocando o cabo flat do HD.
    Faz teste.

  12. #12
    fpmazzi
    Visitante

    Padrão Re: Sera que estou certo?

    Legal, moçada, como disseram, me tirem duas duvidas:
    1ª- Estamos falando de erro fisico, faz aproximadamente dois meses que postei a primeira mensagem, e o mesmo problema nao ocorrew, sera HD mesmo?
    Pergunto isso, pois pelo pouco que sei, se fosse erro fisico do HD era pra ser continuo nao?

    2ª- tenho neste sistema apenas um HD, alguem pode me passar um tutorial ou algo assim, pra me ensina como passa esse fsck certinho pra nao da problemas?!