+ Responder ao Tópico



  1. #1

    Padrão Squid dando raiva

    Pessoal, tenho um servidor slackware 9.1 que estava rodando o squid perfeitamente há 2 meses, nunca tive problemas nenhum com ele.

    Acontece que desde segunda ele começou a dar uns problemas.
    Todo dia por volta do meio dia algumas páginas ficam inacessíveis, no inicio da manhã tudo funciona, dai o problema começa, dura até meia tarde e volta tudo ao normal novamente, alguém sabe o que pode ser?


    Configurei um novo IP pra máquina, única coisa que foi feita de novo depois da implantação deste servidor.
    ifconfig eth1 10.1.1.100
    ifconfig eth1:0 192.168.100.100

    Foram os comandos que usei para dar ip pra máquina.

    Alguém tem idéia do que pode estar ocasionando isso?

    Pensei em cache, mas creio que não deveria dar erro por ter cache cheio, deveria atualizar o cache automaticamente. correto?

  2. #2



  3. #3
    therek
    Visitante

    Padrão Squid dando raiva

    Realmente estranho...
    A página de erro é uma página gerada pelo squid?
    Se a resposta for sim, qual a mensagem?
    *timeout?
    *dns failure?
    etc...

    Passe mais detalhes...

    t+

  4. #4

    Padrão Squid dando raiva

    Eu agora não estou nesta rede, na verdade é em outra cidade, mas o erro que ocorre é de dns failure.

    O q pode ser?



  5. #5
    vul4
    Visitante

    Padrão Squid dando raiva

    Vc ja testou o link? Navegar nateando ao inves do proxy? Assim vc pode isolar o problema, facilitando a solução.

  6. #6
    therek
    Visitante

    Padrão Squid dando raiva

    seu problema eh no dns...
    o squid tentou acessar a página solicitada mas não conseguiu resolver o nome do host.

    inclua mais servidores dns's na linha do squid.conf

    dns_nameservers xxx.xxx.xxx.xxx xxx.xxx.xxx.xxx

    e tambem no resolv.conf

    deve resolver o problema...



  7. #7

    Padrão Squid dando raiva

    Citação Postado originalmente por therek
    seu problema eh no dns...
    o squid tentou acessar a página solicitada mas não conseguiu resolver o nome do host.

    inclua mais servidores dns's na linha do squid.conf

    dns_nameservers xxx.xxx.xxx.xxx xxx.xxx.xxx.xxx

    e tambem no resolv.conf

    deve resolver o problema...
    mas o estranho é que o erro acontece somene em alguns periodos do dia, ñ é um erro frequente, mas que atrapalha bastante.


    No iniicio do dia td funciona, depois do meio dia para, e reiniciando o servidor fica normal la pelo meio da tarde.