+ Responder ao Tópico



  1. #1
    slackrio
    Visitante

    Padrão erro ao instalar o postfix ..

    Galera to tendo uma dor de cabeça pra instalar o postfix , uso o slack 10.1 tenho as bibliotecas gcc instaladas e atualizadas..
    da este erro no make

    gcc -Wmissing-prototypes -Wformat -DHAS_MYSQL -I/usr/include/mysql -DHAS_PCRE -g -O -I. -I../../include -DLINUX2 -o master master.o master_conf.o master_ent.o master_sig.o master_avail.o master_spawn.o master_service.o master_status.o master_listen.o master_vars.o master_wakeup.o master_flow.o ../../lib/libglobal.a ../../lib/libutil.a /usr/lib/mysql -lmysqlclient -lz -lm -L/usr/lib -L/usr/lib -lpcre -ldb -lnsl -lresolv
    /usr/lib/mysql: file not recognized: Is a directory
    collect2: ld returned 1 exit status
    make: *** [master] Error 1
    make: *** [update] Error 1


    aqui esta as minhas libs ..
    [email protected]:/opt/postfix-2.2.3# slackpkg search gcc

    The list below shows all packages with the selected pattern.

    [uninstalled] - x11-6.8.1-i486-4
    [ installed ] - aaa_elflibs-10.1.0-i486-1
    [uninstalled] - zsh-4.2.1-i486-1
    [ installed ] - gcc-3.3.4-i486-1
    [ installed ] - gcc-g++-3.3.4-i486-1
    [ installed ] - gcc-g77-3.3.4-i486-1
    [ installed ] - gcc-gnat-3.3.4-i486-2
    [ installed ] - gcc-java-3.3.4-i486-1
    [ installed ] - gcc-objc-3.3.4-i486-1
    [ installed ] - kernel-source-2.4.29-noarch-1
    [uninstalled] - kdevelop-3.1.2-i486-1
    [uninstalled] - qt-3.3.3-i486-3
    [ installed ] - jre-1_5_0_01-i586-1
    [uninstalled] - x11-6.8.1-i486-3
    [uninstalled] - x11-docs-html-6.8.1-noarch-2
    [uninstalled] - j2sdk-1_5_0_01-i586-1


    o que vcs acham o deve ser ??


    grato!

  2. #2
    Under-linux.Org Team Avatar de MarcusMaciel
    Ingresso
    Dec 2000
    Localização
    Boston
    Posts
    1.970
    Posts de Blog
    44

    Padrão Re: erro ao instalar o postfix ..

    como voce gerou o makefile ???
    passe a linha de comando ai



  3. #3
    slackrio
    Visitante

    Padrão Re: erro ao instalar o postfix ..

    desta forma

    make -f Makefile.init makefiles 'CCARGS=-DHAS_MYSQL -I/usr/include/mysql -DUSE_SASL_AUTH -I/usr/include/sasl' 'AUXLIBS=/usr/lib/libmysqlclient.so -lm -L/usr/lib -lsasl2'


    eu fui neste site para o processo de instalação
    http://slackware.sites.uol.com.br/postfix.htm

    valew

  4. #4

    Padrão Re: erro ao instalar o postfix ..

    Olá, ...

    Pelo o que eu entendi desse erro, é que é um erro de MySQL, tente reinstalar o mysql, e todas as suas bibliotecas.

    BOA SORTE!!!!!



  5. #5
    Under-linux.Org Team Avatar de MarcusMaciel
    Ingresso
    Dec 2000
    Localização
    Boston
    Posts
    1.970
    Posts de Blog
    44

    Padrão Re: erro ao instalar o postfix ..

    amigo tente assim
    Código :
    % make makefiles 'CCARGS=-DHAS_MYSQL -I/usr/include/mysql \
    'AUXLIBS=-L/usr/lib/mysql -lmysqlclient -lz -lm -L/usr/lib '
     
    % make; make install;


  6. #6
    slackrio
    Visitante

    Padrão Re: erro ao instalar o postfix ..

    coloquei da forma que vc me passou e nao ta indo !! fica somente este simbolo no prompt >

    to com mysqld 4 sera isso algum problema ??




  7. #7
    Under-linux.Org Team Avatar de MarcusMaciel
    Ingresso
    Dec 2000
    Localização
    Boston
    Posts
    1.970
    Posts de Blog
    44

    Padrão Re: erro ao instalar o postfix ..

    Acho que o mysql 4 nao é o problema...

    Estranho eu usei exatamente essa linha para compilar o meu...


  8. #8

    Padrão Re: erro ao instalar o postfix ..

    # tar -xvzf postfix-2.1.11.tar.gz -C /opt/

    # cd /opt/postfix-2.1.1/

    # make -f Makefile.init makefiles 'CCARGS=-DHAS_MYSQL -I/usr/include/mysql -DUSE_SASL_AUTH -I/usr/include/sasl' 'AUXLIBS=/usr/lib/libmysqlclient.so -lm -L/usr/lib -lsasl2'

    # make

    # make upgrade

    Depois de tudo isso postconf -m pra se o mysql foi habilitado !!!

    Valeu !!!