+ Responder ao Tópico



  1. #1
    juniox
    Visitante

    Padrão bloquear anexos

    seguinte, não tenho muita experiência com servidor de email... mas preciso bloquear anexos .exe, .pif., .bat, etc...
    o servidor instalado é exim4 (no debian)

    alguém sabe como fazer isso?

  2. #2
    Under-linux.Org Team Avatar de MarcusMaciel
    Ingresso
    Dec 2000
    Localização
    Boston
    Posts
    1.970
    Posts de Blog
    44

    Padrão Re: bloquear anexos

    voce usa qual delivery para as mensagens ?? procmail ? maildrop ?



  3. #3
    etherlink
    Visitante

    Padrão Re: bloquear anexos

    vc poderia da uma olhada nesta pagina onde conta anti-virus que bloqueia qualquer coisa que vc queria
    http://www.goffredo.eti.br/anti-virus/

  4. #4
    juniox
    Visitante

    Padrão Re: bloquear anexos

    estou usando o procmail



  5. #5
    Under-linux.Org Team Avatar de MarcusMaciel
    Ingresso
    Dec 2000
    Localização
    Boston
    Posts
    1.970
    Posts de Blog
    44

    Padrão Re: bloquear anexos

    Voce pode colocar no seu /etc/procmailrc

    Código :
    PMDIR=/var/mail/FILTER
    LOGFILE=$PMDIR/log
     
    :0B $PMDIR/.msgid.lck
    * name=".*\.(scr|pif|bat)| +\.exe|.*\.cmd"
     
     $PMDIR/filter-scr-pif-exe

    Lembre-se de criar o diretorio /var/mail/FILTER

  6. #6
    juniox
    Visitante

    Padrão Re: bloquear anexos

    adicionei isso no /etc/procmailrc, criei o diretório ... mas não funciona.. o anexo continua passando...

    creio que instalando um antivírus resolva, não?

    tentei o amavis aqui (amavis é mesmo antivírus? e o clamav?)

    apt-get install amavisd-new

    mas.. como fazer pra "sincronizar" o amavis com o exim4 ?

    desculpa a falta de conhecimento... mas nunca mexi com email entes
    :-(



  7. #7
    juniox
    Visitante

    Padrão Re: bloquear anexos

    instalei o mailscanner + clamav
    mas o bloqueio de arquivos.exe e .bat ainda não está funcionando

    :-(

  8. #8
    Under-linux.Org Team Avatar de MarcusMaciel
    Ingresso
    Dec 2000
    Localização
    Boston
    Posts
    1.970
    Posts de Blog
    44

    Padrão Re: bloquear anexos

    provavelmente voce tera que configurar nele o bloqueio para esses arquivos..


    mais ai a minha regra de procmail deveria funcionar eu estou usando ela sem problemas.

    []´s



  9. #9
    juniox
    Visitante

    Padrão Re: bloquear anexos

    então cara...
    desculpa minha insistência nisso... mas é que realmente eu nunca mexi com servidor de email e estou usando esse server há 1 semana...
    fui checar o que o administrador dela instalou... e lá constava

    #apt-get install exim4 exim4-base exim4-config exim4-daemon-heavy
    #apt-get install qpopper
    #apt-get install uw-imapd
    #apt-get install procmail
    #apt-get install spamassassin


    isso é tudo que eu sei até agora...
    olha como está o /etc/procmailrc

    # Location of the SquirrelMail user data files
    SQDATA=/var/lib/squirrelmail/data/

    # Location of the user's SM Trash file ($HOME represents the user's home dir)
    SQTRASH=$HOME/INBOX.Trash

    # Full, absolute path of the test utility on the system
    TESTPATH=/usr/bin/test

    # Full, absolute path of the formail utility on the system
    FORMAILPATH=/usr/bin/formail

    # Full, absolute path of the grep utility on the system
    GREPPATH=/bin/grep

    # Full, absolute path of the sed utility on the system
    SEDPATH=/bin/sed

    # DO NOT MODIFY ANYTHING BELOW UNLESS YOU (REALLY) KNOW WHAT YOU'RE DOING!
    SHELL=/bin/sh
    BLOCKLIST=$LOGNAME.block

    :0
    * ? $TESTPATH -f $SQDATA/$BLOCKLIST
    {
    # Get the sender's email address
    :0h
    SENDER=|$FORMAILPATH -IReply-To: -rtzxTo:
    # Grab the domain from the sender
    DOMAIN=\*@`echo $SENDER|sed s/^.*@//`
    :0
    * 1^0 ? $GREPPATH $SENDER $SQDATA/$BLOCKLIST
    * 1^0 ? $GREPPATH $DOMAIN $SQDATA/$BLOCKLIST
    {
    DROPPRIVS=yes
    :0:
    $SQTRASH
    }
    }

    :0:
    *^X-Spam-Flag:.*YES
    $HOME/INBOX.Spam

    :0:
    *^Subject:.*.
    $HOME/INBOX

    # --- BLOQUEAR ANEXOS ---------

    PMDIR=/var/mail/FILTER
    LOGFILE=$PMDIR/log

    :0B $PMDIR/.msgid.lck
    * name=".*\.(scr|pif|bat)| +\.exe|.*\.cmd"
    $PMDIR/filter-src-pif-exe
    pode ajudar?

  10. #10
    Under-linux.Org Team Avatar de MarcusMaciel
    Ingresso
    Dec 2000
    Localização
    Boston
    Posts
    1.970
    Posts de Blog
    44

    Padrão Re: bloquear anexos

    Coloque assim seu procmailrc e faca um teste...


    Código :
    # Location of the SquirrelMail user data files
    SQDATA=/var/lib/squirrelmail/data/
     
    # Location of the user's SM Trash file ($HOME represents the user's home dir)
    SQTRASH=$HOME/INBOX.Trash
     
    # Full, absolute path of the test utility on the system
    TESTPATH=/usr/bin/test
     
    # Full, absolute path of the formail utility on the system
    FORMAILPATH=/usr/bin/formail
     
    # Full, absolute path of the grep utility on the system
    GREPPATH=/bin/grep
     
    # Full, absolute path of the sed utility on the system
    SEDPATH=/bin/sed
     
    # DO NOT MODIFY ANYTHING BELOW UNLESS YOU (REALLY) KNOW WHAT YOU'RE DOING!
    SHELL=/bin/sh
    BLOCKLIST=$LOGNAME.block
     
    # --- BLOQUEAR ANEXOS ---------
    :0
    * ^Content-Type:.*multipart/mixed;
    {
       :0 B
       * ^Content-Transfer-Encoding: base64
       * ^Content-Disposition: attachment;
       * ^.*filename=".*\.(pif|scr|bat|exe|com)"
       /dev/null
    }
     
    :0
    * ? $TESTPATH -f $SQDATA/$BLOCKLIST
    {
     # Get the sender's email address
     :0h
     SENDER=|$FORMAILPATH -IReply-To: -rtzxTo:
     # Grab the domain from the sender
     DOMAIN=\*@`echo $SENDER|sed s/^.*@//`
     :0
     * 1^0 ? $GREPPATH $SENDER $SQDATA/$BLOCKLIST
     * 1^0 ? $GREPPATH $DOMAIN $SQDATA/$BLOCKLIST
     {
      DROPPRIVS=yes
      :0:
      $SQTRASH
     }
    }
     
    :0:
    *^X-Spam-Flag:.*YES
    $HOME/INBOX.Spam
     
    :0:
    *^Subject:.*.
    $HOME/INBOX



  11. #11
    juniox
    Visitante

    Padrão Re: bloquear anexos

    valeu cara!
    funcionou!!
    :-D
    acabou meu horário aqui... depois vou analisar os códigos pra entender (tentar) o motivo de não estar funcionando antes

    valeu!!

  12. #12
    juniox
    Visitante

    Padrão Re: bloquear anexos

    desse jeito a mensagem não chega para o destinatário...

    tem como fazer a mensagem chegar SEM o anexo?
    ao invés de bloquear tudo...



  13. #13
    Under-linux.Org Team Avatar de MarcusMaciel
    Ingresso
    Dec 2000
    Localização
    Boston
    Posts
    1.970
    Posts de Blog
    44

    Padrão Re: bloquear anexos

    ai foge ao meu nivel de conhecimento mais acredito que o GOOGLE tenha a reposta

  14. #14

    Padrão Re: bloquear anexos

    Ai pessoal boa noite ...tambem tô com essa bromca ...não estou conseguindo
    bloquear anexos ...

    estou usando o postfix + uw-imap

    alguem pode me dar uma luz ...

    valew ...



  15. #15

    Padrão Re: bloquear anexos

    Citação Postado originalmente por rootmaster
    Ai pessoal boa noite ...tambem tô com essa bromca ...não estou conseguindo
    bloquear anexos ...

    estou usando o postfix + uw-imap

    alguem pode me dar uma luz ...

    valew ...
    olá consegui com expressões regulares ....

    valew ...

  16. #16
    juniox
    Visitante

    Padrão Re: bloquear anexos

    eu achei o seguinte script:

    ##########################################################
    # Solução 1. Bloqueia qualquer anexo suspeito.
    # - crie o diretorio $DIR;
    # - crie o /etc/virus.msg com a msg de aviso.
    # coloque em /etc/procmailrc

    # Diretorio onde as msg bloqueadas serão guardadas
    DIR="/var/spool/procmail"

    # Protecao contra alguns virus
    :0 B
    * filename=.+\....\.(pif|com|exe|bat|lnk|scr|vbs)
    {
    # Cria um copia carbono, que eh passada ao formail.
    # O formail gera cabecalhos de reply, que concatenado
    # com o /etc/virus.msg, gera uma mensagem que é passada
    # ao agente SMTP, no caso o sendmail.
    #
    # O parametro -i permite trocar o remetente. No caso, estou
    # trocando para "antivirus". Senão a msg de retorno iria
    # com o endereco da vitima (digo, quase vitima...).
    :0 c
    |(formail -r -i"From:antivirus" -A"X-Loop: antivirus";\
    cat /etc/virus.msg)|$SENDMAIL -oi -t

    # Utilizando lockfile, para evitar que mais de um
    # processo mexa no arquivo ao mesmo tempo (recomendavel)

    :0: ${DIR}/${LOGNAME}.lock
    ${DIR}/${LOGNAME}.virus
    }
    # fim
    ##########################################################
    mas não funfou aqui no exim
    :cry:



  17. #17
    juniox
    Visitante

    Padrão Re: bloquear anexos

    ae, dei uma modificada no código e agora está funcionando, parcialmente

    :0 B
    * ^Content-Transfer-Encoding: base64
    * ^Content-Disposition: attachment;
    * ^.*filename=".*\.(pif|com|exe|bat|scr|vbs)"
    e

    :0 c
    |(formail -r -i"From:antivirus" -A"X-Loop: antivirus";\
    cat /etc/virus.msg)|$SENDMAIL -oi -t)
    (a única coisa que fiz aqui foi fechar o parêntese no final, estava aberto e por isso não funcionava) :-P

    PORÉM, ele retorna a mensagem para o remetente original como "Mail Delivery System" e não como "antivirus" como eu digitei acima...

    li o manual do procmail, adicionei outro parâmetros... -t -k, mudei outros parâmetros... mas mesmo assim.. não consegui mudar isso...

    outra coisa..., eu queria que na resposta (-r) ele colasse o conteúdo da mensagem original... e não só a mensagem que estou enviando (/etc/virus.msg)

    alguém pode ajudar?

  18. #18
    juniox
    Visitante

    Padrão Re: bloquear anexos

    ae, eu mesmo respondendo porque já vi muitas dúvidas parecidas na net...

    então, o que eu queria sobre mudar o remetente.. ficando [email protected] eu consegui mudando a linha do formail, deixando-a assim:

    | (formail -r ; cat /etc/virus.msg) | $SENDMAIL -oi -t -f antivirus
    :-D

    prontinho, basta alterar o -f NOME e pronto.

    na verdade... o que eu quero é manter a mensagem original na hora de responder... adicionando o conteúdo do /etc/virus.msg... mas do jeito que tá.. ele só manda o conteúdo do arquivo...

    outra coisa, mandar um email pra pessoa que iria receber o arquivo, avisando que não a mensagem não pôde ser entregue

    do jeito que tá.. só o remetente vai receber a resposta... o destinatário nem ficará sabendo de nada... :S

    mas enfim, quem puder ajudar...