+ Responder ao Tópico



  1. #1

    Padrão Personalizando erro 404 apache 1.3

    galera to com duas situação aki a primeira é que ja tenho um servidor web em produção e então to querendo personalizar o Erro 404, ja descomentei no httpd.conf e setei para o meu diretório e nada, ja utilizei o htaccess e tbem nada, sempre retorna o seguinte erro.
    Invalid error redirection directive: error404.php.
    A outra coisa que gostaria de fazer é recompilar o meu apache para uma versão mais nova com suporte a myql+php4+mod_proxy

    Fica ae se alguem puder me ajudar agradeceria.

  2. #2

    Padrão Re: Personalizando erro 404 apache 1.3

    Bom o que eu recomendo a você é dá uma olhada na documentção do apache: http://httpd.apache.org/docs/2.2/install.html
    Tem dois pacotes extras que devem ser instalados antes do de instalar o apache 2.0.

    Aqui tem dizendo como instalar o php 4 com suporte a myqsl: http://www.php.net/manual/pt_BR/install.unix.php

    Quanto ao mod_proxy, você pode compilar ele junto com o apache:
    #./configure --enable-proxy
    ou colocá-lo como módulo:
    #./configure --enable-so --enable-proxy=shared
    O módulo so é requerido para este processo.

    Quanto ao problema do 404, ainda naõ sei te responder. :|

    Ab. :-)



  3. #3

    Padrão Re: Personalizando erro 404 apache 1.3

    se alguem puder dar uma forcinha ae agradeço

  4. #4

    Padrão Re: Personalizando erro 404 apache 1.3

    e ae galera deem um help-me ae vai



  5. #5

    Padrão Re: Personalizando erro 404 apache 1.3

    no /etc/apache/

    edita o httpd.conf

    encontra

    ErrorDocument 404

    e coloca

    ErrorDocument 404 /erro.html

    entendeu ... ou seja o erro.html precisa estar na pasta root do seu apache

    abraço.

  6. #6

    Padrão Re: Personalizando erro 404 apache 1.3

    foi o que eu fiz de primeiro mas ele retorna este erro no log que vc viu em cima.