Página 2 de 3 PrimeiroPrimeiro 123 ÚltimoÚltimo
+ Responder ao Tópico



  1. #6
    slackrio
    Com este firewall que vc me passou foi blz recebeu os e-mail e entrou ate no FTP de fora ..
    so tem um problema , matei o processo do squid (stop) e mesmo assim as estações continuam navegando
    pra testar eu tirei o proxy do internet explorer e ele navegou ..

    como tinha esta linha
    $IPT -t nat -A PREROUTING -p tcp --dport 80 -i eth1 -s 10.11.20.0/255.255.255.0 -j REDIRECT --to-port 3128

    achei que ele so navegaria com o squid rodando ..


  2. #7
    slackrio
    cara fiz desta forma e agora esta funcionado o e-mail
    mudei so a arrumação do jeito em que eu possa entender melhor


    note que mudei esta linha

    iptables -t nat -A PREROUTING -p tcp --dport 80 -i eth1 -s 0/0 -j REDIRECT --to-port 3128


    estava assim
    $IPT -t nat -A PREROUTING -p tcp --dport 80 -i eth1 -s 10.11.20.0/255.255.255.0 -j REDIRECT --to-port 3128



    #################################################################
    #!/bin/bash
    # Script de Firewall

    # Modulos
    /sbin/modprobe ipt_MASQUERADE
    /sbin/modprobe ip_nat_ftp
    /sbin/modprobe ip_conntrack
    /sbin/modprobe iptable_filter
    /sbin/modprobe iptable_mangle
    /sbin/modprobe iptable_nat
    /sbin/modprobe ipt_LOG
    /sbin/modprobe ipt_limit
    /sbin/modprobe ipt_state


    # Limpando as Regras
    iptables -F
    iptables -t nat -F

    iptables -A INPUT -j ACCEPT
    iptables -A FORWARD -j ACCEPT
    iptables -A OUTPUT -j ACCEPT

    iptables -t nat -A POSTROUTING -o eth0 -j MASQUERADE
    iptables -A FORWARD -m state --state ESTABLISHED,RELATED -j ACCEPT

    # ativar o mascaramento (nat).
    iptables -t nat -A POSTROUTING -d 0/0 -j MASQUERADE
    iptables -t nat -A PREROUTING -p tcp --dport 80 -i eth1 -s 0/0 -j REDIRECT --to-port 3128




    agora ta funcionando somente nao loga em servidores FTP rss e meu amigo e uma luta isso mais vc me ajudou MUUITTO ..



  3. #8
    slackrio
    OPAAAA funcionou o ftp tanto em Smartftp quanto no INternet explorer ...
    cara tirei o proxy do smartftp e ele foi ,
    bom pelo o que entendi e que o ftp nao vai pelo o squid , o squid e somente http!!
    me fale se eu estiver errado

  4. HUMMMMMMMMMMMM, Olha só. O squid é so para requisições da porta 80. Num adianta jogar porta 20 e 21 e nem mesmo a 443 que é https. Nesse caso seu msn não conecta se voc colocar a 443 também pra redirecionar.

    Squid é so porta 80 pra porta dele.

    Tenta ai,

    Tire se voc tiver regras de redirecionar a porta do ftp

    FUI !!!!!!1



  5. #10
    slackrio
    na conf do squid ta assim as acls

    acl all src 0.0.0.0/0.0.0.0
    acl manager proto cache_object
    acl localhost src 127.0.0.1/255.255.255.255
    acl SSL_ports port 443 563
    acl Safe_ports port 80 # http
    acl Safe_ports port 21 # ftp
    acl Safe_ports port 443 563 # https, snews
    acl Safe_ports port 70 # gopher
    acl Safe_ports port 210 # wais
    acl Safe_ports port 1025-65535 # unregistered ports
    acl Safe_ports port 280 # http-mgmt
    acl Safe_ports port 488 # gss-http
    acl Safe_ports port 591 # filemaker
    acl Safe_ports port 777 # multiling http
    acl Safe_ports port 901 # SWAT
    acl purge method PURGE
    acl CONNECT method CONNECT

    nota que aqui tem o acl Safe_ports port 443 563 # https, snews e mesmo assim o msn ta logando blz e o ftp tb loga
    nota tb que ate a porta 21 ta tem acl na conf.. so tem um detalhe
    quando eu tiro o proxy do Internet Explorer .. o ftp o outlook funcionam normalmente so mesmo o IE que nao navega claro por ser na porta 80 de navegação ...

    bom ate ai ta legal assim , mais seria interessante que quando o squid nao estiver rodando ou ate mesmo o IE nao estiver com o proxy nada funciona-se na net .. msn,e-mail,ftp etc .. seria bom ate mesmo por o Administrador ter total poder sobre a rede pq ser Adm Linux e isso e poder mandar no server para o bem da empressa ..

    sabe de alguma dica ?

    eu to achando que pode ser nesta linha que tem no firewall que vc me mandou
    iptables -t nat -A POSTROUTING -o eth0 -j MASQUERADE

    lembrando que eu uso

    ETH0=sem ip onde esta ligado ao modem adsl em modo bridge
    ETH1=rede interna (192.168.0.1)
    PPP0=adsl-start (velox)
    e tb tenho o DHCP dando ip para as estações.







Tópicos Similares

  1. Squid Não fazer FTP Anônimo
    Por andkaiser no fórum Servidores de Rede
    Respostas: 9
    Último Post: 10-03-2007, 09:21
  2. -squid: não libera alguns sites
    Por marcosvargasmt no fórum Servidores de Rede
    Respostas: 3
    Último Post: 21-10-2006, 11:30
  3. SQUID não acessa FTP
    Por Sirius® no fórum Servidores de Rede
    Respostas: 3
    Último Post: 23-02-2005, 10:52
  4. acl no squid não está funcionando. O que fazer ?
    Por no fórum Servidores de Rede
    Respostas: 3
    Último Post: 20-12-2002, 16:01
  5. Respostas: 3
    Último Post: 25-11-2002, 18:22

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L