+ Responder ao Tópico



  1. #1
    eduardoalbano
    Visitante

    Padrão Squid nao inicia

    Oi Pessoal,

    Estou com um problema no meu squid, quando tento startar ele aparece a seguinte mensagem:

    /etc/init.d/squid: line 129: log_daemon_msg: command not found
    * Creating squid spool directory structure
    2006/05/03 09:02:53| Creating Swap Directories
    ...done.


    Ja tentei usar o apt-get para atualiza-lo e nao adianta nada.. continua o mesmo erro. Estava funcionando normalmente e "do nada" parou. Alguem tem uma luz???


    Abraços,

    Eduardo.

  2. #2

    Padrão Re: Squid nao inicia

    Amigo, faça

    squid -z

    ele vai criar o swap.
    Talvez seu problema seja permissão das pastas.

    http://www.vivaolinux.com.br/artigos...hp?codigo=2020

    Veja as permissões aqui e faça o squid -z


    FUI !!!



  3. #3
    eduardoalbano
    Visitante

    Padrão Re: Squid nao inicia

    Amigo,

    Foi otima sua ajuda. Só que continua com o mesmo problema.

    Olha o que aparece no cache.log:

    2006/05/03 11:38:48| Starting Squid Cache version 2.5.STABLE13 for i386-debian-linux-gnu...
    2006/05/03 11:38:48| Process ID 15940
    2006/05/03 11:38:48| With 1024 file descriptors available
    2006/05/03 11:38:48| DNS Socket created at 0.0.0.0, port 32794, FD 6
    2006/05/03 11:38:48| Adding nameserver 10.17.1.34 from /etc/resol2006/05/03 11:38:48| commBind: Cannot bind socket FD 9 to *:3128: (98) Address already in use
    FATAL: Cannot open HTTP Port
    Squid Cache (Version 2.5.STABLE13): Terminated abnormally.
    CPU Usage: 0.028 seconds = 0.018 user + 0.010 sys
    Maximum Resident Size: 0 KB
    Page faults with physical i/o: 0
    Memory usage for squid via mallinfo():
    total space in arena: 2624 KB
    Ordinary blocks: 2495 KB 2 blks
    Small blocks: 0 KB 1 blks
    Holding blocks: 204 KB 1 blks
    Free Small blocks: 0 KB
    Free Ordinary blocks: 128 KB
    Total in use: 2699 KB 103%
    Total free: 128 KB 5%

    Agradeço mais uma vez a ajuda,


    Eduardo.


  4. #4

    Padrão Re: Squid nao inicia

    Tem certeza que não tem outro Squid rodando na máquina? Talvez um processo bobo que não morreu... um firewall que esteja bloqueando a porta 3128?


    Abraços!



  5. #5
    eduardoalbano
    Visitante

    Padrão Re: Squid nao inicia


    Esta tudo liberado. Tenho certeza que nao tem outro processo qdo dou stop e start no serviço olha o que acontece:

    fwmportos:~# /etc/init.d/squid stop
    /etc/init.d/squid: line 137: log_daemon_msg: command not found
    ...done.
    fwmportos:~# /etc/init.d/squid start
    /etc/init.d/squid: line 129: log_daemon_msg: command not found
    * Creating squid spool directory structure
    2006/05/03 12:34:58| Creating Swap Directories
    ...done.


    Olha o que ja fiz:

    chmod 777 /var/spool/squid
    chmod 777 /var/cache/squid
    squid -z


    To começando a ficar louco.
    Antes disso fiz backup de todos meus arquivos de instalação e reinstalei tudo. Ele chegou a startar e o serviço terminou inesperavelmente. E voltou a dar a msm mensagem de erro.

    sera que tem algum arquivo de eu tenha que zerar ou limpar que eu esteja esquecendo?

    []´s

    Eduardo.

  6. #6
    sermutante
    Visitante

    Padrão Re: Squid nao inicia

    Eduardo

    Posto o teu squid.conf prá darmos uma olhada......



  7. #7
    eduardoalbano
    Visitante

    Padrão Re: Squid nao inicia

    hierarchy_stoplist cgi-bin ?
    acl QUERY urlpath_regex cgi-bin \?
    no_cache deny QUERY
    hosts_file /etc/hosts
    refresh_pattern ^ftp: 1440 20% 10080
    refresh_pattern ^gopher: 1440 0% 1440
    refresh_pattern . 0 20% 4320
    acl all src 0.0.0.0/0.0.0.0
    no_cache deny all
    visible_hostname fwmportos
    acl manager proto cache_object
    acl localhost src 127.0.0.1/255.255.255.255
    acl to_localhost dst 127.0.0.0/8
    acl SSL_ports port 443 563 # https, snews
    acl SSL_ports port 873 # rsync
    acl Safe_ports port 80 # http
    acl Safe_ports port 21 # ftp
    acl Safe_ports port 443 563 # https, snews
    acl Safe_ports port 70 # gopher
    acl Safe_ports port 210 # wais
    acl Safe_ports port 1025-65535 # unregistered ports
    acl Safe_ports port 280 # http-mgmt
    acl Safe_ports port 488 # gss-http
    acl Safe_ports port 591 # filemaker
    acl Safe_ports port 777 # multiling http
    acl Safe_ports port 631 # cups
    acl Safe_ports port 873 # rsync
    acl Safe_ports port 901 # SWAT
    acl purge method PURGE
    acl CONNECT method CONNECT

    ## Seta Regras

    #### Define Rede Local #####

    acl rede_local src 10.17.1.0/24

    #### Libera MSN #####

    acl libera_msn src "/etc/squid/acls/libera_msn.txt"

    #### VIP ####

    acl vip src "/etc/squid/acls/vip.txt"

    ##### Sites bloqueados #####

    acl blockedsites url_regex -i "/etc/squid/acls/block.txt"
    # Esse arquivo irá conter os sites bloqueados, pode ser preenchido apenas parte do nome do site
    # Ex: uol => esta palavra dentro do arquivo vai bloquear todos os sites que tenham a palavra uol na URL
    acl unblockedsites url_regex -i "/etc/squid/acls/unblock.txt"
    # Esse arquivo vai conter as excessões da regra acima

    ##### Messenger ######

    # acl deny_group src "/etc/squid/acls/block_msn.txt"
    # Esse arquivo irá conter os ips dos clientes da sua rede que nao poderam
    # ter acesso ao MSN (linha por linha os IPs);

    # acl allow_group src "/etc/squid/acls/allow_msn.txt"
    # Essa arquivo irá conter os ips dos clientes da sua rede que poderam ter
    # acesso ao MSN (linha por linha os IPs);

    acl serv_msn dst "/etc/squid/acls/redes_msn.txt"
    # Bloqueando a rede do Messenger MSN.

    acl instant_messenger url_regex -i "/etc/squid/acls/instant_messenger.txt"

    acl app_msn rep_mime_type -i ^application/x-msn-messenger$
    # bloquear qualquer dado que contenha o Mime padrão do MSN.

    acl msn port 1863
    # Porta do MSN

    ##### Aplica as regras #####

    #### Libera acesso ao msn#####

    http_access allow libera_msn !blockedsites

    #### Libera acesso total####
    http_access allow vip

    ##### Messenger #####
    #http_access allow allow_group serv_msn
    #http_access allow allow_group msn
    #http_access allow allow_group instant_messenger
    #http_access allow allow_group app_msn
    http_access deny all serv_msn
    http_access deny all msn

    http_access deny all instant_messenger !unblockedsites
    http_access deny all app_msn

    ##### Sites Bloqueados #####

    http_access deny blockedsites !unblockedsites

    ##### Libera acesso para o resto da rede #####
    http_access allow rede_local

    http_access allow manager localhost
    http_access deny manager
    http_access allow purge localhost
    http_access deny purge
    http_access deny !Safe_ports
    http_access deny CONNECT !SSL_ports
    http_access allow localhost
    http_access deny all
    http_reply_access allow all
    icp_access allow all
    coredump_dir /var/spool/squid

    cache_mem 300 MB
    cache_swap_low 98
    cache_swap_high 96
    maximum_object_size 4096 KB
    cache_dir null /tmp

  8. #8

    Padrão Re: Squid nao inicia

    Cara, faz assim. Faz um bkp do seu squid.conf

    e se vc criou arquivos para bloquear palavras, sites, sei la mais o q.

    faz um removepkg squid e depois instala novamente e faz do zero a config dele. Claro.

    Joga o squid.conf no /etc/squid e roda o squid -z

    mas antes de rodar o squid -z cria os diretorios e da a permissao.
    Uma coisa que eu faço eh usar o usuario daemon no squid.

    Ve ai, é a melhor coisa. Mas após remover os arquivos faça ainda

    locate squid.conf
    locate squid
    e delete tudo que achar dele

    Nada melhor que limpar realmente e fazer do zero pra encontrar algum erro anteriormente não encontrado.

    Fui !!!



  9. #9
    Wendelsoares
    Visitante

    Padrão Re: Squid nao inicia

    Cara...

    Vc não tem que setar a porta http no seu squid.conf?

  10. #10
    eduardoalbano
    Visitante

    Padrão Re: Squid nao inicia

    galera,
    zerei tudo e funcionou.

    valeu pelas dicas!

    abraços,

    Eduardo.



  11. #11

    Padrão Re: Squid nao inicia

    Citação Postado originalmente por eduardoalbano
    galera,
    zerei tudo e funcionou.

    valeu pelas dicas!

    abraços,

    Eduardo.
    cara uma outra dica é sempre analizar os logs ...( /var/log/messages e etc ....)


    valew ...

    que bom que funcionou ...