+ Responder ao Tópico



  1. #1

    Padrão Tem que ter um luz no fim do tunel

    Pessoal, estou desesperado, aqui na empresa este erro está acontecendo constantemente, me ajudem.

    The requested URL could not be retrieved

    --------------------------------------------------------------------------------

    While trying to retrieve the URL: https://under-linux.org

    The following error was encountered:

    Unable to determine IP address from host name for www5.thecrims.com
    The dnsserver returned:

    No DNS records
    This means that:

    The cache was not able to resolve the hostname presented in the URL.
    Check if the address is correct.
    Your cache administrator is [email protected].



    --------------------------------------------------------------------------------

    Generated Thu, 25 May 2006 14:54:52 GMT by proxy.number.com.br (squid/2.5.STABLE9)

    Me ajudem a encontrar uma solução, este erro ocore sempre quando o meu browser está com o proxy do squid, eu tirando o proxy, não dá mais o erro. Mas tenho que usar o proxy, para poder coletar o relatório no Sarg.

    Me ajudem por favor.

    ABraços

  2. #2

    Padrão Re: Tem que ter um luz no fim do tunel

    issu em qq estação ou em alguma em particular?ou pior ainda...no server..?



  3. #3

    Padrão Re: Tem que ter um luz no fim do tunel

    Qualquer estação, no server, tudo, se tiver pelo proxy ja era, tirando o proxy fica uma magavilha.

    Não aguento mais esse problema tem que ter solução.

    Já falaram para eu limpar o cache, já fiz e nada.

    ME ajudem, valeu

  4. #4

    Padrão Re: Tem que ter um luz no fim do tunel

    mew... seu dominio é number.com.br?isso sempre acontece pelo jeito para qq site que vc digita né?bem o qq vc jah viu nos arquivos de configuração do squid?jah olhou o acces.log no momento que vc tenta acessar algum site?



  5. #5

    Padrão Re: Tem que ter um luz no fim do tunel

    Quer que eu poste o meu squid aqui para vc ver? Vc acha que pode ser o iptable? quer que poste ele tb?

    Valeu fera

  6. #6

    Padrão Re: Tem que ter um luz no fim do tunel

    véi...manda aew....se eu puder ajudar...eu ajudo...se eu naun puder,vou conversar um o meu consultor...



  7. #7

    Padrão Re: Tem que ter um luz no fim do tunel

    iptables;

    #Mude de acordo com sua rede os ips..
    #Start Serv
    #Escript de Firewall e Roteamento de portas
    #==========================================================================================================================
    #Apaga Regras pre Definidas
    iptables -F
    iptables -t nat -F
    #==========================================================================================================================
    #APAGANDO REGRAS
    iptables -F INPUT
    iptables -F FORWARD
    iptables -F OUTPUT
    iptables -X
    iptables -A INPUT -i lo -j ACCEPT
    iptables -A FORWARD -i lo -j ACCEPT
    iptables -A OUTPUT -o lo -j ACCEPT
    #==========================================================================================================================
    #adicionando modulos
    modprobe ip_conntrack
    modprobe ipt_MASQUERADE
    modprobe ipt_LOG
    modprobe iptable_nat
    modprobe ip_nat_ftp
    modprobe iptable_filter
    #==========================================================================================================================
    #Abilita o Roteamento de Kernel
    echo 1 > /proc/sys/net/ipv4/ip_forward
    #==========================================================================================================================
    #Abilita (NAT) Para converter ip 192.168.0.0 para 200.201.158.110
    iptables -t nat -A POSTROUTING -s 192.168.0.10/24 -o eth0 -j SNAT --to 200.201.158.110
    #==========================================================================================================================
    #Redireciona Todas as portas para a 8080 (http) (Squid) / OUTLOOK
    #iptables -t nat -A PREROUTING -i eth0 -p tcp --dport 80 -j REDIRECT --to 8080
    iptables -t nat -A PREROUTING -d 192.168.0.10/24 -i eth0 -p tcp -m tcp --dport 25 -j DNAT --to-destination 200.187.64.134
    iptables -t nat -A PREROUTING -d 192.168.0.10/24 -i eth0 -p tcp -m tcp --dport 110 -j DNAT --to-destination 200.187.64.133
    iptables -t nat -A POSTROUTING -s 192.168.0.0/24 -o eth0 -j MASQUERADE
    iptables -t nat -A POSTROUTING -s 192.168.0.0/24 -o eth1 -j MASQUERADE
    #==========================================================================================================================
    #-------------------- CONTROLA TODAS AS INPUT NO SERVIDOR ---------------------
    #Libera as portas para entrada no servidor
    iptables -A INPUT -p tcp -s 192.168.0.0/24 --dport 53 -j ACCEPT
    iptables -A INPUT -p udp -s 192.168.0.0/24 --dport 53 -j ACCEPT
    iptables -A INPUT -p tcp -s 192.168.0.0/24 --dport 3128 -j ACCEPT
    iptables -A INPUT -p tcp -s 192.168.0.0/24 --dport 25 -j ACCEPT
    iptables -A INPUT -p tcp -s 192.168.0.0/24 --dport 110 -j ACCEPT
    iptables -A INPUT -p tcp -s 192.168.0.0/24 --dport 137:139 -j ACCEPT
    iptables -A INPUT -p udp -s 192.168.0.0/24 --dport 137:139 -j ACCEPT
    iptables -A INPUT -p tcp -s 192.168.0.0/24 --dport 1080 -j ACCEPT
    iptables -A INPUT -p tcp -s 192.168.0.0/24 --dport 9875 -j ACCEPT
    #iptables -A INPUT -p tcp -s 200.218.208.91 --dport 5024 -j ACCEPT
    #iptables -A INPUT -p tcp -s 200.218.209.91 --dport 5024 -j ACCEPT
    #iptables -A INPUT -p tcp -s 192.168.0.0/24 --dport 80 -j ACCEPT
    #==========================================================================================================================
    #Mantem a conexao das portas liberada acima
    iptables -A INPUT -m state --state ESTABLISHED,RELATED -j ACCEPT
    #==========================================================================================================================
    #--------------------- CONTROLA TODOS OS FORWARD NO SERVIDOR ------------------
    #libera as portas para passar pelo servidor e ter acesso externo
    iptables -A FORWARD -s 192.168.0.0/24 -i eth0 -j ACCEPT
    iptables -A FORWARD -p tcp -s 192.168.0.0/24 --dport 53 -j ACCEPT
    iptables -A FORWARD -p udp -s 192.168.0.0/24 --dport 53 -j ACCEPT
    iptables -A FORWARD -p tcp -s 192.168.0.0/24 --dport 25 -j ACCEPT
    iptables -A FORWARD -p tcp -s 192.168.0.0/24 --dport 110 -j ACCEPT
    iptables -A FORWARD -p tcp -s 192.168.0.0/24 --dport 1080 -j ACCEPT
    iptables -A FORWARD -p tcp -s 192.168.0.0/24 --dport 9875 -j ACCEPT
    #iptables -A FORWARD -p tcp -s 192.168.0.0/24 --dport 5024 -j ACCEPT
    #iptables -A FORWARD -p tcp -s 192.168.0.0/24 --dport 80 -j ACCEPT
    #==========================================================================================================================
    #Mantem a conexao das portas acima liberada
    iptables -A FORWARD -m state --state ESTABLISHED,RELATED -j ACCEPT
    #
    #
    iptables -A OUTPUT -p tcp -s 192.168.0.0/24 --dport 53 -j ACCEPT
    iptables -A OUTPUT -p udp -s 192.168.0.0/24 --dport 53 -j ACCEPT
    iptables -A OUTPUT -p tcp -s 192.168.0.0/24 --dport 25 -j ACCEPT
    iptables -A OUTPUT -p tcp -s 192.168.0.0/24 --dport 110 -j ACCEPT
    iptables -A OUTPUT -p tcp -s 192.168.0.0/24 --dport 9875 -j ACCEPT
    iptables -A OUTPUT -p tcp -s 192.168.0.0/24 --dport 5024 -j ACCEPT
    #iptables -A OUTPUT -p tcp -s 200.218.208.91 --dport 5024 -j ACCEPT
    #iptables -A OUTPUT -p tcp -s 200.218.209.91 --dport 5024 -j ACCEPT
    #
    iptables -A OUTPUT -m state --state ESTABLISHED,RELATED -j ACCEPT


    ================================================================
    squid

    http_port 3128
    icp_port 0
    cache_mem 128 MB
    cache_swap_low 95
    cache_swap_high 98
    maximum_object_size 4096 KB
    cache_dir ufs /var/spool/squid 800 32 32
    cache_access_log /var/log/squid/access.log
    cache_log /var/log/squid/cache.log
    cache_store_log none
    #emulate_httpd_log off
    connect_timeout 2 minutes
    acl all src 192.168.0.0/255.255.255.0
    acl manager proto cache_object
    acl localhost src 127.0.0.1/255.255.255.255
    acl SSL_ports port 443 563
    acl Safe_ports port 80 # http
    acl Safe_ports port 1080 # Socks
    acl Safe_ports port 86 # Speedy
    acl Safe_ports port 21 # ftp
    acl Safe_ports port 443 563 # https, snews
    acl Safe_ports port 70 # gopher
    acl Safe_ports port 210 #wais
    acl Safe_ports port 1025-65535 #unregistered ports
    acl Safe_ports port 280 # http-mgmt
    acl Safe_ports port 488 # gss-http
    acl Safe_ports port 591 # filemaker
    acl Safe_ports port 777 # multilink http
    acl CONNECT method CONNECT
    #acl porn url_regex "/etc/squid/porn"
    #acl noporn url_regex "/etc/squid/noporn"
    #http_access allow noporn all
    #http_access deny porn all
    http_access allow manager localhost
    http_access deny manager
    http_access deny !Safe_ports
    http_access deny CONNECT !SSL_ports
    icp_access allow all
    miss_access allow all
    cache_mgr [email protected]
    cache_effective_user squid
    cache_effective_group squid
    visible_hostname proxy.number.com.br
    #store_avg_object_size 4 KB
    httpd_accel_host virtual
    httpd_accel_port 3128
    httpd_accel_with_proxy on
    httpd_accel_uses_host_header on






    ==============================================================
    Cache.log

    2006/05/25 13:54:35 ipcacheparse: no address records in response to 'www.buscape.com.br'


    VAleu cara

  8. #8

    Padrão Re: Tem que ter um luz no fim do tunel

    Dá uma olhadinha no seu arquivo /etc/resolv.conf e veja se os endereços dos seus servidores DNS estão lá. Senão, baixe as suas regras de firewall e habilite apenas o NAT para ver se o problema é no Squid.



  9. #9

    Padrão Re: Tem que ter um luz no fim do tunel

    Estão lá sim, os dois.

    Eu ja fiz tudo que me falaram, quero mais ideias.

    Obrigado galera pela ajuda, e que continuem me ajudando. hehehehe....

  10. #10

    Padrão Re: Tem que ter um luz no fim do tunel

    Antelo, esse Squid já funcionou algum dia?
    Quando parou?

    Tente comentar essa linha:
    #httpd_accel_port 3128

    ou tente mudar para a porta 80


    Tag Name
    httpd_accel_port

    Usage
    httpd_accel_port port

    Description

    Accelerated requests can only be forwarded to one port: there is no table that associates accelerated hosts and a destination port. Squid will connect to the port that you set the httpd_accel_port value to. When acting as a front-end for a web server on the local machine, you will set up the web server to listen for connections on a different port (8000, for example), and set this squid.conf option to match the same value. If, on the other hand, you are forwarding requests to a set of slow backend servers, they will almost certainly be listening to port 80 (the default web-server port), and this option will need to be set to 80. If you want virtual port support then specify the port as "0"

    Default
    none

    Example
    httpd_accel_port 80
    httpd_accel_port 8000

    Caution
    -



    De uma olhada nessa tag tambem....


    Tag Name
    httpd_accel_with_proxy

    Usage
    httpd_accel_with_proxy on|off

    Description

    If you use the httpd_accel_host option, Squid will stop recognizing cache requests. So that your cache can function both as an accelerator and as a web cache, you will need to set the httpd_accel_with_proxy option to on.

    Default
    See Description.

    Example
    -

    Caution
    -


    Post seu squid-error.log , squid-access.log


    Podem ajudar.



  11. #11

    Padrão Re: Tem que ter um luz no fim do tunel

    Acredito que vc não está fazendo proxy transparente, pois não tem nenhuma regra de REDIRECT no seu firewall, nem tão pouco uma regra de DROP, comente essas seguintes linhas do squid, elas só servem quando vc está fazendo proxy transparente
    httpd_accel_host virtual
    httpd_accel_port 3128
    httpd_accel_with_proxy on
    httpd_accel_uses_host_header on

    O squid utiliza os DNS configurados no resolv.conf ( se vc nõa declaro eles no squid.conf na opção dns_nameservers ), então tenta a partir do servidor resolver alguns dominios, com ping mesmo.
    # ping www.uol.com.br
    # ping www.internic.net
    Se não resolver o problema está nos DNS do servidores, verifique com seu provedor de acesso dais são os DNS corretos ou instala um BIND com cache e aponta seu resolv.conf para o 127.0.0.1
    Abraços.

  12. #12
    Waclawiak
    Visitante

    Padrão Re: Tem que ter um luz no fim do tunel

    Pois é amigo, acho que o josiel é quem está mais perto da razão, porém vc disse que quando vc retira o proxy tudo funfa bem, então ai teoricamente descartamos a possibilidade de o seu servidor não estar conseguindo resolver os nomes, isso se o seu servidor estiver rodando rodando bind.

    Pontos que vc deve verificar.

    Caso vc não rode o bind no seu server:
    Dispare o seguinte comando no servidor: host www.google.com.br
    Se ele não resolver temos um problema de dns no server.
    Compare os endereços de dns que vc distrubui para as estações através do dhcp com os endereços dns que estão no seu resolv.conf, caso estejam diferentes utilize os que estão no dhcp, pois como vc disse sem o proxy eles funcionam.
    Teste novamente o primeiro comando.

    Caso vc rode o bind:
    Verifique no seu resolv.conf se a primeira referencia é: nameserver 127.0.0.1 , caso não seja coloque ele em primeiro, reinicialize o bind e o squid.
    Dispare o comando: host www.google.com.br , se ele não resolver verifique se o bind está rodando, em algumas distribuições da linha like redhat poder ser feito com o comando: service named status se vc utilizar outra distribuição você pode disparar o comando: ps xfa |grep named e ps xfa |grep bind esses dois verificam os processos existentes.
    Os logs do bind são direcionados para o arquivo /var/log/messages, dar um tail -F /var/log/messages e reiniciar o bind em outro terminal para ver os logs que ele está gerando.

    Tem outra coisa que vc deve fazer em ambos os casos que é liberar a porta 53 udp do seu server para a net, para ele poder fazer as pesquisas de DNS.

    Espero ter ajudado.
    Qualquer coisa [email protected]



  13. #13

    Padrão Re: Tem que ter um luz no fim do tunel

    Pessoal, agradeço a ajuda de todos, todas as dicas, todas as tentativas.

    Agora está funcionando, eu comentei as últimas linhas do meu squid.conf e troquei o meu dns.

    Até agora o problema não apareceu, espero que não apareça mais.

    Obrigado a todos pela ajuda, como sempre né.

    Abraços

  14. #14

    Padrão Re: Tem que ter um luz no fim do tunel

    Amigos,

    Eu não creio, sabem o que está acontecendo?

    Está em aparecendo outro erro agora, não com tanta intensidade, mas está aparecendo.


    ========================================================================

    ERROR
    The requested URL could not be retrieved

    --------------------------------------------------------------------------------

    While trying to retrieve the URL: http://oglobo.globo.com/online/pais/default.asp?

    The following error was encountered:

    Read Error
    The system returned:

    (104) Connection reset by peerAn error condition occurred while reading data from the network. Please retry your request.

    Your cache administrator is [email protected].



    --------------------------------------------------------------------------------

    Generated Tue, 30 May 2006 14:31:04 GMT by proxy.number.com.br (squid/2.5.STABLE9)

    ===================================================================

    NOssa, estou com alguma urucubaca, pessoal como resolvo isso agora.

    Valeu, feras



  15. #15

    Padrão Re: Tem que ter um luz no fim do tunel

    antelo,

    Carinha, isso já parece ser um erro de conexão, isso é retornado quando o seu servidor não conseguiu conectar a pagina destino.


    como está a utilização da sua banda?

    Não esqueça de postar o squid-error.log


    Abraços

  16. #16

    Padrão Re: Tem que ter um luz no fim do tunel

    é só neste site?os emails passam pela mesma conexão? pode ser conexão sobrecarregada..