Página 3 de 4 PrimeiroPrimeiro 1234 ÚltimoÚltimo
+ Responder ao Tópico



  1. Acredito que vc não está fazendo proxy transparente, pois não tem nenhuma regra de REDIRECT no seu firewall, nem tão pouco uma regra de DROP, comente essas seguintes linhas do squid, elas só servem quando vc está fazendo proxy transparente
    httpd_accel_host virtual
    httpd_accel_port 3128
    httpd_accel_with_proxy on
    httpd_accel_uses_host_header on

    O squid utiliza os DNS configurados no resolv.conf ( se vc nõa declaro eles no squid.conf na opção dns_nameservers ), então tenta a partir do servidor resolver alguns dominios, com ping mesmo.
    # ping www.uol.com.br
    # ping www.internic.net
    Se não resolver o problema está nos DNS do servidores, verifique com seu provedor de acesso dais são os DNS corretos ou instala um BIND com cache e aponta seu resolv.conf para o 127.0.0.1
    Abraços.

  2. #12
    Waclawiak
    Pois é amigo, acho que o josiel é quem está mais perto da razão, porém vc disse que quando vc retira o proxy tudo funfa bem, então ai teoricamente descartamos a possibilidade de o seu servidor não estar conseguindo resolver os nomes, isso se o seu servidor estiver rodando rodando bind.

    Pontos que vc deve verificar.

    Caso vc não rode o bind no seu server:
    Dispare o seguinte comando no servidor: host www.google.com.br
    Se ele não resolver temos um problema de dns no server.
    Compare os endereços de dns que vc distrubui para as estações através do dhcp com os endereços dns que estão no seu resolv.conf, caso estejam diferentes utilize os que estão no dhcp, pois como vc disse sem o proxy eles funcionam.
    Teste novamente o primeiro comando.

    Caso vc rode o bind:
    Verifique no seu resolv.conf se a primeira referencia é: nameserver 127.0.0.1 , caso não seja coloque ele em primeiro, reinicialize o bind e o squid.
    Dispare o comando: host www.google.com.br , se ele não resolver verifique se o bind está rodando, em algumas distribuições da linha like redhat poder ser feito com o comando: service named status se vc utilizar outra distribuição você pode disparar o comando: ps xfa |grep named e ps xfa |grep bind esses dois verificam os processos existentes.
    Os logs do bind são direcionados para o arquivo /var/log/messages, dar um tail -F /var/log/messages e reiniciar o bind em outro terminal para ver os logs que ele está gerando.

    Tem outra coisa que vc deve fazer em ambos os casos que é liberar a porta 53 udp do seu server para a net, para ele poder fazer as pesquisas de DNS.

    Espero ter ajudado.
    Qualquer coisa landrower@hotmail.com



  3. Pessoal, agradeço a ajuda de todos, todas as dicas, todas as tentativas.

    Agora está funcionando, eu comentei as últimas linhas do meu squid.conf e troquei o meu dns.

    Até agora o problema não apareceu, espero que não apareça mais.

    Obrigado a todos pela ajuda, como sempre né.

    Abraços

  4. Amigos,

    Eu não creio, sabem o que está acontecendo?

    Está em aparecendo outro erro agora, não com tanta intensidade, mas está aparecendo.


    ========================================================================

    ERROR
    The requested URL could not be retrieved

    --------------------------------------------------------------------------------

    While trying to retrieve the URL: http://oglobo.globo.com/online/pais/default.asp?

    The following error was encountered:

    Read Error
    The system returned:

    (104) Connection reset by peerAn error condition occurred while reading data from the network. Please retry your request.

    Your cache administrator is informatica@number.com.br.



    --------------------------------------------------------------------------------

    Generated Tue, 30 May 2006 14:31:04 GMT by proxy.number.com.br (squid/2.5.STABLE9)

    ===================================================================

    NOssa, estou com alguma urucubaca, pessoal como resolvo isso agora.

    Valeu, feras



  5. antelo,

    Carinha, isso já parece ser um erro de conexão, isso é retornado quando o seu servidor não conseguiu conectar a pagina destino.


    como está a utilização da sua banda?

    Não esqueça de postar o squid-error.log


    Abraços






Tópicos Similares

  1. Respostas: 12
    Último Post: 13-03-2017, 07:39
  2. uma Luz no fim do tunel - shaper - Debia 6.0
    Por accseixas no fórum Sistemas Operacionais
    Respostas: 4
    Último Post: 16-04-2012, 20:50
  3. Ajuda para um iniciante !(uma luz no fim do tunel)
    Por NetMikrotik no fórum Redes
    Respostas: 9
    Último Post: 22-12-2009, 22:28
  4. Respostas: 12
    Último Post: 19-08-2009, 19:56
  5. Barra no fim do endereço do site
    Por no fórum Servidores de Rede
    Respostas: 3
    Último Post: 02-05-2003, 21:57

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L