+ Responder ao Tópico



  1. #1
    luciano555
    Visitante

    Padrão script que nao roda no cron - ajudem por favor

    ola amigos, tenho um script e colocquei no cron para rodar, só que nao roda ja tentei várias opcoes e nao consequi fazer ele rodar, se puderem me ajudar desde já agradeço

    utilizo conectiva 10

    o script:

    /usr/bin/smbmount //servidor/c /mnt/servidor/ -o username=root,password=123
    cd /pastax
    /usr/bin/zip backup-diario.zip /mnt/servidor/BackupDiario/*.dat
    /usr/bin/smbumount /mnt/servidor
    /pastax/ftp-backup-diario.sh


    utilizando crontab -e ficou assim


    05 01 * * * root run-parts /etc/pastax/manda-backup.sh
    e no crontab utilizando o cron.daily ficou assim:


    # /etc/crontab: system-wide crontab

    SHELL=/bin/bash
    PATH=/sbin:/bin:/usr/sbin:/usr/bin
    MAILTO=root
    HOME=/

    # run-parts
    01 * * * * root run-parts /etc/cron.hourly
    10 09 * * * root run-parts /etc/cron.daily/fotos.sh
    30 23 * * * root run-parts /campestre/manda-backup.sh
    22 4 * * 0 root run-parts /etc/cron.weekly
    42 4 1 * * root run-parts /etc/cron.monthly

    mas não roda. agradeço as ajudas


  2. #2

    Padrão Re: script que nao roda no cron - ajudem por favor

    se vc executar manualmente funciona? jah checou os logs do cron?



  3. #3

    Padrão Re: script que nao roda no cron - ajudem por favor

    Saudações amigo luciano555,

    Quando vc usa o crontab -e ele edita o arquivo de cron do usuário que vc executou o comando. Nesse caso as linhas do cron não tem que conter o usuario, no seu caso vc colocou root

    05 01 * * * root run-parts /etc/pastax/manda-backup.sh

    Essa linha, basta que ela seja desta forma:

    05 01 * * * /etc/pastax/manda-backup.sh

    Esse seu script manda-backup.sh deve ter permissão de execução.
    Não precisa usar o cron-daily se este já funcionar.

    Teste e veja se funciona.
    Abraço

  4. #4
    luciano555
    Visitante

    Padrão Re: script que nao roda no cron - ajudem por favor

    Citação Postado originalmente por joseguilherme
    Saudações amigo luciano555,

    Quando vc usa o crontab -e ele edita o arquivo de cron do usuário que vc executou o comando. Nesse caso as linhas do cron não tem que conter o usuario, no seu caso vc colocou root

    05 01 * * * root run-parts /etc/pastax/manda-backup.sh

    Essa linha, basta que ela seja desta forma:

    05 01 * * * /etc/pastax/manda-backup.sh

    Esse seu script manda-backup.sh deve ter permissão de execução.
    Não precisa usar o cron-daily se este já funcionar.

    Teste e veja se funciona.
    Abraço
    ok joseguilherme fiz o que vc solicitou mas nao deu certo, nao sei o que esta aconetecento o meu crontab -e ficou assim:

    32 15 * * * /campestre/manda-backup.sh

    editei como root
    se tiver alguma dica mais , agradeço



  5. #5

    Padrão Re: script que nao roda no cron - ajudem por favor

    Monte o script, de permissao de execução e coloque ele no diretório /etc/cron.daily

  6. #6
    luciano555
    Visitante

    Padrão Re: script que nao roda no cron - ajudem por favor

    Citação Postado originalmente por Skorpyon
    Monte o script, de permissao de execução e coloque ele no diretório /etc/cron.daily
    Ok amigo, fiz istomas nao roda automaticamente. usei o chmod -x e nada. nos logs do cron, ele executa mas nao roda.
    obrigdo se tiver mais alguma dica.



  7. #7

    Padrão Re: script que nao roda no cron - ajudem por favor

    Tava vendo seu script Luciano, e vc tem dois scripts. Tem um que compacta o que vc precisa para o backup e tem um outro que é chamado no final pra mandar por ftp o backup.
    Esse script ftp-backup-diario.sh tá com permissão de execução?

  8. #8

    Padrão Re: script que nao roda no cron - ajudem por favor

    Citação Postado originalmente por luciano555
    usei o chmod -x e nada.
    -x TIRA permissão de execução

    =/



  9. #9
    luciano555
    Visitante

    Padrão Re: script que nao roda no cron - ajudem por favor

    Citação Postado originalmente por Skorpyon
    Citação Postado originalmente por luciano555
    usei o chmod -x e nada.
    -x TIRA permissão de execução

    =/
    um erro absurdo mas foi cometido. obrigado era permissão mesmo.
    obrigado aos amigos que deram as dicas