+ Responder ao Tópico



  1. #1

    Padrão MRTG

    Bom pessoal estou com o seguinte problema, ja fiz de tudo mas não funciona. Tem em meu firewall o mrtg funcionando perfeitamente, so que agora quero monitorar a interface wlan dos meus ap´s. bem no firewall monitoro a eth0 perfeitamente so que a saida para o star-os e a eth1 até ai tudo bem, crio o arquivo de configuração com o comando cfgmaker [email protected] > /etc/mrtg/aptv.cfg e gera um arquivo .cfg. depois edito o arquivo com o wordir e tudo mais, quando crio o indice, tudo bem indexmaker /etc/mrtg/aptv.cfg > /var/www/html/mrtg/aptv.html e novamente tudo bem e quando coloco o mrtg para rodar mrtg /etc/mrtg/aptv.cfg também normal, so que quando faz a leitura tudo zerado, e vejo que ele tenta fazer o monitoramento, pois a cada momento que entro no grafico, ele mostra um horario diferente.

  2. #2

    Padrão Re: MRTG

    o snmp do seu staros aparece ativado ??




  3. #3

    Padrão Re: MRTG

    Citação Postado originalmente por Alexandre Correa
    o snmp do seu staros aparece ativado ??

    sim está ativado, não sei o que pode estar acontecendo, não consigo fazer a leitura o grafico sempre está zerado. Aqui no firewall como disse faço a leitura da eth0 =201.59.x.xxx e a que sai para o staros e a 10.10.10.2 (feita a rota com o comando route, pois este e um ip invalido e nos ap´s staros os ips sao validos route add -net 200.222.6.xxx netmask 255.255.255.128 gw 10.10.10.2), onde os ips dos staros são 200.222.6.xxx (que estão em morros distintos se comunicando com um staros no predio com ip 200.222.6.xxx e neste sai para a eth 10.10.10.2)
    ou seja
    firewall
    eth0 = 201.59.x.xxx
    eth1 = 10.10.10.1
    staros predio
    eth = 10.10.10.2
    wlan = 200.222.x.xxx

    staros morro1
    wlan1 = 200.222.x.xxx

    staros morro2
    wlan0 = 200.222.x.xxx
    e em todos os ap's o snmp está ativado
    por favor ajudem

  4. #4

    Padrão Re: MRTG

    Primeiramente, voce nao precisa usar ip valido em seus access points..

    vc pode usar um ip de outra classe (ateh mais seguro)...

    seu staros esta em bridge ?



  5. #5

    Padrão Re: MRTG

    Citação Postado originalmente por Alexandre Correa
    Primeiramente, voce nao precisa usar ip valido em seus access points..

    vc pode usar um ip de outra classe (ateh mais seguro)...

    seu staros esta em bridge ?
    Sim estão em bridge
    ap predio 2 cartões pcmcia (wds ambos e um com ip válido 200.222.x.xxx)
    ap morro1 (3 cartões pcmcia -wlan0 em modo ap, wlan1 em wds com o predio e wlan2 como ap)
    ap morro2 (mesma característica co ap morro 1 so que o wlan0 em wds e os outros 2 como ap's)

  6. #6

    Padrão Re: MRTG

    nao precisa de colocar ip valido nao..

    pega uma classe de ip diferente das que vc usa me clientes... e usa em seus aps...

    ai no servidor vc sobe um ip dessa classe..

    ip na bridge serve soh pra vc acessar ela.. nao tem outra utilizada

    pra funcionar o mrtg... tenta usar o snmpwalk pra ver se ele ta pegano os dados.. tenta ssim:


    snmpwalk -v2c -c public <ip do staros>

    ele tem q aparece um monteeeeeeeee de dados ...



  7. #7

    Padrão Re: MRTG

    Citação Postado originalmente por Alexandre Correa
    nao precisa de colocar ip valido nao..

    pega uma classe de ip diferente das que vc usa me clientes... e usa em seus aps...

    ai no servidor vc sobe um ip dessa classe..

    ip na bridge serve soh pra vc acessar ela.. nao tem outra utilizada

    pra funcionar o mrtg... tenta usar o snmpwalk pra ver se ele ta pegano os dados.. tenta ssim:


    snmpwalk -v2c -c public <ip do staros>

    ele tem q aparece um monteeeeeeeee de dados ...
    então como bridge não funciona? deveria, pois um adaptador tem um endereço, seja valido ou invalido, e estou tentando capturar o adaptador que se comunica com o provedor, estranho, vou procurar o snmpwlak e ver o resultado obrigado

  8. #8

    Padrão Re: MRTG

    Citação Postado originalmente por igorallan
    Bom pessoal estou com o seguinte problema, ja fiz de tudo mas não funciona. Tem em meu firewall o mrtg funcionando perfeitamente, so que agora quero monitorar a interface wlan dos meus ap´s. bem no firewall monitoro a eth0 perfeitamente so que a saida para o star-os e a eth1 até ai tudo bem, crio o arquivo de configuração com o comando cfgmaker [email protected] > /etc/mrtg/aptv.cfg e gera um arquivo .cfg. depois edito o arquivo com o wordir e tudo mais, quando crio o indice, tudo bem indexmaker /etc/mrtg/aptv.cfg > /var/www/html/mrtg/aptv.html e novamente tudo bem e quando coloco o mrtg para rodar mrtg /etc/mrtg/aptv.cfg também normal, so que quando faz a leitura tudo zerado, e vejo que ele tenta fazer o monitoramento, pois a cada momento que entro no grafico, ele mostra um horario diferente.
    Igor,

    Você está usando o modo mais rudimentar de MRTG possível. Para podermos te ajudar faça o seguinte:

    #cfgmaker [comunidade]@[endereço do ap] > /root/mrtg.cfg

    Depois disso copia esse arquivo (o conteúdo dele e posta ele aqui). Se quiser mande ele pro seu email para facilitar o recortar e colocar:

    #mail [[email protected]] < /root/mrtg.cfg



  9. #9

    Padrão Re: MRTG

    Citação Postado originalmente por nataniel
    Citação Postado originalmente por igorallan
    Bom pessoal estou com o seguinte problema, ja fiz de tudo mas não funciona. Tem em meu firewall o mrtg funcionando perfeitamente, so que agora quero monitorar a interface wlan dos meus ap´s. bem no firewall monitoro a eth0 perfeitamente so que a saida para o star-os e a eth1 até ai tudo bem, crio o arquivo de configuração com o comando cfgmaker [email protected] > /etc/mrtg/aptv.cfg e gera um arquivo .cfg. depois edito o arquivo com o wordir e tudo mais, quando crio o indice, tudo bem indexmaker /etc/mrtg/aptv.cfg > /var/www/html/mrtg/aptv.html e novamente tudo bem e quando coloco o mrtg para rodar mrtg /etc/mrtg/aptv.cfg também normal, so que quando faz a leitura tudo zerado, e vejo que ele tenta fazer o monitoramento, pois a cada momento que entro no grafico, ele mostra um horario diferente.
    Igor,

    Você está usando o modo mais rudimentar de MRTG possível. Para podermos te ajudar faça o seguinte:

    #cfgmaker [comunidade]@[endereço do ap] > /root/mrtg.cfg

    Depois disso copia esse arquivo (o conteúdo dele e posta ele aqui). Se quiser mande ele pro seu email para facilitar o recortar e colocar:

    #mail [[email protected]] < /root/mrtg.cfg
    criou apenas isso

    # Created by
    # /usr/bin/cfgmaker [email protected]


    ### Global Config Options

    # for UNIX
    # WorkDir: /home/http/mrtg

    # or for NT
    # WorkDir: c:\mrtgdata

    ### Global Defaults

    # to get bits instead of bytes and graphs growing to the right
    # Options[_]: growright, bits


    ######################################################################
    # System:
    # Description:
    # Contact:
    # Location:
    ######################################################################


    achei muito estranho, Nataniel, se puder me ajudar

  10. #10

    Padrão Re: MRTG

    igor,

    Deve ter dado algum tipo de erro no inicio dessa criação. Faça o mesmo comando da seguinte maneira:

    Código :
    #cfgmaker [comunidade]@[endereço do ap] &> /root/mrtg.cfg

    Dai posta aqui o resultado.



  11. #11

    Padrão Re: MRTG

    Citação Postado originalmente por nataniel
    igor,

    Deve ter dado algum tipo de erro no inicio dessa criação. Faça o mesmo comando da seguinte maneira:

    Código :
    #cfgmaker [comunidade]@[endereço do ap] &> /root/mrtg.cfg

    Dai posta aqui o resultado.
    Nada a mesma coisa, criei o arquivo com o
    cfgmaker [email protected] --output /root/mrtg.cfg
    cfgmaker [email protected] &> /root/mrtg.cfg
    mas do mesmo jeito, será que meu mrtg ta com algum erro? não conheço de mrtg, trabalho apenas com o firewall, mas o achei bem simples, so que nada, todos os arquivos .cfg com que trabalho, so cria o que postei

  12. #12

    Padrão Re: MRTG

    eu acho que seu snmp do staros nao esta habilitado !!