+ Responder ao Tópico



  1. #1

    Padrão Instalação Spamassassin [RESOLVIDO]

    pessoal, estou aqui configurando o spamassassin.
    estou instalando os ou pelo menos tentando os modulos do perl

    perl -MCPAN -e 'install DB_File' -> FOI OK
    perl -MCPAN -e 'install Digest::SHA1' -> NAO OK
    perl -MCPAN -e 'install Digest::HMAC'
    perl -MCPAN -e 'install Net:NS'
    perl -MCPAN -e 'install Time::HiRes'
    perl -MCPAN -e 'install HTML::Tagset'
    perl -MCPAN -e 'install HTML::Parser'
    Como não instalou fui fazer na mão. Baixei o pacote do site
    http://search.cpan.org/
    e rodei o perl Makefile.PL foi. quando mandei rodar make deu erro

    /usr/src/qmailsource/pkg_perl# cd Digest-SHA1-2.11
    [email protected]:/usr/src/qmailsource/pkg_perl/Digest-SHA1-2.11# ls
    Changes MANIFEST Makefile.PL README SHA1.pm SHA1.xs fip180-1.gif fip180-1.html t/ typemap
    [email protected]:/usr/src/qmailsource/pkg_perl/Digest-SHA1-2.11# perl Makefile.PL
    Checking if your kit is complete...
    Looks good
    Writing Makefile for Digest::SHA1
    [email protected]:/usr/src/qmailsource/pkg_perl/Digest-SHA1-2.11# make
    cp SHA1.pm blib/lib/Digest/SHA1.pm
    /usr/bin/perl5.8.8 /usr/lib/perl5/5.8.8/ExtUtils/xsubpp -typemap /usr/lib/perl5/5.8.8/ExtUtils/typemap -typemap typemap SHA1.xs > SHA1.xsc && mv SHA1.xsc SHA1.c
    cc -c -fno-strict-aliasing -pipe -Wdeclaration-after-statement -I/usr/local/include -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -O2 -march=i486 -mtune=i686 -DVERSION=\"2.11\" -DXS_VERSION=\"2.11\" -fPIC "-I/usr/lib/perl5/5.8.8/i486-linux/CORE" SHA1.c
    cc1: error: invalid option `tune=i686'
    cc1: error: unrecognized option `-Wdeclaration-after-statement'
    make: *** [SHA1.o] Error 1

  2. #2

    Padrão Re: Instalação Spamassassin

    Kra baixa o SHA1, http://www.cpan.org/modules/by-modul...SHA-1.0.tar.gz, e instala na mão, depois tenta instalar denovo o outro.


    ATT



  3. #3

    Padrão Re: Instalação Spamassassin

    E ai Leonardo.
    ja tentei e da o mesmo problema.

    No aguardo.;

  4. #4

    Padrão Re: Instalação Spamassassin

    Qual a distro q ta usando?



  5. #5

    Padrão Re: Instalação Spamassassin

    Uso slackware.
    e ja tentei com o
    slackpkg, slapt-get, swaret e não vai.

  6. #6



  7. #7

    Padrão Re: Instalação Spamassassin

    Citação Postado originalmente por spyderlinux
    pessoal, estou aqui configurando o spamassassin.
    estou instalando os ou pelo menos tentando os modulos do perl

    perl -MCPAN -e 'install DB_File' -> FOI OK
    perl -MCPAN -e 'install Digest::SHA1' -> NAO OK
    perl -MCPAN -e 'install Digest::HMAC'
    perl -MCPAN -e 'install Net:NS'
    perl -MCPAN -e 'install Time::HiRes'
    perl -MCPAN -e 'install HTML::Tagset'
    perl -MCPAN -e 'install HTML::Parser'
    Como não instalou fui fazer na mão. Baixei o pacote do site
    http://search.cpan.org/
    e rodei o perl Makefile.PL foi. quando mandei rodar make deu erro

    /usr/src/qmailsource/pkg_perl# cd Digest-SHA1-2.11
    [email protected]:/usr/src/qmailsource/pkg_perl/Digest-SHA1-2.11# ls
    Changes MANIFEST Makefile.PL README SHA1.pm SHA1.xs fip180-1.gif fip180-1.html t/ typemap
    [email protected]:/usr/src/qmailsource/pkg_perl/Digest-SHA1-2.11# perl Makefile.PL
    Checking if your kit is complete...
    Looks good
    Writing Makefile for Digest::SHA1
    [email protected]:/usr/src/qmailsource/pkg_perl/Digest-SHA1-2.11# make
    cp SHA1.pm blib/lib/Digest/SHA1.pm
    /usr/bin/perl5.8.8 /usr/lib/perl5/5.8.8/ExtUtils/xsubpp -typemap /usr/lib/perl5/5.8.8/ExtUtils/typemap -typemap typemap SHA1.xs > SHA1.xsc && mv SHA1.xsc SHA1.c
    cc -c -fno-strict-aliasing -pipe -Wdeclaration-after-statement -I/usr/local/include -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -O2 -march=i486 -mtune=i686 -DVERSION=\"2.11\" -DXS_VERSION=\"2.11\" -fPIC "-I/usr/lib/perl5/5.8.8/i486-linux/CORE" SHA1.c
    cc1: error: invalid option `tune=i686'
    cc1: error: unrecognized option `-Wdeclaration-after-statement'
    make: *** [SHA1.o] Error 1

    Esse erro acima.
    Atualizei gcc num adiantou.

  8. #8



  9. #9

  10. #10
    Super_Diaulas
    Visitante

    Padrão Re: Instalação Spamassassin

    rpm???
    acho q não vai ajudar não

    seguinte veja se no Makefile o path para o sha1 tá errado
    tenta instalar ele pelo mcpan
    qual erro q deu no mcpan?



  11. #11

    Padrão Re: Instalação Spamassassin

    Seguinte.
    Removi o perl.
    O problema dava tanto tentando instalar na mão compilando quanto usando o MCPAN

    Então removi o perl.
    Fiz um locate perl e removi tudo que usava o perl.
    updatedb && ldconfig
    instalei novamente mas usando o slapt-get

    Depois de instalar usei ele tb para instalar o spamassassin

    slapt-get --search spamassassin

    ele achou e instalou. Deu uma mensagem de erro.
    E quando eu fui ver se o pacote estava instalado.

    ls -l /var/log/packages/spam
    constava ou seja, vamos remover e tentar novamente

    Quando fiz novamente a instalação do spamassassin e iniciei o mesmo funcionou.


    Agradeço a ajuda de todos.
    Valeu mesmo

  12. #12
    Super_Diaulas
    Visitante

    Padrão Re: Instalação Spamassassin [RESOLVIDO]

    o mais legal foi vc ter postado a solução